WordPress.org

Ready to get started?Download WordPress

Forums

  1. GlobalVagabond
    Member
    Posted 1 year ago #

    In some cases I'm having trouble posting links to my website on my facebook page which contain youtube videos. It's not always showing the proper video preview, or finding the right one. I'm also wondering if there's just a way to turn that off. I want to force people to go to my website instead of just the FB page (Cuz I'm a jerk :P). Open Graph has improved my ability to share pictures from Nextgen but it's not showing the proper picture preview either. The only thing that's better is that it goes to the specific photo, as opposed to the whole album.

    Thanks,
    ~GlobalVagabond

    http://wordpress.org/extend/plugins/nextgen-facebook/

  2. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    You'll need to provide sample URLs.

    Thanks,

    js.

  3. simonsix
    Member
    Posted 1 year ago #

    Having the same problem with posts over facebook containing youtube videos.
    latley it started showing the video link insted of an image (thumbnail).
    and i dont want people to watch videos, i want them to visit my website.

    i also installed the last DEV version. it didn't helped.

    Simon
    Gamepro

  4. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Do you have the URL to a post with a video?

    Thanks,

    js.

  5. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Never mind, I used this one:

    http://gamepro.co.il/2013/04/29/microsofts-illumiroom-could-be-use-on-next-xbox/

    The Open Graph tags appear to be correct:

    <!-- og:image:1 --><meta property="og:image" content="http://gamepro.co.il/wp-content/uploads/2013/04/Microsoft-Illumiroom-720-300x159.jpg" />
    <!-- og:image:1 --><meta property="og:image:height" content="159" />
    <!-- og:image:1 --><meta property="og:image:width" content="300" />
    
    <!-- og:video:1 --><meta property="og:image" content="http://img.youtube.com/vi/nGGMv9RnJIA/0.jpg" />
    <!-- og:video:1 --><meta property="og:video" content="http://www.youtube.com/v/nGGMv9RnJIA" />
    <!-- og:video:1 --><meta property="og:video:height" content="349" />
    <!-- og:video:1 --><meta property="og:video:type" content="application/x-shockwave-flash" />
    <!-- og:video:1 --><meta property="og:video:width" content="620" />

    What Facebook decides to with that information is up to Facebook. Apparently they prefer to embed the video for viewing directly on Facebook.

    If you prefer NOT to include the og:video info, then you can set "Maximum Number of Videos" to "0" or un-check the og:video tags from the "Meta Tag List".

    js.

  6. simonsix
    Member
    Posted 1 year ago #

    OK, trying the "Maximum Number of Videos" to "0" now.
    Working now! thanks man

    Edit: after a couple of minutes, the thumbnail turned into a video link.
    Check my last "Watch Dogs" DOUBLE POST HERE

  7. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Do you mean for this URL? http://gamepro.co.il/2013/04/29/watch-dogs-november-21-release-date/

    If you do a View Source, you'll that video tags are still being added:

    <!-- og:video:1 --><meta property="og:image" content="http://img.youtube.com/vi/5DHFVi0Y8dg/0.jpg" />
    <!-- og:video:1 --><meta property="og:video" content="http://www.youtube.com/v/5DHFVi0Y8dg" />
    <!-- og:video:1 --><meta property="og:video:height" content="349" />
    <!-- og:video:1 --><meta property="og:video:type" content="application/x-shockwave-flash" />
    <!-- og:video:1 --><meta property="og:video:width" content="620" />

    Do you have any full-page caching plugins enabled? You might need to flush their cache.

    If you set "Maximum Number of Videos" to "0" in the NGFB options, those og:video tags should disappear.

    js.

  8. simonsix
    Member
    Posted 1 year ago #

    How do i flush their cache? i'm n00b with wordpress.
    i did set "Maximum Number of Videos" to "0".
    do i need to do anything else?

  9. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Turn on debug mode (checkbox option on the bottom of the NGFB settings page), and I'll have a look.

    Thanks,

    js.

  10. GlobalVagabond
    Member
    Posted 1 year ago #

    I changed the settings as recommended. The video links are working as I want them now. I appreciate the help on that one! :)

    But for Nextgen Gallery the correct photo is not being previewed on FB. It only picks up the first 3 or 4 photos. It does link to the correct photo in the gallery though, which is great, because it didn't do that before I downloaded Open Graph. Should I just change the number of photos to something higher to have more options for thumbnails? I wish there was a better solution because my plan is to have albums with hundreds of photos and I don't want to click through the whole album. Hope that makes sense.

    Thanks,
    ~ GlobalVagabond

  11. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    If you only want one photo, set the Maximum Number of Images to 1, then choose a featured image for each post.

    js.

  12. GlobalVagabond
    Member
    Posted 1 year ago #

    How do I pick a featured image from Nextgen Facebook? Looks like the 'Maximum Number of Images' is already set to 1. I haven't changed it from the default. Right now Facebook is picking up the header image, the first image in the album, and some of the ads on my page, but not the image within the album.

  13. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry for the late reply - just click on the "Add Media" button when editing a Post or Page. Select an image from a NextGEN Gallery, then click on "Use as featured image".

    js.

  14. GlobalVagabond
    Member
    Posted 1 year ago #

    No problem. I know how to set a feature images for blog posts. I'm talking about photos from the gallery. I want to share memes from there to my FB page to get a lot more views to the site. It will link to the correct image, which is didn't do before downloading your awesome plugin for Nextgen, but it still isn't showing the proper preview. Should I turn off the image meta tags like I did with the video? I'm not sure that would help.

  15. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry, but I don't know what you mean. Could you give me an example with URLs etc.?

    Thanks,

    js.

  16. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    GlobalVagabond,

    I think we just had a problem with the language... My guess if that you would like to use the PREVIEW IMAGE defined in NextGEN Gallery for albums and galleries, correct?

    I've just finished adding support for PREVIEW IMAGES in NGFB. Please download and install the latest DEV version from http://downloads.wordpress.org/plugin/nextgen-facebook.zip.

    That *should* do the trick. ;-)

    The changes in the current DEV version are:

    * Added support for NextGEN Gallery preview images for [nggallery] and [nggalbum] (aka [album]) shortcodes.

    * Added an ngfbPlugin::fix_relative_url() method to filter and fix relative URLs in all og:image property tags, not just those from content text (as relative URLs may also come from unexpected sources, like the wp_get_attachment_image_src() function).

    Thanks,

    js.

  17. GlobalVagabond
    Member
    Posted 1 year ago #

    I just updated the Open Graph plugin through WordPress. I'm going to attempt to stop using the word preview if I can help it...

    All I want is to be able to share an image from Nextgen Gallery on my Facebook page. This would be REALLY helpful to get more people to my site. That's all I care about.

    Since downloading your plugin I can link to a specific image (which is great!) in the gallery but it DOES NOT show the correct image on Facebook. Does that make sense? Instead it shows my website's logo on Facebook.

    I think the word I should have been using was "thumbnail" for Facebook, not "Preview."

    Again, I really appreciate you trying to help me out.

  18. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    GlobalVagabond,

    Please provide an example URL to a page you want to share on Facebook.

    Thanks,

    js.

  19. GlobalVagabond
    Member
    Posted 1 year ago #

  20. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Aahhhhh... Now I get it.

    Let me work on this and get back to you.

    Thanks,

    js.

  21. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    GlobalVagabond,

    Ok. Download and install the latest dev version from http://downloads.wordpress.org/plugin/nextgen-facebook.zip.

    Let me know if that fixes your issue. ;-)

    Thanks,

    js.

  22. GlobalVagabond
    Member
    Posted 1 year ago #

    Still not working for me. Is the problem that each image needs its own URL? That would make sense to me. Atm, the only options for the thumbnail on FB are the first image of the gallery.

  23. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Looks good to me, though you may want to enter something in the post/page Excerpt for the OG description. Odd that there's no image height listed. If you turn on debug mode, I can have a look at that.

    <!-- NextGEN Facebook Open Graph (NGFB) meta tags BEGIN -->
    <link rel="author" href="http://www.randpaulreview.com/author/libertyninja/" />
    <meta name="description" content="[Show as slideshow] &nbsp; &nbsp;" />
    <meta property="article:author" content="http://www.randpaulreview.com/author/libertyninja/" />
    <meta property="article:modified_time" content="2013-05-03T16:43:00+00:00" />
    <meta property="article:published_time" content="2012-04-09T15:46:59+00:00" />
    <meta property="og:description" content="[Show as slideshow] &nbsp; &nbsp;" />
    <!-- og:image:1 --><meta property="og:image" content="http://www.randpaulreview.com/wp-content/gallery/cache/250__300x300_clhirzwj.png" />
    <!-- og:image:1 --><meta property="og:image:width" content="300" />
    <meta property="og:site_name" content="Rand Paul Review" />
    <meta property="og:title" content="Rand Paul Review | LibertyGallery" />
    <meta property="og:type" content="article" />
    <meta property="og:url" content="http://www.randpaulreview.com/libertygallery/?album=1&gallery=4" />
    <!-- NextGEN Facebook Open Graph (NGFB) meta tags END -->

    From the FAQ:

    Q. How does NGFB find images to include in the Open Graph meta tags?

    A. The images used in the Open Graph meta property tags for Posts and Pages are chosen in this sequence:

    1. A featured or attached image from a NextGEN Gallery or WordPress Media Library.
    2. A preview image from a NextGEN Gallery [nggalbum] or [nggallery] shortcode.
    3. Image(s) from NextGEN Gallery [singlepic], [nggallery] or [nggtags] shortcodes.
    4. Image(s) from <img/> HTML tags in the Post or Page content text.
    5. A default image defined in the NGFB plugin settings.

    js.

  24. GlobalVagabond
    Member
    Posted 1 year ago #

    Man, unfortunately I don't really know what any of that means. LOL.

    I checked the setting "The gallery will open the ImageBrowser instead the effect" and now the images have there own URLs. NOW I can post to Facebook and it shows the proper thumbnail. I think this will just have to do for now.

    Thanks for the help. The tips on the video links were really helpful.

  25. JS Morisset
    Member
    Plugin Author

    Posted 1 year ago #

    Good call on the ImageBrowser -- I'll have to mention that in the FAQ. ;-)

    Download and install the latest DEV version again from http://downloads.wordpress.org/plugin/nextgen-facebook.zip -- I added better support for the ImageBrowser. ;-)

    js.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.