WordPress.org

Ready to get started?Download WordPress

Forums

Facebook thumbnails not showing up when sharing link (9 posts)

  1. cmannering
    Member
    Posted 4 years ago #

    My site is scrink.com and when I share a link to my fan page the thumbnail isn't showing up. It initially was, but now when I share a link I only get the description. Sometimes I see the thumbnail but when I actually push "share" and it submits, the thumbnail disappears. Please help.

    http://www.facebook.com/pages/Scrink-Bring-Me-Up/211534253105

    http://www.scrink.com

  2. cmannering
    Member
    Posted 4 years ago #

    No replies yet? Anybody? Bueler? Beuler?

  3. taydigga
    Member
    Posted 4 years ago #

    did you ever figure this out? I'm having same problem

  4. archetypemkt
    Member
    Posted 3 years ago #

    Me too. Works on some of my wordpress blogs but the latest one for client not working.

    I've also installed a link rel for an image that should be used when there are no images on the page (works for several of my wordpress blogs).

    If anyone has any ideas that would be great.

  5. okuogren
    Member
    Posted 3 years ago #

    i have the same issue, not with all posts but some doesn't show image when sharing on facebook

  6. archetypemkt
    Member
    Posted 3 years ago #

    This is really a bummer. I have a new client site that I've added the <link rel> to the header.php file as well as installed All In One SEO pack thinking adding the extra meta-tags there would help as well and I'm still not able to get the shares to work with an image or even the page description event though in the source code I can see it there.

    I hope someone has a solution for this. I would prefer not to downgrade to WP 8 but this is a pretty big deal.

  7. hunt4freebies
    Member
    Posted 3 years ago #

    Hi all I was having the same problem with my thumbnails not showing on my Facebook Fan Page and I have been troubleshooting this issue for over a week now.
    My problem is that if I did not cache my RSS feed in WP Super Cache or W3 Total Cache I noticed the thumbnails would not post to facebook...once I started caching my RSS feed it all works great now :) :)

    I hope this help...

    Michele

  8. drinkinsomejava
    Member
    Posted 3 years ago #

    Just an open question...Any1 using the Facebook meta info? I've read a few articles on adding it to the header.php file in the blog.I've also added the Like plugin but this still gives me weird results. I'm looking for a working solution so that a thumbnail preview in Facebook will only populate an image from that post. So far I'm still looking for an answer :/

  9. realitystars
    Member
    Posted 3 years ago #

    I was having the same problem and this worked for me.

    I removed the 'http://www.' in front of the link as well as the '/' at the end of the link. It then showed the thumbnail. Hope this helps!

Topic Closed

This topic has been closed to new replies.

About this Topic