WordPress.org

Ready to get started?Download WordPress

Forums

WP Facebook Open Graph protocol
[resolved] Facebook sharing still doesn't work (11 posts)

  1. maschera
    Member
    Posted 6 months ago #

    Ok, first of all thanks Chuck for making this plugin available for free, and for offering support too. Big kudos!

    I installed the plugin and it works like a charm on Linkedin and Twitter, but it doesn't really want to work on Facebook.

    I've inserted my numeric user ID (no APP ID) but no luck.

    Is there a technical time to wait before it starts working on Facebook?

    Thanks a bunch,
    Maschera

    http://wordpress.org/plugins/wp-facebook-open-graph-protocol/

  2. Chuck Reynolds
    Member
    Plugin Author

    Posted 6 months ago #

    did you try the debugger? it'll clear cache on FB for your urls.
    without a link to view-source i can't help too much. make sure there aren't any more OG: tags being input in your source from other plugins or anything

  3. uvray90
    Member
    Posted 3 months ago #

    Hi Chuck.

    I have a site page here http://padiyottuchal.com/?p=954 I read all the forums and banged my head over it. For most of the posts it takes the featured image for the Facebook share option but in rare cases it takes some random image as in this post's case.

    I simply created an APP Id 167800103344347 and put it in the column under settings :( Don't know if that's the thing I am supposed to be doing.

    Please give few clues.

  4. uvray90
    Member
    Posted 3 months ago #

    I read few posts and checked FB debugger which is giving the following

    <meta property="og:image" content="http://padiyottuchal.com/wp-content/uploads/2014/01/jilla.jpg">

    which is the image it should be taking. Am I looking at the right thing?

  5. Chuck Reynolds
    Member
    Plugin Author

    Posted 3 months ago #

    View your source - I can see that another plugin is also adding OG: tags.

    You need to not allow that plugin to do that. Facebook only needs/wants one set. The other one is messing it up.

  6. uvray90
    Member
    Posted 3 months ago #

    Hi Chuck,

    I got rid of one set of OG: tags but I am still getting problem.

    http://padiyottuchal.com/?p=1148

    FB is pulling some other image telling that the size is wrong :(

    FB debugger for this URL

    Any ways to force FB to use featured image?

    Thanks

  7. Chuck Reynolds
    Member
    Plugin Author

    Posted 3 months ago #

    well what I'm seeing in your source now isn't from my plugin so I can't help with that. My plugin doesn't add author: info or twitter card stuff..

    DB debugger is also saying "fb:admins and fb:app_id tags are missing.".

  8. sandeep c v
    Member
    Posted 3 months ago #

    http://padiyottuchal.com/wp-content/uploads/2014/01/b.png

    Now i have removed all other plugins, and using your plugin,
    Please help me , how to configure the same. have provided the screen shot in that link

  9. sandeep c v
    Member
    Posted 3 months ago #

    Hi chuck Pl help to solve the fb sharing issue

  10. sandeep c v
    Member
    Posted 3 months ago #

  11. @sandeep c v Per the forum welcome please post your own topic.

    http://wordpress.org/support/plugin/wp-facebook-open-graph-protocol#postform

    This topic is marked "resolved" and may not have anything to do with your problem.

    Edit: Actually I see that you're the same user using a different account. Why...?

    Please do not do that. Pick one account and stick with it.

Reply

You must log in to post.

About this Plugin

About this Topic