WordPress.org

Ready to get started?Download WordPress

Forums

Facebook Page Publish
Facebook returned an unexpected error: (#1500) The url you supplied is invalid (50 posts)

  1. rdl419
    Member
    Posted 1 year ago #

    Everything set up fine, but when I try to post I get this message from the settings page.

    Facebook returned an unexpected error: (#1500) The url you supplied is invalid
    Try to resolve this issue, update the plugin or inform the author about the problem.
    [Error occured at line 350]

    Any suggestions??

    Thank you

    http://wordpress.org/extend/plugins/facebook-page-publish/

  2. ConquerorTravel
    Member
    Posted 1 year ago #

    I have exactly the same problem, so it looks there is a bug. Please fix it.
    Thanks!

  3. kostas1986
    Member
    Posted 1 year ago #

    same error here. Pls find a solution. Will be happry to here a fix soon. Chears!!!!!

  4. fjellreven
    Member
    Posted 1 year ago #

    Same error here.. Need solution asap :)

    Thanks

    [No bumping. If it's that urgent, consider hiring someone. Or try posting your own topic instead of tagging onto someone else's.]

  5. LordOfChaosPT
    Member
    Posted 1 year ago #

    Yeah, same thing here... It was working perfectly until now... So I guess something changes in Facebook...

  6. alexdamiao
    Member
    Posted 1 year ago #

    same problem here..
    this is boring..

    if you go to the plugin settings, came back to post and click "Refresh", the plugin publish in the facebook

  7. fjellreven
    Member
    Posted 1 year ago #

    same problem here..
    this is boring..

    if you go to the plugin settings, came back to post and click "Refresh", the plugin publish in the facebook

    The same here. So the problem need to be in the script

  8. Jackson
    Member
    Posted 1 year ago #

    I am seeing this issue as well. 3.5.1 with latest version of plugin.

  9. eggsyntax
    Member
    Posted 1 year ago #

    Yep, same problem here, 3.5.1 and latest plugin.

  10. alexdamiao
    Member
    Posted 1 year ago #

    the same version here...

    and I also believe that the problem could be the script...

  11. fjellreven
    Member
    Posted 1 year ago #

    Try reinstall, now i got this error:

    Facebook returned an error: Invalid application ID. Please refer to the detailed setup instructions.
    [Error occured at line 1080]

    Your connection options could not be validated.

  12. alexdamiao
    Member
    Posted 1 year ago #

    serious????

    OMG!!! I will waiting for the plugin update..

    lol

  13. fjellreven
    Member
    Posted 1 year ago #

    For now I taken "Jetpack by WordPress" in use. This has the same function.

  14. kostas1986
    Member
    Posted 1 year ago #

    Try to create a new app to facebook as the one you had before and change the apps id and secret with the one you created now at faceook page publish settings to your admin panel. That fixed it 4 me.

  15. Sba Nyft
    Member
    Posted 1 year ago #

    Same problem here, tried the kostas1986 suggestion but it didn't fix. Umh, I realize that without this plugin it's a hard life, as well as in the stone age.

  16. nimmis
    Member
    Posted 1 year ago #

    For me this worked:
    After publishing and getting the error, press Update with Publish on Facebook checked and the article is published

  17. alexdamiao
    Member
    Posted 1 year ago #

    nimmis, this work, I know..

    but this is not a correct way to work the plugin..

  18. fjellreven
    Member
    Posted 1 year ago #

    I got this message today:
    That plugin is no longer being kept up to date in the repository as versions of WordPress change.

  19. lesorsier
    Member
    Posted 1 year ago #

    I have (#1500) The url you supplied is invalid too :(((

    I tried to change lot of options, post as link, as blog, etc... but I always got this error... as someone mention before, it works when you do the update... but it is completely out of use for scheduled posts...

    HEEEELP :(

  20. nimmis
    Member
    Posted 1 year ago #

    alexdamiao, sorry missed that you already said that, and yes this should be fixed thats only a workaround

  21. tobalsan
    Member
    Posted 1 year ago #

    Hello,

    I've found a patched version of the plugin that fixes this issue. You can download it here: http://afterbankruptcyhub.com/facebook-page-publish-2-patch/

  22. eggsyntax
    Member
    Posted 1 year ago #

    ^ Looks sketchy as hell.

  23. alexdamiao
    Member
    Posted 1 year ago #

    someone download this patch? is this ok?

  24. tobalsan
    Member
    Posted 1 year ago #

    nah, i've written too fast out of enthusiasm. The plugin makes you believe everything is ok when configuring it, but it's still not posting on facebook on first publishing (but does when you update post).

    sorry for that

  25. TEGS
    Member
    Posted 1 year ago #

    I've been experiencing the same issue.

    I am wondering if anyone else has a really slow admin area, or had their sites hacked recently...

  26. thejamal
    Member
    Posted 1 year ago #

    I created a bug in facebook regarding this issue (#1500) the url you supplied is invalid
    Please "repro" it and provide your app over there if you are facing the issue. As many developers repro it will make the issue to resolve ASAP.

  27. mixos
    Member
    Posted 1 year ago #

    The same issue here:

    Facebook returned an unexpected error: (#1500) The url you supplied is invalid

    Do we have to create a new app on Facebook? Has anyone tried that?

    Yours
    Mike

  28. peaChic
    Member
    Posted 1 year ago #

    Facebook returned an unexpected error: (#1500) The url you supplied is invalid
    Try to resolve this issue, update the plugin or inform the author about the problem.
    [Error occured at line 350]

    Just got this, too.

  29. eggsyntax
    Member
    Posted 1 year ago #

    Since this hasn't been fixed yet, does anyone know of an alternative plugin that does the same thing? Jetpack will do it, but not very well IMHO.

  30. jurajpuchky
    Member
    Posted 1 year ago #

    Dear,

    had already same issue was recognize fix subjected to issue which is releated to following facebook changes like Stream Post URL Security Migration

    https://developers.facebook.com/roadmap/secure_stream_urls_migration/

    You should be sure that domain and URL is originaly FQN as url which is posted to the Post stream.

    Eg.: My page is located primary and redirected to the http://www.zivot-vecny.cz that means all posts are with following mask http://www.zivot-vecny.cz/*

    Application on facebook should be configured like this:

    App Domains: Only http://www.zivot-vecny.cz
    Access with facebook:

    URL of page: http://www.zivot-vecny.cz

    In any case should be selected with respecting of http or https.

    [links removed]

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic