WordPress.org

Ready to get started?Download WordPress

Forums

Facebook
[resolved] Facebook Publish on post creation (42 posts)

  1. jaydokie
    Member
    Posted 1 year ago #

    It was working nice until I updated the update this morning. Now I am getting the following message when publishing a new post:

    Failed posting to your Facebook Timeline. Error: {"message":"Can only modify connections owned by this application","type":"Exception"}

    Any suggestions? I don't really understand how to do the Open Graph creation thing in FB but it was working until the last update. Thanks.

    http://wordpress.org/extend/plugins/facebook/

  2. Niall Kennedy
    Member
    Plugin Author

    Posted 1 year ago #

    When you view the settings debugger (wp-admin/admin.php?page=facebook-debug) do the permissions appear checked for the author's account?

    Try removing and adding back permissions between your Facebook account and your app. Remove the application from your Facebook account's app settings page then reconnect the account via the Social Publisher settings page in WordPress admin or your edit profile page in WordPress admin.

  3. hlanglais
    Member
    Posted 1 year ago #

    I am now also having this problem. It stopped posting to my timeline before this update though it just wasn't giving me the error. I think it was the last update before 2.0 that messed it up. Also, for some reason I have never been able to get mentions to work including the new search feature for mentions tagging in this new version. Search never happens like on facebook page.

  4. bantonis
    Member
    Posted 1 year ago #

    I am having this problem. After update version 1.2.1 i have this error message "Can only modify connections owned by this application" and when writing messages to "Facebook Status on Your Timeline" i have this error:
    {"message":"Can only modify connections owned by this application","type":"Exception"}.
    Î’efore the upgrade everything worked normally.
    @Niall I have done the settings you say but nothing has been done.

  5. jaydokie
    Member
    Posted 1 year ago #

    I am completely lost. I struggle with the open graph and sdk stuff. I always get hung up because it's not clear on where you add the code. I don't know what file you copy the code from FB for the SDK into except that it says "after <body>. Also, I deactivated Facebook plugin and reactivated and now there's this error:

    Failed posting to your Facebook Timeline. Error: {"message":"Can only modify connections owned by this application","type":"Exception"}

    Sorry but I have struggled to do this for the past 3 months and can't find clear instructions for my level of knowledge. I was hoping to find a plugin that wouldn't require me to do all of this coding and inserting so I could avoid messing up my site worse. Please advise.

  6. semfreak
    Member
    Posted 1 year ago #

    I am having the exact same issue.
    When I post I get: Failed posting to your Facebook Timeline. Error: {"message":"Can only modify connections owned by this application","type":"Exception"}

    I have removed the Facebook plug in. and reinstalled it today. Version 1.2.1

    I can do a curl post to my timeline so I know my app is installed correctly.

    My user un Debug has permissions to post.

  7. jaydokie
    Member
    Posted 1 year ago #

    I don't know what I did, but I got my error to disappear. Sorry but I think I deactivated, deleted and removed the plugin and then downloaded a fresh install and activated. Voila!

  8. tagged
    Member
    Posted 1 year ago #

    I'm getting the same exact error, when I publish a new article :

    Failed posting to your Facebook Timeline. Error: {"message":"Can only modify connections owned by this application","type":"Exception"}

    I have tried completely deleting the plugin and reconfiguring it. I have "people can publish an article" approved in OpenGraph.

    I have version 1.2.2. The debugger pages says the account is connected to facebook and that "Post to Timeline" should work.

    I'm not sure what the issue is?

    Thanks.

  9. hengbokdl7
    Member
    Posted 1 year ago #

    i'm having the exact same problem, any solutions?

  10. jaydokie
    Member
    Posted 1 year ago #

    I just did what I stated in my last post and it's still working. I can't understand how to configure the Open Graph thing in FB so maybe I messed up and accidently did something right. But I made sure the plugin was deleted completed from my domain directory and did a fresh download and install.

  11. semfreak
    Member
    Posted 1 year ago #

    jaydokie, can you do a screen cast of you Open Graph app so I can see if maybe I have an issue there? please contact me I'll through you some love. semfreak at gmail dot com

  12. hlanglais
    Member
    Posted 1 year ago #

    I tried the new version 1.2.2 just released. Deactivated and reactivated the plug in. The debugger says I am connected. I don't see an issue anywhere but yet I am still getting this error.

  13. semfreak
    Member
    Posted 1 year ago #

    hlanglais,
    I ma getting the same thing. I know My app is working. I can go to a ssh prompt on my server and run a curl script and post to the timeline. My publish has even been submitted and approved. This is very strange. I know that it has to be on the WordPress side as I am able to post from my command line using Curl. I was having this problem with 1.2.1 and the latest 1.2.2

    Has anyone checked the dev releases maybe there is a 1.2.3a ?

    -J

  14. semfreak
    Member
    Posted 1 year ago #

    Here is the developer repo on Github.

    https://github.com/facebook/wordpress

    Here is the issue tracking:
    https://github.com/facebook/wordpress/issues

    [ Signature moderated. ]

  15. josh.spurlock
    Member
    Posted 1 year ago #

    I am also having this issue and have no idea how to go about correcting it. I can't seem to find any helpful direction anywhere either.

    These are the two messages I'm getting.

    Failed posting to your Facebook Timeline. Error: {"message":"Can only modify connections owned by this application","type":"Exception"}

    Failed posting to Josh Spurlock, MA, LPC Timeline. Error: {"message":"(#100) link URL is not properly formatted","type":"OAuthException"}

  16. semfreak
    Member
    Posted 1 year ago #

  17. semfreak
    Member
    Posted 1 year ago #

    Josh,
    Follow These instructions all the way down. Should help.
    https://developers.facebook.com/wordpress/
    -J

  18. semfreak
    Member
    Posted 1 year ago #

    This is the direct Link to the developer Build: http://downloads.wordpress.org/plugin/facebook.zip

    This is the direct link to Ver 1.2.2:
    http://downloads.wordpress.org/plugin/facebook.1.2.2.zip

  19. tagged
    Member
    Posted 1 year ago #

    None of the above has worked for me. Same error.

  20. semfreak
    Member
    Posted 1 year ago #

    Same man. This is the suck.. I cannot get any support for this. I am not sure if the issue is that my Open Graph action is wrong or what. I did it just like the tutorial showed. Publish // Article.
    Kinda straight forward.

  21. SteveE71
    Member
    Posted 1 year ago #

    Have been trying to get this to work all day.
    Really doing my head in now, done everything posted here and all i get is
    Failed posting to your Facebook Timeline. Error: {"message":"Can only modify connections owned by this application","type":"Exception"}

  22. tagged
    Member
    Posted 1 year ago #

    Semfreak,

    Mine has been setup and working for months. It only happened when I went up to 1.2.2. I know my opengraph actions are right, yours probably are too, like you said... straight forward.

  23. jaydokie
    Member
    Posted 1 year ago #

    Sorry guys, but I can't figure out how to do a screen shot. The instructions for Mac don't work. But, was thinking and the only thing I did different than before was activate the hosting URL to the herokuapp.com ( which was a free host selection on the FB developer). And then it worked.

  24. Martyr13
    Member
    Posted 1 year ago #

    I'm definitely having this problem too. It's obviously a problem with the plugin, because it was working (more or less) before the update. Before the update, my posts wouldn't publish to my timeline, but at least they would go to my news feed. Now, I just get this error message. This plugin has been nothing but trouble, even when it's "working." I was hoping the bugs would get straightened out by the update, but apparently, they've just gotten worse, and there's no help in sight.

  25. pappan
    Member
    Posted 1 year ago #

    Anyone found a sollution?

    Good to know I'm not the only one experiencing this problem...

  26. timbearcub
    Member
    Posted 1 year ago #

    I'm having this problem too - oddly though the Facebook Page is working fine, it's just the post to my personal timeline is broken.

  27. timbearcub
    Member
    Posted 1 year ago #

    Tried all previous versions back to 1.2 - don't work.

    The fact the app does post to my Page suggests it's the plugin (and it was working before) but previous versions don't now work like they used to, so suggests it's something Facebook's end that's changed.

    My app has been approved upto April for the 'breaking changes' so don't think it's that.

  28. Martyr13
    Member
    Posted 1 year ago #

    Yep timbearcub, both of those are true for me as well. Posts to page, but not to timeline, and now the older versions of the plugin aren't posting to the timeline either.

  29. Mike Shupp
    Member
    Posted 1 year ago #

    Same here... unable to publish at all to my profile timeline, get same error message:

    Failed posting to your Facebook Timeline. Error: {"message":"Can only modify connections owned by this application","type":"Exception"}

    I've tried all the debugging suggestions, have deleted, reinstalled, reauthorized, etc., numerous times. Publishing to a page timeline does work.

  30. timbearcub
    Member
    Posted 1 year ago #

    To jaydokie - how did you get it to work with Heroku? Just setup a new Heroku app and done my first test post - still doesn't work, and of course I can't publish the app until I've done at least one post on the timeline, which it refuses to do gah...

    Did you click 'You have not generated a URL through one of our partners (Get one)' with an existing FB app? I don't want to break the current app...which did work, before.

    I thought it might be my server as I don't have proper HTTPS on my domain (kind of, but it's a different URL which isn't WP friendly) so this ruled that out.

    As per the other one, it still did post to my page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic