WordPress.org

Ready to get started?Download WordPress

Forums

Customizr
Facebook post image (6 posts)

  1. lindseybdc
    Member
    Posted 5 months ago #

    Usually, when I copy a link and paste it into facebook, a featured image shows up.

    However, when I copy a link of mine into facebook, no image appears. Even when I have a featured image set and images in my post. For example: http://www.breastdiagnostic.com/tomatoes-breast-cancer-prevention/

    I have these plug ins installed:
    google analytics
    jetpack
    w3 total cache
    wordfence security
    wordpress seo

    Anyone know how to get my featured images to show up in facebook posts?

    Thanks!

  2. ElectricFeet
    Member
    Posted 5 months ago #

    I don't understand the first two sentences. You say usually it shows when you copy and paste, but then you say it doesn't. What do you mean by "a link of mine" and how does it differ from the first sentence?

  3. acub
    Member
    Posted 5 months ago #

    A look at the linter will give you the answers you're looking for.

    Provided og:image is not big enough. Please use an image that's at least 200x200 px. Image 'http://www.breastdiagnostic.com/wp-content/uploads/2014/01/tomato-in-glass.jpg' will be used instead.

    If your original image should be larger than 200 x 200 either total cache or wordpress seo are messing with what is served to facebook. If it's important for you, you should use a plugin to control the output for facebook (a sharing plugin) like simple share buttons, etc... there are a ton out there.

  4. BitWPThemes
    Member
    Posted 5 months ago #

    As Acub stated, it really depends on the size :)

  5. lindseybdc
    Member
    Posted 5 months ago #

    Thanks everyone!

    to clarify for @electricfeet
    If I were to copy and paste foodnetwork.com (as an example) a featured image pops up in facebook. However, when I put my own website's page urls, nothing appeared.

    But, thanks to @acub for the advise- I now am looking at the size of the image. When I changed the size of the image within the post to over 200 x 200, it pulled up that image and the "feature image" perfectly.

    However, the home page http://www.breastdiagnostic.com, still does not pull up a feature image or anything. I have a featured image set on my page. Any help with that?

    Thanks!

  6. ElectricFeet
    Member
    Posted 5 months ago #

    I'm seeing 3 perfect featured images (well, nearly perfect: the last one needs cropping to be 270x250 so that the sides don't get cropped)

Reply

You must log in to post.

About this Theme

About this Topic