WordPress.org

Ready to get started?Download WordPress

Forums

Facebook Meta trouble after .htaccess 301 redirect (1 post)

  1. vickistep
    Member
    Posted 2 years ago #

    Hello. I had trouble with permission settings on the root folder so my wordpress installation lives in a subdirectory /home (http://www.chrislaughter.com/home). I did a 301 redirect via the .htaccess file so that my site appears as http://www.chrislaughter.com. Everything works wonderfully so far...

    Until someone wants to share the url http://www.chrislaughter.com on Facebook. None of the meta is appearing and I'm looking for a fix. Not only that, but the description that IS appearing shows script errors and I have no idea where that is pulling from. ": include(freshwork/freshpanel/freshpanel.php) [function.include]: failed to open stream: No such file or directory in ¸W¹ on line 36Warning: include() [function.include]: Failed opening 'freshwork/freshpanel/freshpanel.php' for inclusion (include_path='.:/home/trengine/domains/rockitim.com/includ…"

    I would like the title, description, and icon to match the results of a user sharing http://www.chrislaughter.com/home.

    Any advice would be greatly appreciated!

    My (messy) htaccess file looks like this:
    (I know nothing about htaccess and was just trying a bunch of things)

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    # Map http://www.chrislaughter.com to /home.
    RewriteRule ^$ /home/ [L]

    # Map http://www.chrislaughter.com/x to /home/x unless there is a x in the web root.
    # RewriteCond %{REQUEST_FILENAME} !-f
    # RewriteCond %{REQUEST_FILENAME} !-d
    # RewriteCond %{REQUEST_URI} !^/home/
    # RewriteRule ^(.*)$ /home/$1

    # Add trailing slash to directories without them so DirectoryIndex works.
    # This does not expose the internal URL.
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteCond %{REQUEST_FILENAME} !/$
    RewriteRule ^(.*)$ $1/

    # Disable auto-adding slashes to directories without them, since this happens
    # after mod_rewrite and exposes the rewritten internal URL, e.g. turning
    # http://www.example.com/about into http://www.example.com/jekyll/about.
    # DirectorySlash off

    RewriteEngine On
    RewriteBase /home/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /home/index.php [L]
    </IfModule>
    # END WordPress

Topic Closed

This topic has been closed to new replies.

About this Topic