WordPress.org

Ready to get started?Download WordPress

Forums

WP Bulletin Board
[resolved] Facebook Login (13 posts)

  1. Punka Tess
    Member
    Posted 1 year ago #

    I am having problems setting up the Facebook login on this. Is there instructions somewhere on which Facebook type of app I need to set up? Thank you.

    Tess

    http://wordpress.org/extend/plugins/wp-bulletin-board/

  2. Punka Tess
    Member
    Posted 1 year ago #

    Right now I've set the bulletin board up at http://scrapjack.net/final/discus/

    But it will be moving domains tonight.

  3. codebycarter
    Member
    Plugin Author

    Posted 1 year ago #

    Sorry yes there aren't actually any instructions on how to set this all up. This is all you have to do:

    1. https://developers.facebook.com/apps (register or login)
    2. "Create New App"
    3. Enter App Name, can be anything you want, don't worry about app namespace or web hosting. Click continue.
    4. Facebook should've created the app for you and you'll see at the top the name of your app and the default avatar, next to that there is your App ID and App Secret Key. Enter those into your WPBB facebook settings.
    5. You may want to enter a contact email and change any other settings to your liking but leave sandbox mode disabled and don't use the "Hosting URL"
    6. Click "Website with Facebook Login" under "Select how your app integrates with Facebook" then enter the URL to your wpbb forum e.g. http://mysite.com/wordpress/forum
    7. Save changes

    You just have to make sure your settings match the settings in your WPBB settings. Also make sure that the Redirect URL is the same, usually people make a mistake there.

    Let me know if you need any further help and I will also add this as an FAQ and add to the readme for the next version.

    Thanks

  4. Punka Tess
    Member
    Posted 1 year ago #

    Thanks!

    I followed your instructions about an hour ago, but when I try to login to Facebook, it gives me an error. Could you possibly look at the page and tell me if I have something set up incorrectly?

    http://www.audiojack.com/discuss/

    I really appreciate your help! Thank you so much.

  5. codebycarter
    Member
    Plugin Author

    Posted 1 year ago #

    In WPBB facebook settings is Redirect URL set as http://www.audiojack.com/discuss/ ?

    6. Click "Website with Facebook Login" under "Select how your app integrates with Facebook" then enter the URL to your wpbb forum e.g. http://mysite.com/wordpress/forum
    7. Save changes

    You just have to make sure your facebook app settings match the settings in your WPBB settings. Also make sure that the Redirect URL is the same, usually people make a mistake there.

    Make sure the Website URL you provided to facebook in those steps is the same as your redirect URL in your wpbb facebook settings.

    Forgot to mention you should also make sure you have entered a random string in the CSRF protection in your wpbb facebook settings e.g. dfdhf49hfdf9ns2v0fcf4t (must be alphanumeric - numbers and letters only) but don't use this one.

    Thanks

  6. tadpole207
    Member
    Posted 1 year ago #

    Hi,

    ive created the app, but now i am having trouble getting anyone to log in to the forum, using facebook or not. http://www.nicklacaria.com/forums

    I saw the log in screen http://www.audiojack.com/discuss/
    for some reason, i dont have one and cannot get past permissions into the forum if not logged in as admin. Am i missing steps?

  7. tadpole207
    Member
    Posted 1 year ago #

    Update: if i log out of the site, the Facebook Log in and Facebook registration pops up. It will allow me to log in using facebook but it will not let anyone "register using facebook" it says i have "Sorry, the administrator has disabled user registrations."

    where is this controlled?

    thx

  8. tadpole207
    Member
    Posted 1 year ago #

    Update: I tried registering myself, and it let me go to the app, i used the app and it spit me back out and says
    "You must register for an account using WordPress or Facebook before logging in."

  9. codebycarter
    Member
    Plugin Author

    Posted 1 year ago #

    1st Post: Check the permissions for the forum you're having trouble accessing. If you have any problems saving your changes then refresh your roles (WPBB -> Tools -> Refresh Roles).

    2nd Post: The "anyone can register" setting in your admin dashboard settings must be ticked to allow facebook registrations.

    3rd Post: It should work after you've made the above changes and looked over your wpbb and facebook settings again to make sure they are setup correctly. That error message is displayed when you try to login with an account that doesn't exist, e.g. you provided an incorrect username / password. You must register using facebook before being able to login with facebook and then you can login with wordpress but registering through wordpress does not work the same way. If you registered using facebook and are trying to login using wordpress remember your username will be your facebook name (remember the spaces if any) and the password you entered when you created the account with WPBB.

  10. tadpole207
    Member
    Posted 1 year ago #

    Thank you. I am using S2 Membership and now i cannot get the facebook log in to show up at all. Could this be a theme issue?

    Anyone can register is checked. If i click the name of the forum, it tells me:
    You do not have the required permissions to read topics in this forum!

    However, if i am viewing a forum and click who made it, it takes me to the log in page.

    Shouldn't it do that either way?

  11. tadpole207
    Member
    Posted 1 year ago #

    also, i clicked the "log in using facebook" and it spit me back out on a page that says "You must register for an account using WordPress or Facebook before logging in."

    I have a facebook account, it wont let me log in.

    And if i click register using facebook, it still says "Sorry, the administrator has disabled user registrations. "

  12. codebycarter
    Member
    Plugin Author

    Posted 1 year ago #

    I believe this was resolved by email as haven't heard back from them since. To anyone else encountering the same problem, make sure your facebook settings match your app settings from facebook and don't forget to use a random alphanumeric (letters and numbers only) string for CSRF protection.

    In the next update there will be clear descriptions by the facebook settings so you know what to do.

  13. Punka Tess
    Member
    Posted 1 year ago #

    Sorry for not closing this out earlier. I had passed it on to another programmer, and then someone else started posting on this thread.

    It was the missing CSRF. The app URL and redirect URL's were always the same. Thank you for your help. I will mark this as resolved.

    Tess

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic