WordPress.org

Ready to get started?Download WordPress

Forums

Wordbooker
[resolved] Facebook Like button does not appear in the blog (15 posts)

  1. Marulke
    Member
    Posted 1 year ago #

    I have checked the option to have Wordbooker add Like buttons to my blog. However, no buttons are displayed. Everything else works fine, as far as I can tell.

    This problem is mentioned in the Wordbooker FAQ (below). However, something seems to be missing from the last sentence (qoute):
    Why doesn't the Facebook Like /Send show up properly even though I've enabled it?

    You may need to add the following to the HMTL tag in your theme : xmlns:fb="http://www.facebook.com/2008/fbml".
    So it looks something like :

    (End quote)
    The rest is missing?
    Where do I add this tag?

    You can view my blog at: blogg.notsocool.no

    Please provide the following information about your installation:
    Wordbooker: 2.1.29
    Wordbooker Code Base: 2.1.29 R00 - One of These Days
    Wordbooker ID: 254577506873
    Wordbooker Schema: 5.6
    WordPress: 3.5.1
    Table prefix: wp_
    PHP: 5.3.18
    PHP Memory Limit: 256M
    PHP Memory Usage (MB): 36.25
    JSON Encode: PHP
    JSON Decode: PHP
    Curl Status: Curl is available and can access Facebook - All is OK ( Response Time was : 1.06058001518 seconds )
    Curl Version: 7.24.0
    JSON Version: 1.2.1
    SimpleXML library: 0.1 (provided by PHP)
    HTTP Output Character Encoding: pass
    Internal PHP Character Encoding: UTF-8
    MySQL: 5.5.28-cll
    Database character_set_client : utf8
    Database character_set_connection : utf8
    Database character_set_database : latin1
    Database character_set_filesystem : binary
    Database character_set_results : utf8
    Database character_set_server : latin1
    Database character_set_system : utf8
    Database character_sets_dir : /usr/share/mysql/charsets/
    Database collation_connection : utf8_general_ci
    Database collation_database : latin1_swedish_ci
    Database collation_server : latin1_swedish_ci
    Server : Apache
    Active Plugins :
    Akismet ( 2.5.7 )
    Google Analytics for WordPress ( 4.2.8 )
    Page Links To ( 2.8 )
    RSS Icon Widget ( 4.0 )
    WP Facebook Open Graph protocol ( 2.0.7 )

    Wordbooker Table Status :
    Table 'wp_wordbooker_errorlogs' is present and contains 368 rows
    Table 'wp_wordbooker_postlogs' is present and contains 3 rows
    Table 'wp_wordbooker_userdata' is present and contains 1 rows
    Table 'wp_wordbooker_userstatus' is present and contains 1 rows
    Table 'wp_wordbooker_postcomments' is present and contains 4 rows
    Table 'wp_wordbooker_process_queue' is present and contains 0 rows
    Table 'wp_wordbooker_fb_friends' is present and contains 0 rows
    Table 'wp_wordbooker_fb_friend_lists' is present and contains 0 rows

    http://wordpress.org/extend/plugins/wordbooker/

  2. Steve
    Member
    Plugin Author

    Posted 1 year ago #

    Well you've got two sets of Open Graph Tags which wont cause problems but you should fix.

    When I try to follow a link to a single post it fails with an error.

    For example http://blogg.notsocool.no/elektriskoppvarmedes%C3%A5lerfraThermo

    ends up at a error page

  3. Marulke
    Member
    Posted 1 year ago #

    Steve,
    1) I have corrected the link problem (I hope). Thanks for the advice.
    2) How do I correct the Open Graph Tags problem?
    3) The initial problem, the missing "Like" buttons remains.

    Regards,
    Lars

  4. Steve
    Member
    Plugin Author

    Posted 1 year ago #

    You can either turn off OG tag production in Wordbooker (its in the Advanced Options) or you can disable the WPFBOGP plugin.

    I'd also suggest you turn on Fancy Permalinks - that makes your post urls a lot more friendly... unless of course its Fancy Permalinks that are causing the urls not to work properly.

    Can you do me a screen shot of the Wordbooker Like/Share options?

    Also you seem to have some problems in that I don't see a close for the Wordbooker open graph tags and you've got half a style statement in there (.recentcomments a{display:inline !important;padding:0 !important;margin:0 !important;}) I think this MIGHT be a wordooker bug.. can you see if you have any errors in your PHP error log?

  5. Marulke
    Member
    Posted 1 year ago #

    Steve, I dont understand much of this, but I will try to answer:
    1) Screenshot: http://blogg.notsocool.no/wp-content/uploads/2013/02/FB_like_settings.jpg
    2) Error log. Checked the file blog\error_log. Only a couple of old errors.
    3) Deactivated the WPBOGP plugin

    Regards,
    Lars

  6. Marulke
    Member
    Posted 1 year ago #

    Steve, I moved the screenshot.

    Lars

  7. Steve
    Member
    Plugin Author

    Posted 1 year ago #

    Can you show me the bottom part of the like/send settings?

  8. Marulke
    Member
    Posted 1 year ago #

  9. Steve
    Member
    Plugin Author

    Posted 1 year ago #

    Try setting the last option (Facebook Send - Display Button) to Yes...

  10. Marulke
    Member
    Posted 1 year ago #

    I have set to display the Facebook display button, but the blog still looks the same. No Like button.

  11. Steve
    Member
    Plugin Author

    Posted 1 year ago #

    You've got FB rendering set to use the Iframe - it looks like FB have finally withdrawn support.

  12. Marulke
    Member
    Posted 1 year ago #

    Steve, yes, I have set the Facebook Send - Display Button to Yes. Still does not work.

    "FB rendering to use Iframe?" I dont understand what this means? Should I turn Iframes off? How do I do that?

  13. Steve
    Member
    Plugin Author

    Posted 1 year ago #

    Its in the advanced options "Use Iframes instead of FBXML to render FB features" which is usually off....

  14. Marulke
    Member
    Posted 1 year ago #

    Steve. It worked! I turned off "Use Iframes instead of FBXML to render FB features", and the Like and Send buttons appear. Fantastic.Thanks a lot for your support.

  15. Steve
    Member
    Plugin Author

    Posted 1 year ago #

    I think I'll drop that option and code from Version 2.2 as its obviously no longer working.

    Glad its all working now.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic