WordPress.org

Ready to get started?Download WordPress

Forums

WP Bulletin Board
Facebook Integration (24 posts)

  1. esedwards
    Member
    Posted 1 year ago #

    First off, thanks for the application. It looks great and I am excited to use it once I get it going.

    I am attempting to set up the Facebook Integration and am repeatedly receiving the API Error Code 191
    API Error Description: The specified URL is not owned by the application
    Error Message: Invalid redirect_uri: Given URL is not allowed by the Application configuration.

    What am I doing incorrect here?
    I'm trying to fully understand all of the jargon but am lacking here. Please help!

    http://wordpress.org/extend/plugins/wp-bulletin-board/

  2. esedwards
    Member
    Posted 1 year ago #

    Now when I click "Login Using Facebook" I receive this alert:

    You must register for an account using WordPress or Facebook before logging in

    I'm so lost.

  3. codebycarter
    Member
    Plugin Author

    Posted 1 year ago #

    Hey,

    You'll just need to make sure that the link you access your forum from is entered as the redirect url in your facebook settings in settings -> wpbb settings and that it is also the same over at facebook e.g. "http://mywpsite.com/forums" or "http://mywpsite.com/?page=12002"

    Yes you'll also need to register using facebook first, which basically just registers a WordPress account for you. Makes it easy for administrators to keep track of facebook registrations in my opinion, rather than allowing anyone with a facebook account to login and use the forum. Haven't looked into it too much though, so it could all change someday, but that's what you have to do atm.

  4. Ileana
    Member
    Posted 1 year ago #

    Hi, I am having trouble with the Facebook integration also. I have been trolling through the help forums to see if I could find the answer but haven't so far.

    I followed the useful directions you had posted on the F.A.Q.'s which explained step by steps how to set up the Facebook App. Where FB asks for 'Site URL', I entered the following address where the forums are located: "http://www.birdsleuth.org/ambassadorhome/forums/"

    When I was done, I went to test out the "Register Using FB" option only to get this message: "Unable to load the registration form for this ID. You may have previously blocked this app on Facebook. Go to your Facebook privacy settings to unblock this app. (Error: Invalid 'client_id'.)"
    Otherwise I was getting the following message: "The redirect_uri URL must be absolute"

    What does this mean and how can I fix the problem?
    Thanks in advance for your help.

  5. Ileana
    Member
    Posted 1 year ago #

    After further investigation, the problem, we have realized, is that in the WPBB settings, the "My App ID / API Key" form will not accept more than 10 digits. Our FB App ID has over that number--15 digits to be exact.

    Help?
    Thanks.

  6. vessel65
    Member
    Posted 1 year ago #

    I am facing the same issue with lleana "My App ID / API Key" form will not accept more than 10 digits". please help.

    Thank you so much

  7. vessel65
    Member
    Posted 1 year ago #

    This is my app id from facebook developer = 602190456459187, but after i click save Facebook settings WPBB automatically change back to this number 2147483647.

  8. BRIDGETOINDIA
    Member
    Posted 1 year ago #

    Dear vessel65,
    I am having the same problem right now. Any way to resolve this?

  9. Ileana
    Member
    Posted 1 year ago #

    Vessel65 and Bridgetoindia,

    This has not yet been resolved for me. Vessel, it seems that the app ID was automatically changing for us as well.

    Still looking to get some support on this...

  10. BRIDGETOINDIA
    Member
    Posted 1 year ago #

    Hi Ileana,
    Turn off 'sandbox mode' in the Facebook app and fill the App ID again.

  11. Ileana
    Member
    Posted 1 year ago #

    Hi, "Sandbox mode" was already disabled and I believe there is no way to change the App ID. You can only reset the "App Secret"

  12. dowhilesomething
    Member
    Posted 11 months ago #

    Has anyone found a solution to this? I really like the forums module, but FB integration is KEY.

  13. The Author Jack Foreigner
    Member
    Posted 10 months ago #

    Bump: I don't even get any error messages; there's just no Facebook anything on my WPBB forums page!!

  14. brandingpeople
    Member
    Posted 9 months ago #

    Has anyone figured out this issue?

    "This is my app id from facebook developer = 602190456459187, but after i click save Facebook settings WPBB automatically change back to this number 2147483647."

    This is exactly what's going wrong with mine.....

    I just emailed WPBB and waiting on reply.

    Thanks in advance

  15. Ileana
    Member
    Posted 9 months ago #

    No luck yet... still hoping for some sort of response but also willing to use another forum platform if I come across one that looks good. If anyone has any suggestions, or has found an alternative, please let me know.

  16. brandingpeople
    Member
    Posted 9 months ago #

    Admins? Does this mean we should use another plugin all together?

  17. dowhilesomething
    Member
    Posted 9 months ago #

    Edit the following file "wpbb-admin-settings.php" and remove the int constraint check on the post submission for this field.

    The reason it keeps resetting is because it fails the check and uses the default.

  18. brandingpeople
    Member
    Posted 9 months ago #

    Thanks so much for helping out.....i'm looking at the file now.....what specifically am I deleting?

  19. brandingpeople
    Member
    Posted 9 months ago #


  20. dowhilesomething
    Member
    Posted 9 months ago #

    Find this line in the file I listed:
    $facebook_app_id = absint($_POST['wpbbfacebookappid']);

    edit that to be:
    $facebook_app_id = $_POST['wpbbfacebookappid'];

    And this should correct the issue.

  21. brandingpeople
    Member
    Posted 9 months ago #

    YOU ARE A GEM!!!! EVERYTHING WORKS NOW!!!! YAY!!!! THANK YOU SO MUCH!

  22. brandingpeople
    Member
    Posted 9 months ago #

    okay and now there's a problem with signing in now :(

    Warning: file_get_contents() [function.file-get-contents]: URL file-access is disabled in the server configuration in /homepages/27/d380977797/htdocs/nhlblog/wordpress/wp-content/plugins/wp-bulletin-board/php/facebook/wpbb-facebook.php on line 94

    Warning: file_get_contents(https://graph.facebook.com/oauth/access_token?client_id=618471701532710&redirect_uri=http://locextensions.net/forums/&client_secret=01bef5b0ef9edff8b3f2ee7499a0dce9&code=AQCwoyPi4Ar7Kq1WQW3yYRecZj0mS7uhFmEGCwXBwOWDaMAuKLaBhOBrN5rD-SOsGStD6Itis40VzL2OjGqgFeGTky9PvEe2cR1U-3Ak9I-NEYj0Y7LfUGhllz51tn4WE66yyYkULSKsgUzgQHzlozgeTp0W8VqVdomXhEFMxwdakKAGRMyw8eu97lyFZeicqBgrTH0s5mMSblbJ0cc8i1fnSQZ8eN0p6qWNagvO7NM0Do7Nrpstilt2ZGOLjvsxaFYFZWezZJiWJxJNHVoxT-8aWQdaRgrfh_WsxGpsAyVxK_-WMHVPK7GC0dt4J961vsE) [function.file-get-contents]: failed to open stream: no suitable wrapper could be found in /homepages/27/d380977797/htdocs/nhlblog/wordpress/wp-content/plugins/wp-bulletin-board/php/facebook/wpbb-facebook.php on line 94

  23. dowhilesomething
    Member
    Posted 9 months ago #

    I'm not by any means a PHP expert, but I believe you need to change your configuration to allow external file access.

    Change from:
    allow_url_fopen = Off
    allow_url_include = Off

    Settings should be:
    allow_url_fopen = On
    allow_url_include = On

    Hope that helps

  24. The Author Jack Foreigner
    Member
    Posted 7 months ago #

    Hell, I can't even get any mention of Facebook anything to show up at all...despite the code spelunking....

    This plugin may be abandonware...ya think??

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.