WordPress.org

Ready to get started?Download WordPress

Forums

WP Facebook Open Graph protocol
Facebook Graph API (7 posts)

  1. writegnj
    Member
    Posted 1 year ago #

    I'm having problem with main page that doesn't show up properly on Facebook when someone hit Like button on my website. All the other pages work perfectly fine but only main page still displays the contents that I had couple days ago on my main page.

    On Facebook's Object Debugger, Scraped URL shows CORRECT data from my site but on Graph API shows old data from couple days ago..
    Also, it says Error Linting URL: An internal error occurred while linting the URL.

    Can anyone help me out with this issue?
    Thanks in advance.

    http://wordpress.org/extend/plugins/wp-facebook-open-graph-protocol/

  2. Chuck Reynolds
    Member
    Plugin Author

    Posted 1 year ago #

    what's the url in question? can't look into it without knowing where to look.

  3. writegnj
    Member
    Posted 1 year ago #

    Hi Chuck! the url is u wanna take a look at.
    http://developers.facebook.com/tools/debug/og/object?q=http%3A%2F%2Fgoodnightjournal.com%2F

    seems to me my website send all the correct information to Facebook but some reason Facebook does not read it correctly.
    I waited for a day to see if Facebook updates data but it didn't. trying to find out what's goin on with this.

    my website address is http://www.goodnightjournal.com

    thank you

  4. Chuck Reynolds
    Member
    Plugin Author

    Posted 1 year ago #

    hmm that's weird. the source is normal and fine. the raw debug scraper looks fine.
    At first I thought maybe your site's robots.txt was blocking it or something. Maybe the server or something is blocking it? But it shows the raw source it scraped...

    Idk what this error means; never seen it before. "Error Linting URL: An internal error occurred while linting the URL."

    It's just something with your front page as the inside pages work fine. Exp:
    https://developers.facebook.com/tools/debug/og/object?q=www.goodnightjournal.com%2Fcategory%2Fread-public-journal%2F

    I'd check what scripts and plugins you have loading on the front of the site... what redirects may be in place etc. FB just doesn't like your homepage for some reason.

  5. writegnj
    Member
    Posted 1 year ago #

    Hi Chuck! thanks for the reply. Well I'm still trying to figure out whats goin on with this. Seems like there are not that many people having this problem as I couldn't find any useful resources about this issue.

    http://stackoverflow.com/questions/13731206/error-linting-url-an-internal-error-occurred-while-linting-the-url
    http://developers.facebook.com/bugs/513920671963638?browse=search_50dbb232300af8270174614

    I think this plugin works perfectly fine. It's a bug on FB side.
    Each time I debug my site on FB debugger, I see FB spider reached my site but didn't get latest contents on homepage.

  6. writegnj
    Member
    Posted 1 year ago #

    Hey, I found the way to make it work. I don't know why but some reason Facebook doesn't like og:type "website". I changed website to blog on wp-facebook-ogp.php at line 145 and it works fine.

  7. Chuck Reynolds
    Member
    Plugin Author

    Posted 1 year ago #

    so it looks like FB has updated all of those requirements a couple weeks ago (as per https://developers.facebook.com/docs/technical-guides/opengraph/built-in-objects/

    I made an issue in github to remind me to look at it. Glad it works for you now. This maaaay be something we'll patch in the next release.

    They change shit all the time and there's really no way to subscribe to when that happens so... i'll figure it out. Cheers!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.