WordPress.org

Ready to get started?Download WordPress

Forums

Facebook gets wrong image (12 posts)

  1. leonardogsouza
    Member
    Posted 1 year ago #

    Everytime I write http://www.zunkabitz.com on Facebook and it pulls the preview for my website, the image (and description) are the ones from this link:

    http://www.zunkabitz.com/universo/cientistas-descobrem-tres-planetas-capazes-de-suportar-vida/

    It gives me 3 options of images, all of them from posts and not the actual logo and description. Why is that?

  2. lettergrade
    Member
    Posted 1 year ago #

    Hi @leonardogsouza, I tried this tutorial and ran your site through the Facebook debugging tool he mentions:

    Using the Facebook Debugger Tool

    Now your three image options are showing up in status updates, instead of just two! Check it out yourself and see if it's fixed.

  3. leonardogsouza
    Member
    Posted 1 year ago #

    Thank you for your reply. When I use the Debug Tool I get the following message:

    "More Than One OG URL Specified: Object at URL 'http://www.zunkabitz.com/' of type 'article' is invalid because it specifies multiple 'og:url' values: http://www.zunkabitz.com/, http://www.zunkabitz.com/planeta-terra/brasil-desenvolve-tecnologia-inedita-com-fibra-de-carbono/."

  4. leonardogsouza
    Member
    Posted 1 year ago #

    Actually, I believe the description is wrong.

    When I type http://www.zunkabitz.com on my Facebook, the description is from the most recent post instead of the actual description of the website. How to fix this?

    And the logo, I'd like to use the logo that I use on my website fan page, not the website logo (which is too large), how do I do that? I'm afraid to do sth wrong and mess with the imagem from posts..

  5. lettergrade
    Member
    Posted 1 year ago #

    I don't think you have to worry about the error message. If you read the article I posted about the Facebook Debugging Tool, you'll see that you don't really need debugging -- but going through the process is what updated the Facebook cache of your images. The cache is the result of a crawl of your page, because Facebook can only pick up what's actually there. I don't believe it's possible to assign an image that doesn't exist on the page whose url is being posted.

  6. leonardogsouza
    Member
    Posted 1 year ago #

    I did read the article (very informative and well written, by the way).

    The thing is: how can I make Facebook get the right image logo and description of my website? I don't want that when people simply type "www.zunkabitz.com" they get the last post image and description..

  7. lettergrade
    Member
    Posted 1 year ago #

    Here's a good post on the subject: Set Up your Website to Control Images & Text in Facebook Status Update Links

    Let us know what you change and if it works!

  8. leonardogsouza
    Member
    Posted 1 year ago #

    I believe I have found the error:

    Object at URL 'http://www.zunkabitz.com/' of type 'article' is invalid because it specifies multiple 'og:url' values: http://www.zunkabitz.com/, http://www.zunkabitz.com/tecnologia/acabou-a-bateria-do-celular-recarregue-com-sua-propria-urina/.

    on my header.php I have:

    <meta property="og:type" content="<?php if (is_single() || is_page()) { echo "article"; } else { echo "website";}
    ?>"/>

    What should I change?

  9. lettergrade
    Member
    Posted 1 year ago #

    Are you using a plugin to generate that code, or is it part of the theme you're using? The theme is commercial, so you may want to check their support forums. If it's a plugin, you may want to ask directly in that plugin support forum.

  10. leonardogsouza
    Member
    Posted 1 year ago #

    My theme is free, doesn't have a support. I mean, it does, but they do not give support..
    It is not plugin, I added that manually after seeing somewhere in the web...
    I can't manage to get these OpenGraph right, dammit..

    Thank you so much for your time :)

  11. esmi
    Forum Moderator
    Posted 1 year ago #

    I'm sorry but as you are using a non-WPORG theme, you need to seek theme-specific support from the theme's developers - paid or otherwise. We only support themes downloaded from wordpress.org here.

  12. leonardogsouza
    Member
    Posted 1 year ago #

    Even if I have a general question? I thought it was like a community or something, sorry for my mistake.

Topic Closed

This topic has been closed to new replies.

About this Topic