WordPress.org

Ready to get started?Download WordPress

Forums

Jetpack by WordPress.com
[resolved] Facebook does not show how many counts (20 posts)

  1. yonahman
    Member
    Posted 1 year ago #

    Hey Guys,
    Im using Jetpack and I'm wondering if there is a bug into the Facebook part of Jetpack.
    When I share my website link on facebook, and members like the post, the facebook counter does not update(underneath all posts or pages). This is for me a huge problem! Also when I share it with friends it does not refresh.

    What could this be? Please contact me ASAP.

    my website is http://www.odbasis.com it is a music website / online magazine type of thing.

    http://wordpress.org/extend/plugins/jetpack/

  2. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    I had a look at some of your posts, and the counter seems to be displayed properly. Here is an example with your latest post:

    Could you give me a specific example so I can investigate further?

  3. velogazette
    Member
    Posted 1 year ago #

    I have the same bug...

    My website : http://velogazette.ca
    A post : http://velogazette.ca/2012/11/29/antoine-duchesne-chez-bontrager-livestrong/

    On this API, there are not the shares count who the Jetpack use...

    1-2 week ago, the count was there...

    Thanks

  4. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @velogazette Your site includes duplicate Open Graph Meta tags, and that might confuse the Facebook counter.

    Could you try to remove Jetpack Open Graph Meta Tags by adding the following code to your theme's functions.php:
    add_filter( 'jetpack_enable_open_graph', '__return_false' );

    See this post for more information:
    http://kovshenin.com/2012/double-titles-when-sharing-on-google/

    Let me know if this helps.

  5. allwork
    Member
    Posted 1 year ago #

    I think Kovshenin's site is experiencing same problem.
    http://kovshenin.com/2012/double-titles-when-sharing-on-google/

    Facebook badge shows no share counts but facebook api return 1 (total count).

  6. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Indeed!
    Could you go to Settings > Sharing in your dashboard, switch from the Text button to the Official buttons, save changes, and check if you experience a similar issue with Facebook's Like buttons on your site?

    Thanks!

  7. allwork
    Member
    Posted 1 year ago #

    I have older post (17th November). It's working fine with both official button and text/icon buttons. http://ruoka.ts.fi/haarukassa/kotini-on-kuin-kiljutehdas/

    FB Graph page returns

    "id": "http://ruoka.ts.fi/haarukassa/kotini-on-kuin-kiljutehdas/",
    "shares": 15

    FB API page returns total count 15.

    Newer post (9th December) works with official buttons but shows no count with text/icon buttons.

    Initially this post didn't have likes and FB Graph returned only
    "id": "http://ruoka.ts.fi/haarukassa/jotain-pitaisi-keksia-myyjaisiin/"

    After liking FB Graph data changed and is now different from older post.

    FB API data is fine. Total count is 1.

  8. velogazette
    Member
    Posted 1 year ago #

    Remove the double OG : nothing
    Switch to official button : The count is there
    Switch to Button+Text : The count is there...

    Now it's work, but I don't know why!

    Other things, with infinite scroll, the new post have not the count and the link don't go to popup. I have repair it on my site, but I don't think is the best way I have done...

  9. velogazette
    Member
    Posted 1 year ago #

    work on home page but not on the post page...

    There are definitely a bug

  10. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    @allwork Thanks for all the details! Could you switch back to the Text/Icon buttons now, so I can have another look at that post?

    @velogazette This could be a cache issue. Do you use any cache plugins on your site?

  11. velogazette
    Member
    Posted 1 year ago #

    hmmm not don't think...

  12. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Thanks for the info. I forwarded the issue to our developers, and I will keep you posted!

  13. velogazette
    Member
    Posted 1 year ago #

    ok thanks!

    For the link popup, I have repair with :

    file : sharing-sources.php
    line : 166
    change : jQuery(document).ready(function(){
    for : jQuery(document).on('ready post-load', function() {

  14. velogazette
    Member
    Posted 1 year ago #

    In the Open Graph for this post don't have share count

    but Open Graph for this post yes... I have switch to official button and the shares was there after...

  15. allwork
    Member
    Posted 1 year ago #

    @Jeremy I switched back to the Text/Icon buttons and It's now showing the count.

    I tested a few other posts and text/icon didn't show count but after switching to official buttons, refreshing the page and switching back to text/icon, count appeared.

  16. velogazette
    Member
    Posted 1 year ago #

    @allwork It's do the same things on my site

    @Jeremy I have edited for the share work with de infinite scroll. Do you have a mail that I can send the modified file?

  17. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    You can send us an email via this contact form:
    http://en.support.wordpress.com/contact/?jetpack=needs-service

  18. yonahman
    Member
    Posted 1 year ago #

    So, to be specific about this. What could I do to solve the problem that i'm having? Visitors are thinking that the blog is not working properly at this moment. People told me that the blog is heading down hill.

    Could somebody tell me what to do to solve this problem? I have little HTML knowledge, but I think it is not a big operation?

    Please contact me at ynhman@gmail.com or here in this conversation. My website is http://www.odbasis.com

    Thank you for your effort already!!

  19. Jeremy Herve
    Happiness Engineer
    Plugin Author

    Posted 1 year ago #

    Could you try to disable WP Super cache, and see if that helps?

    Could you switch to the official Like button, as I explained above, and let me know if the problem persists?

  20. velogazette
    Member
    Posted 1 year ago #

    Update with the new version, it's work now!

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic