WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Facebook Connect API key error in Simple Facebook Connect (12 posts)

  1. wiresaw
    Member
    Posted 3 years ago #

    I just install Simple Facebook Connect, add the app secret, app ID and API key but whenever I add the API key(which is the same with APP ID) then click save changes the API key is automatically gone/erased in the text box, then I try to enter the App secret it will not gone in the text box but I get an API key error.. Any fix for this? Thanks

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 3 years ago #

    The API key is not the same as the App ID.

    Go to https://www.facebook.com/developers/apps.php and get the correct information.

  3. Ken Soszka
    Member
    Posted 3 years ago #

    Holy cow - there are two different sites or something for Facebook Apps. The one linked to above:
    https://www.facebook.com/developers/apps.php
    shows a separate API Key and Application ID.

    BUT this one says that the API Key and Application ID are the same:
    https://developers.facebook.com/apps/

    No wonder we are confused.

  4. Samuel Wood (Otto)
    Tech Ninja
    Posted 3 years ago #

    Yeah, but why are people going to the second one at all?

    SFC itself has the link to the first one in the setup instructions and in the Help dropdown itself. Nobody should be going to https://developers.facebook.com/apps/ when SFC explicitly tells you to go to https://www.facebook.com/developers/apps.php.

  5. Ken Soszka
    Member
    Posted 3 years ago #

    Well, here's why I did - I only tried this plugin because I am having an issue with the "Facebook Page Publish" plugin. The instructions for that send you to the site with the incorrect info (which doesn't matter because that plugin does not use the API Key). Also, if you search google for "Facebook Developer" the site with the incorrect info comes up first.

    Is there a way to make this plugin automatically publish posts only from certain categories? That is why I like Facebook Page Publish...

    Thanks!

  6. Ken Soszka
    Member
    Posted 3 years ago #

    Actually, when you search google for "Facebook Developer" the site with the incorrect info is the ONLY one from Facebook that comes up... what's up with that? :-)

  7. Samuel Wood (Otto)
    Tech Ninja
    Posted 3 years ago #

    Version 1.0 of the plugin will no longer require the API key at all.

  8. maddman75
    Member
    Posted 2 years ago #

    Otto,

    Your plugin looks like exactly what I need! But referring to this comment

    Yeah, but why are people going to the second one at all?

    SFC itself has the link to the first one in the setup instructions and in the Help dropdown itself. Nobody should be going to https://developers.facebook.com/apps/ when SFC explicitly tells you to go to https://www.facebook.com/developers/apps.php.

    It looks like Facebook is redirecting https://www.facebook.com/developers/apps.php over to https://developers.facebook.com/apps/.

    So even when you follow the link in the plugin, there's no way to get the seperate API key. Is there a quick way to fix this?

  9. maddman75
    Member
    Posted 2 years ago #

    Nevermind, if anyone else has this problem make sure you have version 1.0 :)

  10. razer0r
    Member
    Posted 2 years ago #

    Is there any way to recover the old API key?

    I've updated my SFC installation, but, now my registration form looks all wrong. And I wanted it back the way it was. With autofill in the same style as the wordpress registration was.

    Otto, can I preserve the SFC registration style with the new 1.0 version?

  11. Samuel Wood (Otto)
    Tech Ninja
    Posted 2 years ago #

    No, sorry. And going back to version 0.25 won't help you either. Old versions of SFC will likely stop working October 1st, when FB mandates OAuth 2.0.

  12. razer0r
    Member
    Posted 2 years ago #

    I'm cuurently using a plugin to modify the registration fields, so that the username is equal to the email address (look at: http://londerzeel.vantveer.be/wp-login.php?action=register )
    Is there any way the plugins can be compatible?
    The site is in development, and i was realy happy the way the integration was :p

Topic Closed

This topic has been closed to new replies.

About this Topic