WordPress.org

Ready to get started?Download WordPress

Forums

NextScripts: Social Networks Auto-Poster
[resolved] Facebook auto post error (6 posts)

  1. kioub
    Member
    Posted 1 year ago #

    Hello

    I have setup SNAP and auto posting on almost every supported social network with success. Facebook is the only network that returns this error (the past part - from PostID onwards - is the info for the link I am posting):

    [Error] [Facebook - JCG-FB] - -=ERROR=- Array ( [pgID] => [isPosted] => 0 [pDate] => 2013-06-20 22:05:10 [Error] => [ERROR] (#1500) The url you supplied is invalid ) | PostID: 14567 - Java SE 7 Update 25 - Release-Notes explained. |im

    Am I doing something wrong? My configuration is to post on my Facebook page. I tried to manually post it on Facebook and it succeeded (using the "Repost to Facebbok" button at bottom of the article's editor).

    Your answer will be highly appreciated.
    Byron

    http://wordpress.org/extend/plugins/social-networks-auto-poster-facebook-twitter-g/

  2. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

  3. kioub
    Member
    Posted 1 year ago #

    Thank you very much for your response!

    I have another question. As I said I am posting to my Facebook page, but the link post is created by the Facebook user (account) that I used to create the Facebook App to support the posting procedure. This user account is different than my page admin account. What I would like to do is to post on my page as the Facebook's page admin account so as the links to appear directly on the page's timeline and not in the "posts by others" section of the timeline. Is that possible?

    Thank you in advance
    Byron

  4. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    Plugin will post as the user who authorized the account. You can setup an app from one account and authorize it from another.

  5. kioub
    Member
    Posted 1 year ago #

    Thank you very much for your response. I have authorized with my page account and everything is working as expected - at least with the test posting that is.

    One last thought. As far as my original question is concerned, you specified that is a duplicate question and that its Facebook's issue. I was wondering how can it be a Facebook issue when using your plugin I perform a manual check (a test post) from the service's configuration page and it gets posted correctly, additionally I perform the same manual submission from withing the posts editor and it succeeds also where only the automatic submission is not working?

    I am a programmer myself and from what I can understand is that the code to get executed so as to submit a post should be the same regardless of how its being triggered (explicitly or through a cron like manner)... Since I am using the scheduled publishing I was wondering what is the possibility the issue to originate in this specific kind of code invocation?

    Thanks in advance
    Byron

  6. NextScripts
    Member
    Plugin Author

    Posted 1 year ago #

    It's internal Facebook caching/indexing problem. When you submit brand new page first time, sometimes Facebook can't cache/index it fast enough and throw 1500 error. When you try to publish it again manually it's already cached by Facebook, so it works.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic