WordPress.org

Ready to get started?Download WordPress

Forums

Facebook Album
[resolved] "Facebook API came back with a result, but it had no photos!" (8 posts)

  1. SteffenFraWots
    Member
    Posted 1 year ago #

    I get this message upon posting a short link

    "Facebook API came back with a result, but it had no photos!"

    Also - facebook albums no longer seem to be using the same reference code and now looks like this: https://www.facebook.com/media/set/?set=a.348197025211879.90699.123229947708589&type=3

    or am I getting the URL from the wrong place on the page?

    http://wordpress.org/extend/plugins/facebook-albums/

  2. mglaman
    Member
    Plugin Author

    Posted 1 year ago #

    That error means basically Facebook responded with an API error. I'll check this out within next day or two.

  3. Nathan401
    Member
    Posted 1 year ago #

    i am getting a similar error message

    "Album ID was empty, or Facebook API returned empty result. Please double check your Facebook album URL."

    any ideas whats wrong. the album links are right and ther are photos in the albums.

    Thanks

  4. zenrhe
    Member
    Posted 1 year ago #

    I am also getting the same. A mix of
    "Facebook API came back with a result, but it had no photos!" and
    "Album ID was empty, or Facebook API returned empty result. Please double check your Facebook album URL."

    Ones from this page don't work
    https://www.facebook.com/david.mcaleavy/photos_albums

    Ones from this page do work
    https://www.facebook.com/GraniteCityRollerGirls/photos_albums

    They are all public albums. I wondered if maybe it was album size, but even the small albums on the page that doesnt work still don't work.

    This is the first plugin I've used to do this task, and I am mightly impressed with it.. bar the fact it seems very picky :p

    Any help would be much appreciated.
    Cheers

  5. zenrhe
    Member
    Posted 1 year ago #

    I think I've worked it out. It works for Page's but not people.
    Would this be the case ? Or just a coincidence ?

  6. juiceex
    Member
    Posted 1 year ago #

    This seems to be a constant issue. Getting the error message "Album ID was empty, or Facebook API returned empty result. Please double check your Facebook album URL."

    The photos will show up for a little while, but as I work on the site eventually they will be replaced with that error message.

    Is there a limit on the number of API calls in a given period? Has anyone been able to eliminate this issue?

    I can usually restore the photos if I re-paste the album URL in the widget and hit submit.

    Thanks

  7. mglaman
    Member
    Plugin Author

    Posted 1 year ago #

    @zenhre this plugin only works for pages not personal accounts as the API does not authenticate.

    I am planning on adding authenticated capabilities, and donations would work as a great push http://glamanate.com/wordpress/facebook-album/

  8. mglaman
    Member
    Plugin Author

    Posted 1 year ago #

    Version 2.0 is released. This should resolve most API issues, if they continue integrate a Facebook app. Video is linked on plugin page, and plugin settings page.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.