WordPress.org

Ready to get started?Download WordPress

Forums

WPBook
[resolved] [closed] Facebook Access Token for WPBook has expired (16 posts)

  1. armen_1982
    Member
    Posted 2 years ago #

    This messsage has appeared

    Your Facebook Access Token for WPBook has expired. Please visit the settings page for WPBook and grant a new access token. Until you do so, cross-posting to Facebook and import of comments will fail.

    (visit the settings page for WPBook) link shows wrong path. I have installed WP here http://www.mydomain.com/directory/ but the link showed http://www.mydomain.com/wp-admin/options-general.php?page=wpbook.php.
    So when I click on it, showed blank page.

    http://wordpress.org/extend/plugins/wpbook/

  2. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    Are you able to locate the WPBook settings page?

    Are you reporting the bug so I know to get the link pointed at the right place (which is helpful - don't mean that sarcastically), or are you actually stuck trying to generate a new access token?

  3. armen_1982
    Member
    Posted 2 years ago #

    Yes, I am able to locate the WPBook settings page (Settings/WPBook) and generate a new access, after 1 or 2 hours that message is appearing again (top of the window). So I cann't directly join the WPBook settings page.

  4. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    Have you changed the settings in your Facebook application so that the "remove offline_access" setting is ENABLED?

    You are only getting "short lived" tokens if they only last 2 hours - you want "long lived" tokens which are more like 2 months. That setting in the migrations section (advanced) of your Facebook application controls this.

  5. armen_1982
    Member
    Posted 2 years ago #

    Remove offline_access is enabled. Before it was desabled and I have the same result.

  6. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    There are a number of Facebook issues in this area. See http://developers.facebook.com/bugs/420414797988850 and https://developers.facebook.com/bugs/185263104927672

    There's a discussion on stack overflow: http://stackoverflow.com/questions/9031056/facebook-access-token-with-longer-expiration

    Two things you can try:

    1. Remove the app from your personal Facebook profile, and then re-add it. This seems to cause new tokens to be generated that are long-lived.
    2. Also set the 'enhanced oauth dialog' setting in your Facebook app - some have reported this is necessary for long-lived tokens

    There's also the nuclear option - delete your Facebook app and make a new one. This will get you the long lived tokens but will also require changing your FB app's url, etc.

  7. armen_1982
    Member
    Posted 2 years ago #

    Sorry for my simple question, where is located 'enhanced oauth dialog'? :)

  8. johneckman
    Member
    Plugin Author

    Posted 2 years ago #

    It's a setting in the Facebook application settings on Facebook

  9. jasminestailorshop
    Member
    Posted 1 year ago #

    Sorry for a newbie question here, how do you generate a new token to regain access to Facebook? I cannot find that option on wpbook setting page in wordpress. Thanks a lot!

  10. johneckman
    Member
    Plugin Author

    Posted 1 year ago #

    If you're using WPBook, there is a link at the bottom of the instructions paragraph on the admin page titled "checking permissions" - that takes you to a page inside Facebook powered by WPBook where you can do the grant of permissions.

    If you're using WPBook Lite, the link is on the WPBook Lite settings page in WP and is titled "generate access token"

  11. jasminestailorshop
    Member
    Posted 1 year ago #

    Thanks, John. You seem to be extremely help, always! :) I suspect that my setup with WPBook (not lite) is not 100% correct, so I am having this problem.

    When I click on this "checking permissions" link, it takes me to this page which returns an error of "page not found", the URL is:

    http://apps.facebook.com/www.jasminesbridalshop.com/blog//?is_permissions=true&wp_user=1

    I have these settings in the Basic Section of my Facebook App's setting page:

    Website with Facebook Login
    Site URL: http://www.jasminesbridalshop.com/blog/

    App on Facebook
    Canvas URL: http://www.jasminesbridalshop.com/blog/
    Secure Canvas URL: https://s14.phpfogapp.com/free/

    Page Tab
    Page Tab Name: jasminesblogs
    Page Tab URL: http://www.jasminesbridalshop.com/blog/?app_tab=true
    Secure Page Tab URL: https://s14.phpfogapp.com/free/?app_tab=true
    Page Tab Edit URL: <empty>

    In WPBook setting portion of WordPress, I have this setting "www.jasminesbridalshop.com/blog/" for Facebook Canvas Page URL, NOT INCLUDING "http://apps.facebook.com/"

    But this setting is not working, whenever I click on Visit this Canvas Page link in WPBook, it returns "Page Not Found" on Facebook.

    I think the main problem is that I don't really understand some of the terms in the WPBook installation guide, mainly involving the basic setup & Canvas page. I think if some real examples were added to the instructions, it would definitely help.

    I am using the Social Server for HTTPS on Facebook, by the way.

    Now the weird thing is that my blog works in Facebook. They are integrated. The Facebook App Tab works, and people can see the blogs within Facebook on a separate page here when they click on the tab for this app: http://www.facebook.com/pages/Jasmines-Bridal-Shop/121989811259949?sk=app_455641391127508

    I think the only problems left for me to tackle are:
    1. Learn to get long-lived session tokens for WPbook
    2. Make sure Facebook and WPBook can cross-post to each other.

    Thanks and sorry for the long message! Being pulling my hair out all day over this :(

  12. johneckman
    Member
    Plugin Author

    Posted 1 year ago #

    Where you have:

    In WPBook setting portion of WordPress, I have this setting "www.jasminesbridalshop.com/blog/" for Facebook Canvas Page URL, NOT INCLUDING "http://apps.facebook.com/"

    That's wrong.

    The url of your canvas page should be something like:

    http://apps.facebook.com/openparenthesis/

    The "openparenthesis" bit of that is what Facebook used to call your app name - now I think they call it namespace or something?

    If you go visit your actual application in Facebook you should see what the address of your app canvas page is.

  13. jasminestailorshop
    Member
    Posted 1 year ago #

    Thanks, I updated it to be "jasminesblogs" in wpbook setting, but still page not found. Which setting in Facebook app can I find the canvas page address? Is it the "Page Tab Name: "?

    Thanks!

  14. johneckman
    Member
    Plugin Author

    Posted 1 year ago #

    It's right on the main landing page of https://developers.facebook.com/apps when you view your app.

    It's called: Canvas Page, and it is basically the combination of "apps.facebook.com" and your App Namespace, so in my case:
    http://apps.facebook.com/openparenthesis/

    The part that WPBook is looking for in its setting is just the App Namespace part.

  15. mikecapetown
    Member
    Posted 1 year ago #

    hello John

    My name is Mike and I live in Cape Town South Africa.

    Pleased to meet you.

    unfortunately South Africans are not the most clued up people when it comes to coding wp or fb. I am really struggling to get wpbook to work in my canvas page please will you help me get it up and running. I will be so grateful for your help in this matter.

    please take a look if you would be kind enough to help me

  16. Mike? Please start your own topic instead. This issue is 7 months old and has been marked resolved.

    http://wordpress.org/support/plugin/wpbook#postform

    Starting your own topic really is the best way to get support for your specific problem.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.