WordPress.org

Ready to get started?Download WordPress

Forums

Extremely slow posting in WP 1.5 (42 posts)

  1. Narada
    Member
    Posted 9 years ago #

    Hi,

    My WP 1.5 is extremely slow in posting. 1.2 was damn quick and had that little checkbox for "Pingback URL's in this post". In 1.5 this checkbox has gone! Why? I've disabled pingbacking post URLs in the options but still posting takes forever. Any help would be much appreciated as slow posting is discouraging me from posting!

    Thanks.

  2. Narada
    Member
    Posted 9 years ago #

    I should also add that only new posting is slow and everything else is fine.

  3. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Is this slowness happening in every post or is it that more links in a post = more slowness ?

  4. Narada
    Member
    Posted 9 years ago #

    Every post. I've even reduced number of links in posts to one or two and I've stopped linking to other blogs completely and only link to normal web pages for speed. Still it continues to be very slow. I'm running on a UML VPS linux server but still it shouldn't affect it this much. You can see by going to my blog that it loads pretty quickly so speed is not a problem.

  5. zimzam
    Member
    Posted 9 years ago #

    This is probably the same problem as I've experienced - for some reason (for me at least) posts without links publish almost instantly, but put a link in there, and I'm waiting 5+ minutes for the software to finish whatever it's doing.

    A workaround or a hack would be wonderful!

  6. zimzam
    Member
    Posted 9 years ago #

    After some more testing on my end, I've gotten the following (odd!) results:

    When a link is included pointing to the root of a site (for example, [a href="http://www.cbc.ca"]link[/a]), the posting is instant.

    However, add more to the tree of the site (for example, [a href="http://www.cbc.ca/x"]link[/a]), and I get the long delay.

    I disabled all my plugins to be sure, and the same case still happens.

    Finally, the option "Attempt to notify any Weblogs linked to from the article (slows down posting.)" is _not_ checked, same for "Allow link notifications from other Weblogs (pingbacks and trackbacks.)".

    Please, someone, save us poor lads from turning old and grey waiting for our posts to publish!

  7. pieceoplastic
    Member
    Posted 9 years ago #

    same here. for me its even when i edit posts, seems like the pinging just takes forever.
    and that pingback posts option is sourly missed.

  8. jakesutton
    Member
    Posted 9 years ago #

    Ditto here.

    Even though I have the "Attempt to notify" option unchecked, I'm still sending pingbacks to linked posts.

    I also notice the text in the pingback is screwy.

    It looks like:
    [...][partial title of my previous post][title of current post][text excerpt][...]

    Example:
    [...] uck of the Oirish More on Da Kine The news is good. First, from Kin-Shay: 2005-03-16 UPDATE - Courtney just called, she just spoke wi [...]

    Where the current post is titled "More on Da Kine" and the previous post is titled "Luck of the Oirish"...

    Very odd.

  9. adagiomarine
    Member
    Posted 9 years ago #

    I unchecked the option "Attempt to notify any Weblogs linked to from the article (slows down posting.)".

    That speeded up posting dramatically - I would say it is OK now, typical post takes 2-5 seconds.

    If I add a trackback URL I don't notice any slowdown.

  10. brakka
    Member
    Posted 9 years ago #

    Unchecking"Attempt to notify any Weblogs linked to from the article (slows down posting.)" didn't make a noticable change for me, still very slow. I do have about 10 categories, will that make it slower?

    Besides, isn't it good to "Attempt to notify any Weblogs linked to from the article?"

  11. far2fish
    Member
    Posted 9 years ago #

    For me the slowest "feature" in WP1.5 was actually the "Site Admin" page which before the upgrade loaded in 1 second, and after upgrade to WP1.5 it took 15-20 seconds - which actually has made me stop using the Site Admin page. It was much faster to just click on Edit on a post, and then use the menu from there.

    But the suggestion to uncheck "Attempt to notify any Weblogs linked to from the article (slows down posting.)" worked for me. Thank you :)

  12. davidrothman
    Member
    Posted 9 years ago #

    Even with features disabled like "Attempt to notify any Weblogs,"it takes forever to post with 1.5--sometimes five minutes or even longer. Help!

    Odds and ends:

    --The problem seems worse with longer posts. Not sure if links in the posts are a factor.

    --My blog may be as long as 900,000 words, including an import from Blogger. I wonder if the size could be a factor, though I see I'm not the only one with problems. Anyone else have a long blog and the same delays? Maybe the testing of new builds should be done especially with users like us in mind. If WordPress will suffice for us, it will for anyone. Are any developers working on the publishing-speed problem?

    --1and1.com is adamant that nothing screwy is going on with MYSQL or anything else at its end.

    --The problem is only with the actual publishing. "Save" and "Save and continue editing" both work great--almost no delays whatsoever.

    --Blog is at http://www.teleread.org/blog/index.php.

    Any troubleshooters care to take an interest in this case?

    Other than the above and a problem ordering my categories and maybe another detail or so, I'm very happy I made this long-overdue switch to WordPress.

    Thanks.

    David Rothman | 703-370-6540 | dr@teleread.org
    (Can call back so you don't spend long distance)

  13. mirdin
    Member
    Posted 9 years ago #

    On my site it takes forever (20-30 seconds) to log on to wp-admin/index.php. Once I'm logged in every page in the admin section loads fast, except for index.php (dashboard).

    I have this problem with a clean install, no plugins.

    Never had this problem with 1.3, server is fast and not overloaded (load average: 0.02, 0.04, 0.01 )

  14. zimzam
    Member
    Posted 9 years ago #

    It seems that some people who uncheck "Attempt to notify any Weblogs linked to from the article (slows down posting.)" are getting very lucky, and it magically fixes the problem. Not so for the rest of us! I'm still having the if-post-contains-many-links-it-takes-5-to-10-minutes-to-post problem, but I'm glad that I finally know I'm not alone in this.

    Any chance of a WP guru to weigh in on this issue?

  15. maggotcontrol
    Member
    Posted 9 years ago #

    I've got the same problem. It's driving me insane. Sometimes if I manually enter tags like or <br>, it automatically closes them right after my open tag.

  16. davidrothman
    Member
    Posted 9 years ago #

    To everyone with a speed problem:

    Are any of you using 1and1.com--and with what kind of account? And how big are your blogs? Anything close to my 800,000 words or whatever?

    David Rothman | dr@teleread.org

  17. You guys might want to consider repairing your MySQL database.

    http://www.tamba2.org.uk/wordpress/repair/

  18. mirdin
    Member
    Posted 9 years ago #

    In my case it has nothing to do with a slow server, large database etc. , as mentioned it happens on a fast server, clean install with 1 post in the database.

    My problem is only with wp-admin/index.php. Something must be slowing the loading of this page down, it takes 20-30 seconds to load.

  19. zimzam
    Member
    Posted 9 years ago #

    I'm also on 1and1, but I doubt that I'm anywhere close to 800,000 words - my blog only has about 150 posts total. Anyways I don't know where I could look to count it.

    I don't think that there's anything wrong with the MySQL db, as this problem *only* happens when we publish posts where there are links. Saving the posts in the db as drafts is instant. And if as mirdin says the problem of slow publishing occurs right after a clean install, then...

    It feels like a bug in the code - maybe it's still pinging all the links even though the option is not checked?

  20. zimzam
    Member
    Posted 9 years ago #

    Anyways I just looked and there's no overhead for any of my tables - all is well :)

  21. Ryan Duff
    Member
    Posted 9 years ago #

    To all with slow posting:

    I've noticed this as well. It does not appear to be an issue with sql (since is saves quickly) nor with your host. It is a bug with the pingback feature. It is slow because it wants to ping every site, when it hits a site that doesn't accept pingbacks, it waits the timeout period before trying the next. This is also why you notice it with the more links you have in a post.

    If you stop the page load after you submit and its hanging and view the main page, you'll notice its there, its already published. The only thing it was still trying to do is pingback/trackback the other sites.

    If you know you have a page with lots of links, none of which need to be pinged/trackedback you can cancel the page load so it just stops trying.

  22. mirdin
    Member
    Posted 9 years ago #

    My firewall doesn't allow the apache user to make outgoing connections to port 80. That was causing the 30 seconds log-in delay.

    Now I have to figure out why and to where wordpress is trying to connect when I log in to wp-admin/index.php

  23. killelea
    Member
    Posted 9 years ago #

    I just installed 1.5 and everything works great except that comments take 30 to 45 seconds to post.

    I'm betting it is something trying to make a network call out and the ISP is blocking it, resulting in a timeout. No difference if I include links in the comments or not.

    Any advice appreciated. p@patrick.net

  24. ealvin
    Member
    Posted 9 years ago #

    I posted this in my thread about WP saves taking so long, but I think it may have value to this thread as well. I deactivated all of the plugins, as suggested. That didn't help. However, this did, I had a long list of ping sites listed. When I deleted all but pingomatic, it seemed to solve the problem.

    I hope this will be helpful to my fellow WP'ers.

  25. vijk
    Member
    Posted 9 years ago #

    If your Blog server has no internet connection (e.g. Intranet's or like mirdin's case..)
    Comment the lines starting
    $rss = @fetch_rss(...
    in wp-admin/index.php

  26. gothiphop
    Member
    Posted 9 years ago #

    Our website was having the same slow loading problem, but when we deleted all the sites that get pinged, it's now fast. Now the question is which are the best ping sites to use, instead of all 40+ ping sites.

  27. clappingtree
    Member
    Posted 9 years ago #

    Where do you delete all the sites that get pinged? Are there really 40+ sites? I can only see one (http://rpc.pingomatic.com/) in the Writing Options.

  28. jpinnix
    Member
    Posted 9 years ago #

    I am experiencing the same thing. It's definitely not a server issue...

  29. WebSP
    Member
    Posted 9 years ago #

    Not a server issue, but a WP issue. It must be. I have a few clients with the same problem and they are in diferent machines, with 0.10 of load, MySQL runing OK, etc.

    No new ideas about this?

  30. The slow posting is due to both the ping Update Services function and the function that pings articles linked to in the post. WordPress will ping all of the links that you have entered into the post and then wait for a response from the pinged server (the link). If the remote server is slow to respond, then WP is slow to react.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.