WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Extra '/' in URL for index.php (2 posts)

  1. sam_m
    Member
    Posted 6 years ago #

    I am having a problem viewing my blog pages when I use the 'View>>' link in the Write post part of WordPress.

    I have wordpress installed in a subdirectory of my site as the I have a php script installed for the main site. So, I need to keep it separate from the root directory.

    The problem I get is when I click on the link it tries this url:

    http://www.mysite.com/wp/index.php/?p=21

    As you can see an extra '/' is appearing in the url after the index.php

    My site url in the wp Options is set to :

    http://www.mysite.com/wp/index.php

    Because otherwise, http://www.mysite.com/wp yields me a display of no pages. I have to include the 'index.php'

    Any help on this would be highly appreciated...

    Thx!

  2. sam_m
    Member
    Posted 6 years ago #

    Added .htaccess file to subdirectory where WP is installed. This addressed the problem.

Topic Closed

This topic has been closed to new replies.

About this Topic