WordPress.org

Ready to get started?Download WordPress

Forums

WordPress HTTPS (SSL)
[resolved] external links in theme (*.googleapis.com) not changed to https (4 posts)

  1. Vezado
    Member
    Posted 3 years ago #

    My theme has several http external links to google APIs for fonts etc.

    if ( $et_body_font <> '' ) {
    			$font_style .= "<link id='" . $et_body_font_id . "' href='http://fonts.googleapis.com/css?family=" . $et_body_font . "' rel='stylesheet' type='text/css' />";
    			$font_family = "font-family: '" . str_replace( '+', ' ', $et_body_font ) . "', Arial, sans-serif !important; ";
    		}

    WordPress HTTPS is not changing these links, even with 'Bypass external checks' disabled, but these API links work fine on https.

  2. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    Hey Vezado,

    This is being caused by the Regex used to match URL's in the code. I will have this fixed in the next version.

    Thanks,
    Mvied

  3. Vezado
    Member
    Posted 2 years ago #

    Thanks Mvied! This will reduce the amount of modification needed.

    Your plugin is very useful and I appreciate you work. Thank you very much.

  4. Mvied
    Member
    Plugin Author

    Posted 2 years ago #

    This fix is out in version 1.9. :)

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic