WordPress.org

Ready to get started?Download WordPress

Forums

Google Analyticator
[resolved] External Link Tracking doesn't work (11 posts)

  1. mores
    Member
    Posted 6 months ago #

    It's loading the external-tracking.min.js file, but won't add any code to my content links.
    Doesn't matter if it's an external link or a link to a zip or pdf file.

    Yes, it's activated in the back-end, and I set the file extensions properly ... zip,mp3,pdf,xls

    http://wordpress.org/plugins/google-analyticator/

  2. Video User Manuals
    Member
    Plugin Author

    Posted 6 months ago #

    Hi,

    Can you please confirm you have checked in the real time stats in Google Analytics that its not tracking.

    Thanks

  3. rafi401
    Member
    Posted 6 months ago #

    I am having the same problem.

  4. Video User Manuals
    Member
    Plugin Author

    Posted 6 months ago #

    Hi Rafi401,

    Can you confirm you have checked the real time tracking in analytics and the events are definitely not tracking?

    Thanks

  5. alicelknox
    Member
    Posted 5 months ago #

    Hi, I'm also having this problem and I have a suspicion about why it's happening.

    I installed the plugin and was testing it out by looking at my real time GA stats as I clicked various external links on my site. I found that links opening in a new tab did get tracked, while links that opened in the current tab did not get tracked.

    I suspect this is because the tracking js does not have time to fire before the user leaves the page. This issue is mentioned in the download/external link tracking solution given here: http://www.blastam.com/blog/index.php/2013/03/how-to-track-downloads-in-google-analytics-v2/. Their solution adds a 400ms delay to links opening in the current tab so that the tracking code has time to process.

    That being said, I haven't investigated this plugin's code real thoroughly, so it's just a hunch.

    Hope that helps - other than this issue, this is a pretty slick plugin.

  6. femski
    Member
    Posted 5 months ago #

    I am having same problem and I have checked in Real Time event tracker.
    My website is http://avnav.us and link is a big button right on the home page:

    <span class="icon"></span>Download now For Android 4.0 or higher Tablets

    Link is generated by FluidApp Theme and I believe all the Google Analytics plugins are having trouble converting it. I don't see an onClick... code added to the link.

    Can this work or do I have to contact the Theme developer ?

    Thanks,

    -Sanjay

  7. Video User Manuals
    Member
    Plugin Author

    Posted 5 months ago #

    Hi Sanjay,

    I used the chrome google analytics chrome extension:

    https://chrome.google.com/webstore/detail/google-analytics-debugger/jnkmfdileelhofjcijamephohjechhna?hl=en

    On your site, I can see the command:

    ga(send, event, Outbound Traffic, play.google.com, https://play.google.com/store/apps/details?id=us.avnav.efb) being sent as an event.

    Are you saying these events are not appearing at all?

    Thanks

  8. femski
    Member
    Posted 5 months ago #

    I am not sure what happened. I tried again and now its working !
    I am using Universal Analytics but still its working.
    Thank you.

  9. Video User Manuals
    Member
    Plugin Author

    Posted 5 months ago #

    Hi Alice,

    Can you try installing this:

    https://chrome.google.com/webstore/detail/google-analytics-debugger/jnkmfdileelhofjcijamephohjechhna?hl=en

    And you can view if its being tracked or not.

    Thanks for the kind words

  10. alicelknox
    Member
    Posted 5 months ago #

    The extension does show that external/download links that open in the current page are being sent. So it all looks good from there, but they're definitely not showing up in my real time events, and the clicks from yesterday aren't showing up under Behavior > Events.

    However - I tried adding a delay to a link opening in the same page, and clicks to that link do appear in my real time events. Not sure why there seems to be a discrepancy between what the extension says is sent and what appears in Google Analytics, but adding the delay seems to resolve the discrepancy.

    Thanks for the help!

  11. Video User Manuals
    Member
    Plugin Author

    Posted 5 months ago #

    Hi Alice,

    Thanks for the heads up, in our testing it all works fine, thought what you say does make sense.

    We will consider this for the future.

    Thanks for your support.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.