WordPress.org

Ready to get started?Download WordPress

Forums

External images appear on blog page but not posts pages (4 posts)

  1. fbbr
    Member
    Posted 2 years ago #

    I have embedded the wordpress blog into my site http://www.freebetreview.com.au/blog/

    The images in my header come up fine for the blog home page, however when i click on the individual posts pages the images don't appear!

    I realise the images directory changes for the individual post pages but I'm unable to find a solution to this problem.

  2. peter achutha
    Member
    Posted 2 years ago #

    I had a look. I have not used your theme before but when I checked the code your blog homepage differs from the post pages in the <body ... statement.

    In your blog home page it is <body class="home blog custom-background"> but in you post pages it is <body class="single single-post postid-24 single-format-standard custom-background">

    I do not know why this is the case. I think you may want to keep them the same. Is there a CSS or set up that differs for your home page and post page?

  3. fbbr
    Member
    Posted 2 years ago #

    Thanks for your reply Peter.

    I see what you mean about the body class changing, however, I am not able to fix it. All i have done is setup a custom theme (adapted from 2010 theme) and made posts as you normally would.

    For some reason path on the images changes from:

    blog/wp-content/themes/free-bet/images..... to

    blog/post>/wp-content/themes/free-bet/images..... which means that the images don't appear.

  4. peter achutha
    Member
    Posted 2 years ago #

    Could you temporarily change your theme to Twenty Ten theme and see if the images do show up? If they do then you know that your current them has problems.

    Did you add a plugin before this happened?

Topic Closed

This topic has been closed to new replies.

About this Topic