WordPress.org

Ready to get started?Download WordPress

Forums

External blog editor cannot access blog (9 posts)

  1. edventures
    Member
    Posted 8 years ago #

    I have a WordPress 2.0.2 installation on my site (http://edventures.whitemountaintech.net). I've been trying to configure both Flock and Performancing to act as an external blog editor.

    Both recognize the blog and prompt for username/password and attempt to log in. But both editors kick back an error which states "Login error. Please check your username and password for errors and try again."

    Yet the same username and password allow me access to the blog when logging directly into the WordPress installation. This and the fact that I have had no problems accessing my old wordpress.com account through both of these apps, leads me to believe that the problem is with the installation and/or configuration of my blog.

    So I am at a loss and I'm not sure where to start looking. Any gurus out there have any flashes of brilliance for me?

  2. johnoz
    Member
    Posted 8 years ago #

    Sound to me like you might NOT be using the user name and password from your config.php? But instead are using your WP login details.

    That's all I can think of. Hope it helps..

  3. edventures
    Member
    Posted 8 years ago #

    Isn't the username in the wp-config file simply used to access the mySQL db?

    Although I did try it to see if it had any effect - I received the same rejection letter.

    I am wondering if it is a permissions issue with the files in that they won't allow external access but I am not sure which file would control login access. Hmmmm...

  4. johnoz
    Member
    Posted 8 years ago #

    Sorry. I gave you bad information.

    I point Performancing to the xmlrpc.php file

    eg http://whatever/wordpress/xmlrpc.php

    and I use the same login details I use to access the dashboard.

  5. edventures
    Member
    Posted 8 years ago #

    That's what I tried as well. It sees the blog, brings up the login screen and then promptly fails to authenticate. I even went so far as to reinstall the app. The .htaccess is the standard mod_rewrite with no additional tweaks.

    I'm out of ideas at this point.

  6. johnoz
    Member
    Posted 8 years ago #

    I've since uninstalled Performancing as I can't see that much difference in using it vs the WP editor.

    I mostly use ECTO http://ecto.kung-foo.tv/ -- I think you can get a demo.

  7. kickass
    Member
    Posted 8 years ago #

    Damn, you're using the newest version? There were problems with earlier versions. Also, sometimes the server itself imposes filesize upload limits that can conflict.

  8. edventures
    Member
    Posted 8 years ago #

    Ok, so I am still having problems.

    Checked with my host and they had me add my IP range to the mySQL authorized IP list. Done. Still no luck.

    It seems to keep kicking back the authentication credentials as I am prompted for username/password and I use the same creds that allow me access directly to my blog.

    The host mentioned something about class-IXR.php but I have no idea how/why that would affect remote accessibility.

    Ack!

  9. jedbro
    Member
    Posted 8 years ago #

    Hi Guys.
    According to a post by a member at Performancing
    (http://performancing.com/node/2968#comment-9508),
    a way to fix this is as following;

    1) Under the Account settings, where the API URL is found
    (see image: http://performancing.com/files/handbook/wizard4.jpg)
    Check the 'Advanced Settings' check box.

    2) Then Check the 'Use boolean for Publishing" option.

    Please post your results here:
    http://performancing.com/node/2968
    or directly to me
    http://jedbrown.net/contact

    As I would love to get this issue resolved for the next version of Performancing. This seems to only happen to some wp users on certain hosts, so the more information the better.

    Thanks, and sorry you are having issues.

    -Jed

Topic Closed

This topic has been closed to new replies.

About this Topic