WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Extended URLs broken (9 posts)

  1. gfindlay
    Member
    Posted 7 years ago #

    As with all plugins that do this, the Permalink Validator breaks any plugins that use extended URLs, as in:

    http://mysite.com/forum?forum=6&page=1

    and just changes it to

    http://mysite.com/forum/

    No-one has got one of these plugins right yet

  2. snakefoot
    Member
    Posted 7 years ago #

    Have updated the Permalink Validator to version 0.4, which should fix issues with bbPress integration.

    What forum software are you using ?

  3. snakefoot
    Member
    Posted 7 years ago #

    See that you are using the Simple Forum plugin.

    Maybe I should implement an option to exclude pages from being validated for the different forum software solutions out there.

  4. snakefoot
    Member
    Posted 7 years ago #

    Have updated the Development Version with a little hack, so you can add urls that should not be included in validation.

    After installing the plugin use the plugin editor and modify the Permalink Validator code so the $excludes array contains the sub-pages to exclude from validation.

    Guess I'm a lazy programmer for not creating a proper plugin options interface.

  5. gfindlay
    Member
    Posted 7 years ago #

    I grabbed the dev version, put "/forum" in the excludes line and voila, happy bunny again.

    Thanks.

  6. jimtomas
    Member
    Posted 6 years ago #

    Am I missing something?

    On IIS using ISAPI rewrite. WordPress is installed at the root of the site. I have a custom html page I'd like to display, that is not part of wordpress, located at /state/index.html . I added "/state/" to the excludes array, with no change. The only way to get this page to show up is to type in the full URI to the file /state/index.html . Is there anyway to tell my ISAPI rewriting module to ignore this directory (state) altogether?

  7. snakefoot
    Member
    Posted 6 years ago #

    Try adding this to your isapi_rewrite httpd.ini, it should redirect any request for anything located below the state folder:

    RewriteRule /state/(.*) /state/$1 [L]

    Since the pages are not part of WordPress then you don't have to modify the Permalink Validator.

  8. robanna
    Member
    Posted 6 years ago #

    I'm using iis too and I'm having a problem with a static front page.
    I'm using PV .5 and WP 2.3.1
    My permalink structure is:
    /index.php/%year%/%monthnum%/%day%/%postname%/

    I tried to add /news-and-events/ and /index.php/news-and-events/ to the $exclude array but it still returns to the front page

    http://www.northjeffco.org/blog is the front page
    and http://www.northjeffco.org/blog/index.php/news-and-events is the posts page.

  9. snakefoot
    Member
    Posted 6 years ago #

    A bug was introduced in Permalink Validator 0.5 during a code cleanup. Have fixed the bug, so update to ver. 0.6 and it should work.

    Sorry about the trouble

    -Rolf

Topic Closed

This topic has been closed to new replies.

About this Topic