WordPress.org

Ready to get started?Download WordPress

Forums

Extended Live Archives (6 posts)

  1. varresa
    Member
    Posted 8 years ago #

    Hello there!

    I am getting the following errors after I activated the Extended Live Archives Plugin (which my theme, unsleepable, README says I should be using). I get these errors when I go to the options page in order to configure the plug-in:

    "Unable to create cache directory. Check your server credentials on the wp-content directory."

    "Warning: mkdir(/home/renee/public_html/varresa/wp-content/af-extended-live-archive/): Permission denied in /home/renee/public_html/varresa/wp-content/plugins/af-extended-live-archive/af-extended-live-archive-options.php on line 120"

    I checked that file, but the error doesn't really mean anything to me since I am quite new at this. I'd love some help getting the archive to work since currently I don't have any!

    Thanks!

  2. varresa
    Member
    Posted 8 years ago #

    Update:

    I'm still getting a similar error, but now the error line # has changed:

    Warning: mkdir(/home/renee/public_html/varresa/wp-content/af-extended-live-archive/): Permission denied in /home/renee/public_html/varresa/wp-content/plugins/af-extended-live-archive/af-extended-live-archive-options.php on line 239

    I'm still stuck on this one - I have no working archives! Yikes!

  3. Chris_K
    Member
    Posted 8 years ago #

    Never used the plugin, so no clue what it is up to. But based on that error, it would appear that it expects
    /home/renee/public_html/varresa/wp-content/af-extended-live-archive/
    to be writable by the server process. If you look at the directory (perhaps via a term or FTP) what is the current owner and permissions of that directory?

  4. varresa
    Member
    Posted 8 years ago #

    The permissions are set to "777." I changed them to that - they were at "755." The owner and group have different labels. I did read something about the owner having to be (myself), so I deleted the file, recreated a next txt file, uploaded it, but the owner didn't change at all. I'm not sure what else to do.

    At this point, I'd really be happy with any archives at all - it is my theme creator (unsleepable) that said in the README to use the ELA plug-in. Perhaps something else would work though. Can you recommend one?

  5. labuschagne
    Member
    Posted 8 years ago #

    @ varessa: make sure that the permissions of the "af-extended-live-archive" folder are set to "777". not the "wp-content" folder.

    hth

  6. ElaineVigneault
    Member
    Posted 7 years ago #

    ELA seems to be really buggy. It's a neat tool if you can get it to work, but it's not perfect.

Topic Closed

This topic has been closed to new replies.

About this Topic