WordPress.org

Ready to get started?Download WordPress

Forums

Extended Characters and Character Codes (7 posts)

  1. Thorne
    Member
    Posted 8 years ago #

    I've been testing WordPress for about two weeks. I found this to be the best way to write/edit posts:

    1. write/edit the post in Microsoft word. Type extended characters into the document.
    2. copy and paste the post into the WordPress Write Post window.
    3. save the post and voila -- the extended characters are replaced by the correct codes (like &#8322)

    This morning, I noticed that my extended characters had gone haywire. They weren't appearing correctly in the blog.

    I did a reboot and the problem is gone, but something has changed. It used to be that when I saved a post, the extended characters got converted. Now, they as extended characters after the post is saved!

    The characters show up just fine in the blog. Still, I'm trying to figure out what changed and why. Any ideas? Thanks

  2. moshu
    Member
    Posted 8 years ago #

    I found this to be the best way to write/edit posts:

    That's a very bad idea, not "the best" way, sorry.
    Write in a plain text editor if you want to keep your sanity... :)

  3. Thorne
    Member
    Posted 8 years ago #

    moshu:

    Why not? WordPress was converting the characters for me just fine. If I work in a text editor, I have to convert the extended characters manually.

    Is there a better way to change them? Thanks

  4. Thorne
    Member
    Posted 8 years ago #

    moshu:

    Let me put the problem this way. I'm typing my post in the WordPress Write Post window. I don't bother inserting paragraph markers. What I find is that, if I put an extra line between each paragraph, then when I save the post, WordPress adds the paragraph markers for me.

    Likewise, if I type a curly quote or an apostrophe or an em dash, WordPress converts them to the appropriate character codes for me.

    That's the way it was working. Now, WordPress adds the paragraph markers, but it doesn't convert the extended characters. That's a problem. How do I get it to convert extended characters again when I save a post?

    Thanks.

  5. moshu
    Member
    Posted 8 years ago #

    I meant copying from MS Word is the worst idea ever.

    As for your extended characters... I often blog in other languages than English (with many diacritics) and/or with non-Latin alphabet, too, but I never had any problems with WP not doing what I wanted. It's true, I kept the original utf-8 encoding, because all the others just create mess.

  6. Thorne
    Member
    Posted 8 years ago #

    So . . . your experience is that you should be able to type extended characters in your posts (using the WordPress Write Post window) and they get converted when the post is saved.

    Is that they way it should work? That's how it was working for me until . . . I dunno! Something must have gone haywire.

  7. moshu
    Member
    Posted 8 years ago #

    Look at this test post:
    http://www.transycan.net/blogtest/2005/03/04/font-test/
    The first four have been done by changing the language on my keyboard, the last one just copy/paste from the original tex.
    In the pre-utf-8 era you had to have
    iso-8859-1 for English
    iso-8859-2 for HU and RO
    several options for RU and Greek... and now I just switch with ease and everything is always displayed as intended. True, I have some rules of thumb:
    - never use the wysiwyg editor
    - never use MS Words

Topic Closed

This topic has been closed to new replies.

About this Topic