WordPress.org

Ready to get started?Download WordPress

Forums

Extend Plugins Constrain Search by Compatibility (2 posts)

  1. Edified
    Member
    Posted 3 years ago #

    I'm happy that there's so many WordPress plugs but often I feel like we brag about the numbers without considering that half of them are dead and many more are outdated. I'm so very tired of wading through old plugins that aren't even compatible with WP3.0.

    I know this month is meta-cleanup month so I propose that we add a control to plugin search on wordpress.org and in wordpress' native interface to constrain a search by compatibility with a particular wordpress version.

    It seems like the kind of job computer would be good at, matching and sorting by numbers. I strongly propose this mostly for plugins but also for the theme pages.

    Cheers, Ed

  2. Edified
    Member
    Posted 3 years ago #

    It could be as simple as a pull-down box:
    Compatible with WordPress: [3.0, 2.9, 2.8 etc..]

    Also...Updated: [Within 1 Week, Within 1 Month, Within 6 Months, With 1 Year, Within 2 years]

    And Rated: [5 Stars, At least 4 Stars, At least 3 Stars, At least 2 Stars]

    That would be very very helpful. It seems like it should be fairly simple to implement. Keep the sorting options. Perhaps the rest of this can hide in a div that is revealed when someone clicks an "Options" link in the search area.

Topic Closed

This topic has been closed to new replies.

About this Topic