WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
[resolved] Expanding too much in agenda view (7 posts)

  1. mario83
    Member
    Posted 1 year ago #

    Hi all,

    I upgraded the plugin and after redoing all the css work (the design I had was gone), I can't figure out two things I hope you guys can help:

    1) In the agenda view (which is my default option), if I expand an event it suddenly shows the whole content in this preview. In the previous version of the plugin this didn't happen. Do you know how I could configure it to show just a few lines?

    2) The background in the widget agenda was covering the whole widget but after upgrading, it only covers the title, which is new to this version. Do you know how to fix this?

    Many thanks!
    mario

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. Richard
    Member
    Posted 1 year ago #

    Hi mario83,

    1. This is new functionality of the 1.8.3 version. If you wish to change this please:

    replace: <?php echo apply_filters( 'the_content', $event->post->post_content ) ?>

    with

    <?php echo substr( apply_filters( 'the_content', $event->post->post_content ), 0, 35 ) ?>

    File location - agenda.php
    line 94

    2. Please provide a link and we can take a closer look and provide you with some code to change this.

    I hope this helps!

  3. mario83
    Member
    Posted 1 year ago #

    Hi Richard,

    1) I tried that but it breaks the agenda view by no applying any css. Don't know why.

    2) Here is the link: http://www.centroamate.com/agenda-de-eventos/. On the left sidebar, the widget should have a slight darker background that after upgrading only covers the title of the widget, but not the whole of it.

    By the way, is there a way to open the events in the agenda view if using IE7 or IE8? It seems not to be working...

    Many thanks for your help!

  4. bnkeith22
    Member
    Posted 1 year ago #

    Hi Mario,

    To edit the background colour of your widget, you need to edit the code below (the bolded part) and copy and paste it into the bottom of your wp-content/themes-ai1ec/vortex/style.css

    #sidebar .widget {
    background-attachment: scroll !important;
    background-clip: border-box !important;
    background-color: transparent !important;
    background-image: url("images/widget-bg.png") !important;
    }

    *You need to change the background colour to whatever you'd like, and remove the "background image" line.

    In regards to your expanded Agenda view - there will be many options to customize what you want to appear in v1.9 - This upgrade will be available in roughly 2 weeks.

    Just a reminder as well, you need to create a child theme before editing your css or al; of your customizations and changes will overwritten on upgrade. Here are the steps that you can follow: http://help.time.ly/customer/portal/articles/541097-how-do-i-create-a-child-theme-

    Thanks

  5. Richard
    Member
    Posted 1 year ago #

    Hi Mario,

    I am going to mark this as resolved as we have not heard from you in over a month.

    Regards.

  6. sjamieson
    Member
    Posted 1 year ago #

    Hi

    I'm looking for the same solution regarding the Agenda view expanded view, only for version 1.9.3.

    How can I restrict the agenda view from diplaying the entire post content, and restict it to just a preview like in previous versions?

    I tried the above code change but it messed up the formatting completely.

    Appreciate your help.

    Thanks,
    Si

  7. bowoolley
    Member
    Posted 1 year ago #

    Another request for a fix; I have a 600x800 image in a post, and the whole thing shows up in agenda view. Looks pretty nasty...

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.