WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Existing Pages on multisite giving 404 (7 posts)

  1. CircleReader
    Member
    Posted 3 years ago #

    (Continued from http://wordpress.org/support/topic/pages-not-showing-permalinks-issue-using-multisite)

    On my 3.1a multisite install, one of the sites has started returning a 404 Not Found whenever I try to view a Page. I can create, edit & update pages without a problem, but not view them from the front end. Pages on the other sites in the network are not affected.

    Thoughts?

  2. Have you tried the reset permalinks trick? (well, not a trick, it just flushes the cahce)

  3. CircleReader
    Member
    Posted 3 years ago #

    Went to Settings => Permalinks on the affected blog, selected "Default" and saved it, re-selected the permalink structure I wanted and saved it -- and voila, the Page is back.

    Thanks, matey!

  4. rlgrobert
    Member
    Posted 3 years ago #

    Just installed WP 3.1 and am having the same problem. I tried resetting the permalink structure as explained above, but still getting 404s when the permalink structure is anything but "Default". I'm using a Network subdomain install and also tried it on a newly added site in this network.

    Also, these are the apache 404 pages, not the WordPress ones:

    <strong>Not Found</strong>
    
    The requested URL /sample-page/ was not found on this server.
    
    Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request.
    
    Apache/2.2.17 (Unix) mod_ssl/2.2.17 OpenSSL/0.9.8q DAV/2 mod_fcgid/2.3.6 mod_auth_passthrough/2.1 mod_bwlimited/1.4 FrontPage/5.0.2.2635 Server at dev.example.com Port 80

    Any ideas? Thank you.

  5. rlgrobert
    Member
    Posted 3 years ago #

    Found the problem. I had been testing out the BackupBuddy plugin and had restored this test network from a backup. In doing so the contents of my .htaccess had been removed. Added the original .htaccess file back and everything works.

  6. permalinks are always htaccess related :)

  7. jamie3000
    Member
    Posted 2 years ago #

    I had this problem too... It was htaccess related.

    I did not figure out how to confirm that my .htaccess files were being loaded. Reading up on the Apache docs, it says that using .htaccess should be avoided. My server had them (.htaccess files) disabled. (Running my own apache server here.)

    Rather than put the directives in the .htaccess file, I put them into my httpd conf file. Now my (non-default) permalinks work for multisite, and I get better performance too.
    (Okay, I am just echoing the performance thing from the Apache docs. I have no idea what the performance difference is.)

    For me, I edited /etc/httpd/conf.d/website.conf and inserted at the top:

    <Directory /var/www/html>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    etc...
    </Directory>

    and it started working.

Topic Closed

This topic has been closed to new replies.

About this Topic