WordPress.org

Ready to get started?Download WordPress

Forums

Existing Page gives 404 status (14 posts)

  1. mtaylor924
    Member
    Posted 6 years ago #

    On the site I administer, we use WP as a CMS - only Pages, not Posts.
    One of the pages in particular - the one that holds our sitemap - is returning a 404 status code to Google, so it's not getting crawled, and Webmaster Tools shows a crawl error. However, the correct page content still appears when I browse to the page in FF or IE. Double checking the status code reveals that the server does in fact give a 404 code along with the correct content.

    I have disabled all the plug-ins and the error still appears, leading me to believe this problem is within WP. This is the only page that returns a 404 error, all the others return 200.

    Any idea why this particular page would return an incorrect status code, without redirecting to the 404 template set up in WP?

  2. hotkee
    Member
    Posted 6 years ago #

    Maybe you are including something into the page dynamically which isnt being found?

    Try recreating the page - delete completely and recreate as a new one.

  3. mtaylor924
    Member
    Posted 6 years ago #

    Nope, that didn't work. I deleted the page under "manage pages" then created a new page under "write page". Again, the content appears correctly in the browser but the server gives code 404, meaning the content will be invisible to search engines.

  4. mtaylor924
    Member
    Posted 6 years ago #

    OK...this gets weirder...
    I changed the permalink from "/sitemap/" to "/sitemap1/" and it gave code 200, as it should.

    After changing permalink back to "/sitemap/" it gives 404 again! What gives? Does WP have something against this particular permalink?

  5. hotkee
    Member
    Posted 6 years ago #

    Your permalink should be more than just one part - for example

    /category/postname

  6. mtaylor924
    Member
    Posted 6 years ago #

    My permalink structure is "/%category%/%postname%/"
    When writing Pages (capital P) in WP that have no parent Page, they automatically default to "/page-slug/" only. At least that's how they have been for all main level Pages, and only this one has the problem.

    Can anyone take a look and let me know what I'm missing?

    http://www.thescenestealers.org/

  7. mtaylor924
    Member
    Posted 6 years ago #

    Still haven't fixed the problem...can anyone take a look and let me know if I'm missing something obvious?

  8. mtaylor924
    Member
    Posted 6 years ago #

    Sorry to keep bumping, but the problem still exists. Does anyone have any ideas?

  9. mtaylor924
    Member
    Posted 6 years ago #

    Anyone?

  10. iridiax
    Member
    Posted 6 years ago #

    I have a page with the permalink sitemap on my WordPress 2.5.1 site and it works just fine for me.

    Does your theme have a 404.php? Do you have a directory or some other file named sitemap on your site? I noticed that you are using the Google (XML) Sitemaps Generator for WordPress plugin, could this have something to do with it?

  11. iridiax
    Member
    Posted 6 years ago #

    Another thought, I've seen sites with custom 404 pages that serve up a sitemap instead of a standard not found page. Did you ever do anything like this? I'm wondering how a page that generates a 404 can still show up.

  12. mtaylor924
    Member
    Posted 6 years ago #

    Hi iridiax,

    Yes, I have a separate 404.php page, which shows up successfully when I type in a URL for a permalink that doesn't exist.

    My 404 page does show a sitemap as well, to help people who type in the wrong URL. It uses html comment code to activate a sitemap plugin. But the template on my 404 is different from the rest of the site so I know for a fact that the /sitemap/ permalink I see in FF or IE is not my 404 page.

    Also, removing the plugin html comment code and writing in my sitemap info by hand doesn't solve the problem - the "/sitemap/" permalink still returns a 404, despite serving the proper content.

  13. mtaylor924
    Member
    Posted 6 years ago #

    No amount of google searching has provided an answer - everything either points back to this post, or talks about creating a custom 404.php.

    Any other ideas?

  14. s.lepler
    Member
    Posted 5 years ago #

    I am having a similar problem. I found a solution, if i change my permalinks back to a non-custom setting the 404 errors go away. So I have learned to be content having index.php in my links if thats the trade off for google indexing.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags