WordPress.org

Ready to get started?Download WordPress

Forums

Exhibit Permission Problems (11 posts)

  1. depiction
    Member
    Posted 9 years ago #

    I have installed Exhibit for my WordPress blog. However when I try to upload an image or viewing the contents of a folder created through Exhibit to store photos.
    When I try to upload a new image, I get the following error.
    Warning: imagecreatefromjpeg(/home/depicaac/public_html/blog/galleryimages/matt/Edited Ocean View from Amelia Inn.JPG): failed to open stream: Permission denied in /home/depicaac/public_html/blog/wp-content/plugins/exhibitimg/exhibit10f.php on line 618
    Warning: imagesy(): supplied argument is not a valid Image resource in /home/depicaac/public_html/blog/wp-content/plugins/exhibitimg/exhibit10f.php on line 621
    Warning: imagesx(): supplied argument is not a valid Image resource in /home/depicaac/public_html/blog/wp-content/plugins/exhibitimg/exhibit10f.php on line 622
    Warning: copy(/home/depicaac/public_html/blog/galleryimages/matt/Edited Ocean View from Amelia Inn.JPG): failed to open stream: Permission denied in /home/depicaac/public_html/blog/wp-content/plugins/exhibitimg/exhibit10f.php on line 648
    Warning: chmod(): Permission denied in /home/depicaac/public_html/blog/wp-content/plugins/exhibitimg/exhibit10f.php on line 655
    Warning: imagedestroy(): supplied argument is not a valid Image resource in /home/depicaac/public_html/blog/wp-content/plugins/exhibitimg/exhibit10f.php on line 658
    Edited Ocean View from Amelia Inn.JPG uploaded successfully, 415k bytes.
    (It says it was succussfully uploaded, but it doesn't upload.)
    When I try to view the contents of a folder, I get the following:
    opendir(/home/depicaac/public_html/blog/galleryimages/test): failed to open dir: Permission denied in /home/depicaac/public_html/blog/wp-content/plugins/exhibitimg/exhibit10f.php on line 485
    I see that these are alot of permission errors. I have tried 777,755, and 666 permissions for both the "galleryimages" folder folders mentioned in the config file. I'm not sure what else I could try.

  2. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Have you correctly put the file permissions in the exhibit config as well. I did this for someone recently, and it needed the config file to have the same numbers for the permissions as the folders themselves.

  3. depiction
    Member
    Posted 9 years ago #

    I just tried them again verifying permissions in the config matched the actual folder permissions. I'm still getting the same errors.

  4. depiction
    Member
    Posted 9 years ago #

    anyone have any ideas?

  5. depiction
    Member
    Posted 9 years ago #

    I've tweaked it for the past few hours. I have been able to cut it down to 2 errors.
    This is what I get when I upload an image:
    Warning: chmod(): Permission denied in /home/depicaac/public_html/blog/wp-content/plugins/exhibitimg/exhibit10f.php on line 655
    sunriseonocean_small.jpg uploaded successfully, 65k bytes.
    (It successfully uploads the image, but I would like to get rid of this error message.)
    When I try to view the contents of a directory created in the admin panel, I get the following:
    Warning: opendir(/home/depicaac/public_html/blog/galleryimages/matt): failed to open dir: Permission denied in /home/depicaac/public_html/blog/wp-content/plugins/exhibitimg/exhibit10f.php on line 485

  6. Anonymous
    Unregistered
    Posted 9 years ago #

    bump

  7. Mark (podz)
    Support Maven
    Posted 9 years ago #

    I'll give it a go ...
    In 'exhibit10.cfg' what do you have on:
    101-104
    # use_chmod is the chmod setting to use for created files.
    # Set to 0 if you don't use it. 0664 is a good setting.
    # See also below: use_chmod_dir
    use_chmod=0
    and
    195-197
    # use_chmod_dir is the chmod setting to use for created directories.
    # Set to 0 if you don't use it. 0777 is a good setting.
    use_chmod_dir=0

  8. depiction
    Member
    Posted 9 years ago #

    I'm using the recommended settings; 0664 and 0777. I first tried taking the 0 off in front of each number since I have never seen chmod with 4 values before. I have tried 0664, 0644, 0755, and 0777 for the first setting (101-104). I have tried almost all possible settings for the second one; 0755, 0777, 0666, 0664, 0644. I have probably worked for a least an hour on it trying different chmod values, but I still can get it to work.

  9. Mark (podz)
    Support Maven
    Posted 9 years ago #

    Have you contacted the plugin author at all ?

  10. depiction
    Member
    Posted 9 years ago #

    No, I was going to wait and see if anyone here could solve it first. However, I will e-mail the author shortly.

  11. ringmaster
    Member
    Posted 9 years ago #

    Beware: My Linux permission knowledge is limited to getting my own stuff to work, and I'm not familiar with your setup...
    It looks like your admin panel is creating directories with a user that PHP isn't in the same group as. You might not need to have chmod settings in Exhibit. Did you try setting them to 0?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.