WordPress.org

Ready to get started?Download WordPress

Forums

Exhibit 1.1c Photo Gallery Plugin (22 posts)

  1. ringmaster
    Member
    Posted 10 years ago #

    Yes, a new release.
    This one fixes a couple of known glitches and makes the Remove and Preview buttons not need to reload the page. Also, you can reorder the image sequence using little up/down buttons.
    Download from here, as usual.

  2. Anonymous
    Unregistered
    Posted 10 years ago #

    [PROBLEM] - Thanks Owen for making this tool available. I am running into a problem that I can't figure out. I installed V1.1c and I believe I'm running the latest version of WP (it says 1.2 at the bottom of my admin page. I also ran the update.php file)
    Anyway, I can't get the full images to appear in my post. For example, I edited my post and then clicked on "Insert Full Image Here". My post shows the following:
    Begin
    <!--exhibit-->
    end

    When I publish, I see the following
    Begin
    End

    If I view the sourcecode, I still see the <!--exhibit--> in the code. It's like it never gets replaced by the plugin. Any thoughts? Thanks again [STEVE]

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    [PROBLEM - CONT..] Looks like my previous post removed some of my comments. basically, I'm still seeing !--Exhibit-- when I view the source code. It does not insert the full image. Make sense? [STEVE]

  4. ringmaster
    Member
    Posted 10 years ago #

    @Steve:
    Would love to help, but your problem is unfamiliar to me. I'll have to see the site/code that it produces. If you log in and fill out your profile, a link to your site will show up every time you post a message.
    @neil:
    np. Glad you like it. :)

  5. orliville
    Member
    Posted 10 years ago #

    Could some please send me to a guide for implementing this on a Win2003 Server running MySQL+PHP+Wordpress 1.2+Exhibit 1.1c? I am receiving the following error when attempting to attach a picture:
    "Fatal error: Call to undefined function: imagecreatefromjpeg() in C:\Inetpub\wwwsite\wordpress\wp-content\plugins\exhibitimg\exhibit10f.php on line 578"
    What would I need to do to fix this? Sorry if this is very noob-ish

  6. Anonymous
    Unregistered
    Posted 10 years ago #

    @orliville:
    Please verify (through phpinfo()) that you have GD2 installed.

  7. orliville
    Member
    Posted 10 years ago #

    @Anonymous
    phpinfo isn't showing GD2. How do I install/enable this?

  8. ringmaster
    Member
    Posted 10 years ago #

    @orliville:
    You need to enable GD2 in your php.ini. Locate your php.ini on your server. It's often in C:\windows. There's a line that says:
    ;extension=php_gd2.dll
    Remove the semicolon from the front of that line. Save php.ini. Restart IIS.
    If the line is already uncommented, then I hope the 2003 server box is yours to admin, because you'll need to install a later version of PHP. I can give you instructions for this, too, if you like, but I'd rather save the lengthy description if you really need it.
    @khaled:
    Let me restate what you want to do. What you want to do is simply select an image from your site and have it appear, sans-thumbnail, in full glory right inside your post?
    Exhibit doesn't do this. :)
    Really, there's no good excuse for why it doesn't. I never planned on adding images to my posts that way and although maybe someone asked me for it in the past, I might have overlooked it to add other features.
    Here's the skinny on popup/non-popup:
    Using the popup setting (thumbnail_popup=true), Exhibit embeds its own popup code into the page. Whenever a user clicks on the image, it should pop up the image in a new window.
    Not using the popup setting (thumbnail_popup=false), Exhibit links to the post permalink with the index of the image. The full-sized image will appear where you insert < !--exhibit--> into your post. (Note that any comments I write here will have an extra space between the "<" and the "!" because the forum mangles them otherwise.) This only happens when the post is forced for display by itself ($single==true), not when it appears in a list of other posts, even if that list only has one post in it, like if you display a single days worth of posts and there was only one post that day.
    That's the basics of it. From there, it gets more complicated.
    You can define a custom popup page by setting popup_page. If this is set, then Exhibit will link to this page instead using it's own links as described above.
    You can use the exhibit_full.php file as the value of embedded_image, which is just a different WordPress template (like index.php) that will display your post when the user clicks on a thumbnail image.
    When the full-sized image is displayed on a page, if you have suppress_content=true, then your actual text content will not appear, just the full-sized image. If you use embedded_image, then also using suppress_content is a good idea.
    If you set no_pic_use_preview=true, then the first thumbnail in your thumbnail list is automatically replaced for the < !--exhibit--> when no image is specified. This is useful for formatting the page with an image when the user first arrives, because otherwise that space is just an HTML comment; blank.
    When you select one of the options in the Post Config box, it adds some code to the body of the post. Exhibit finds this code later and uses it to temporarily (for the duration of that one post) alter its behavior. If you set thumbs_at_top=true using the Post Config box, then the thumbnails will appear at the top of the post only when that post is displayed.
    There are quite a few options, and there are a ton of combinations. Some work better than others. The defaults should always work pretty good, even if they don't do exactly what you want.
    If you see a person who has implemented Exhibit in a way that you like, you can simply ask them for their config file (it's actually pretty easy to access it through your browser when you know where it's stored) and use it on your own site.
    I know I probably haven't answered your question, but now you have a little more detail on the presentation methods. How would you suggest I best implement the display style you suggest? Should I just insert an image tag into the post body when you click on a button in the file picker? Seems easiest.

  9. orliville
    Member
    Posted 10 years ago #

    @ringmaster
    After enabling GD2 in the php.ini file and restarting IIS, I received the following error:
    -Unknow(); unable to load dynamic library'./php_gd2.dll' - The specified module could not be found-
    Do I need to install a later version of PHP? And yes, this is my server box, so I have free access to srew it up serverely ;)
    Oh yeah, I currently have PHP Version 4.3.7

  10. ringmaster
    Member
    Posted 10 years ago #

    The DLL comes shipped with the PHP install. You need to set the extension_dir value in php.ini to point to the PHP extensions subdirectory. After you do that, you should have no error and be able to enable any of the other extensions, too.

  11. orliville
    Member
    Posted 10 years ago #

    @ringmaster
    GD2 is now working fine. Thanks for the help! This is really a great plugin, thanks for all your hard work and patience.

  12. symantix
    Member
    Posted 10 years ago #

    @RM
    In the last version, I could click on a thumbnail in the left-hand column of included pictures, and an img tag with an address to the thumbnail would automatically appear. It doesn't do this anymore. That was really useful for me, because I could take out the "/t" in the address, and have a quick way to insert full size images throughout my articles.
    Do you think you could put that functionality back in? And maybe instead of it inserting the thumbnail, it would insert an img tag for the full size image? Even better, how about the ability to click an icon text to an image in the right column to insert an img tag, so that you don't have to actually include the image in the thumbnail list in order to insert it into article.
    If you want to see what I mean, just check out my site. Some of the posts, like the one at the top for the moment, have images in them, but no thumbnail sets. Yet I have used your plugin to insert all of the images in all of the posts on my site. I just include the image, click the thumbnail to insert the tag, then remove it. If I could insert an auto img tag without including the image in the thumbnail list in the first place, that would be even sweeter.
    But, if you can, at least put the original functionality back in, of being able to click the thumb of an included image in the left column, to auto insert an img tag.
    Also, I don't see the ability that you're talking about. I see that you can include an image without saving and continuing, but if you want to remove it, you still have to save and continue. What am I missing?
    Thanks again, my friend.

  13. khaled
    Member
    Posted 10 years ago #

    Owen, thanks for the speedy response, I'm glad I wasn't missing anything, i.e the fact that Exhibit doesn't actually do that ,..right now is fine :), hopefully that will change :).
    I'm still trying to understand the idea, I think I've got a grasp of it, just need you to confirm this little thing. Can I add multiple tags within a post. You say that there are many configurations, is there a specific type of configuration that should be followed? You see if I put the following code in the post it doesn't work.
    < !--exhibit:thumbnail_popup=0--> <img src="http://www.brokenkode.com/images//t/picture.jpg" alt="©2004" border="0" />< !--exhibit-->
    In this case the picture is called picture.jpg and all that happens is a thumbnail with a popup, so I'm a bit confused about how to go about putting the tags etc inside the post.
    The reason I think Exhibit is a fantastic plugin is because it basically integrates ftp access to my computer with my blog and I can chuck in my images without having to ftp them into a directory first, which isn't that much of a hassle but I like the free reign you get and the ease of inserting images at will while you're blogging.
    So yeah I think an insert button would be a cherry on the cake. Having a small link after you've chosen the image and have it displayed on the left column, under the remove button, you could have a insert full image within post.

  14. Anonymous
    Unregistered
    Posted 10 years ago #

    Hi, just installed version c and I get this error:
    Database error: [Unknown column 'picorder' in 'order clause']
    SELECT ID FROM wp_exhibit WHERE post_ID = 25 and preview = 1 ORDER BY picorder;
    I goes away if i just save the post again, but it can be annoying if you have many posts with images..

  15. Anonymous
    Unregistered
    Posted 10 years ago #

    oups, my mistake. You only need to edit one post before the picorder-column-thingie goes away. Not a big problem then.
    Thanks for the plugin! It's very good!

  16. ringmaster
    Member
    Posted 10 years ago #

    Drat.
    For whatever reason, every time I write a masterpiece post that answers all of your questions regarding life, the universe, and everything, the WordPress forum eats it.
    There are a couple of bugs in 1.1c, most notably the one Xyth mentioned, and one I found early today where adding an image to the list doesn't add the proper interface.
    I hope to release a fix for all this miscellaneous junk tomorrow. If you find anything else, post it and I'll try to get to it before 1.1d.
    @neil:
    I'll add your change to the popup script. Thanks.
    @khaled:
    The bulk of my previous post explained how to do exactly what you want with the tools you've got. I'll give it another shot.
    To make images everywhere only appear full-sized:

    • Use preview_like_single=true in your config file or < !--exhibit:preview_like_single=true--> in your post body.
    • Use no_pic_use_preview=true in your config or < !--exhibit:no_pic_use_preview=true--> in your post body.
    • Use thumbnail_popup=false in your config or < !--exhibit:thumbnail_popup=false--> in your post body.
    • Set your image as a preview image in the post.
    • Put < !--exhibit--> where you want the image to appear full-sized in the post.
    • If you have only one image in you post, you can get rid of the thumbnails by adding < !--nothumbs--> to your post body.

    That might do it. I checked it earlier and it worked, but these settings are from memory and possibly faulty or incomplete. Be aware that all of the comments contain an extra space so that they'll appear on this message board and you should remove them. Note that if you make a copy of your config file and make the changes to that, that you can make all of these changes at once by specifying a different config file for that one post. For an example, see how the main exhibit10.cfg creates a Post Config entry for the pictorialis.cfg file. In fact, I should probably make this a default option in the d release.

  17. symantix
    Member
    Posted 10 years ago #

    I feel so neglected...

  18. ringmaster
    Member
    Posted 10 years ago #

    @symantix:
    Sorry. Fixing the bugs I was talking about above will fix your problem too. :)

  19. khaled
    Member
    Posted 9 years ago #

    Ah ha. Now it all makes sense, powerful little plugin isn't it. Like you said loads of combinations.
    Now I've picked up on something else, and sorry to be really dim about this but if I didn't ask I wouldn't get it, and believe me I'm going to write a bit more indepth introduction to this plugin, but here's my next question which I know you've mentioned but I want to be perfectly clear about. You've said that you can set the preferences in the config file, not clear on that point. I've understood that in order to stop me from having to put this code in every single time I can sort it out once and bob's your uncle, buuut I'm not sure which file it is, and if it's the one I'm thinking of, the comments on the page say not to modify.....is there a config file I have to make and attach it? Not being lazy just wanted to know which way to go about it.
    Once again thanks for all the help here, it's well appreciated.

  20. ringmaster
    Member
    Posted 9 years ago #

    No worries.
    The config file is "exhibit10.cfg". With the "cfg" on the end. If I was a good user-friendly programmer, my filename would be "exhibit_config.cfg", but I'm a mean old nasty grizzled 8.3 filename convention programmer, which still doesn't make sense because this filename is 9 characters long.
    Anyway, yeah, feel free to goof around with the exhibit10.cfg file as much as you like to alter the default settings of Exhibit. The file that you're not supposed to change (but who am I to stop you?) is the exhibit10.php file, which contains a mirror of all of the default options. This is so if you leave an option out of the config file, it still gets a good setting. This is important when you upgrade, since you can keep your old config file and Exhibit uses the defaults for any new features even though your old file doesn't specify them.

  21. Rog43
    Member
    Posted 9 years ago #

    Not sure which version of Exhibit I'm using. (Recommend that you title the blue Exhibit in the box's upper left to reflect the version)
    Anyway, nice plugin! You are truly GD-Man!
    If I load a .wmv file onto my site, Exhibit will list it and provide a 'no thumb' thumbnail for it but when the post is published and I click the thumbnail, I get a picture display page, not the media player.
    If this is normal, then I guess somebody needs to make some changes to the code so it knows what to do when it gets a movie file. I could probably do this. Any tip as to which file to tweak?

  22. ringmaster
    Member
    Posted 9 years ago #

    @Rog43:
    This is something that I meant to do for myself and never got around to. An unfinished feature.
    Ok, you can have a go at it. It'll be nice to have help. :)
    The files you want to look at are exhbiti10p.php. The 'p' file outputs stuff to the WordPress page. You'll want to look for a class variable called $exc->full_image_display. It's only used once.
    What you should do is change full_image_display into an array of file types in the config file (and in exhibit10.php), with the key being the file extension and the value being the tags to use to display it (ie- ... = array('.jpg'=>'<img src=IMGSRC/>' ... )). Then change the line in exhibit10p.php to use the appropriate full_image_display element for the filetype displayed (like$exc->full_image_display['.jpg']).

Topic Closed

This topic has been closed to new replies.

About this Topic