WordPress.org

Ready to get started?Download WordPress

Forums

Exhibit 1.0c Photo Gallery Plugin (88 posts)

  1. ringmaster
    Member
    Posted 9 years ago #

    @wayward bob:
    Sounds like PHP might be timing out before it finishes making all of your thumbnails. If it starts over each time, it might behave exactly as you describe. Either that or a filename in that directory is causing problems for the script.
    My suggestion, just to try: split those images into a couple different directories, and add the directories separately.
    This problem shouldn't exist in 1.1 because it builds thumbnails in a different way, and you can create thumbnails individually, too.
    @mufflonen:
    I don't want to say to you "works for me", but it does. Perhaps are there odd characters in your captions? Try deleting anything "odd" like punctuation or symbols.
    I'm at a loss as to what could cause this. Maybe if you sent a snapshot of your exhibit table? (ringmaster [at] midnightcircus [dot] com) Send a warning email first so I can add you to my spam whitelist, otherwise your attachment will be deleted and your email incinerated. :)

  2. valiot
    Member
    Posted 9 years ago #

    Ringmaster, Thank You for your response.
    I'm presently implementing a conference related blog and would like the features I discussed to be in place before the launch. Any idea when 1.1 will be released? As if you don't have enough pressure already...

  3. jmb85
    Member
    Posted 9 years ago #

    Hey.. I am having some problems. I am using wordpress 1.2 mingus.. and when i try to use the plugin i get this error:
    "Database error: [Table 'blog.wp_exhibit' doesn't exist]
    SELECT ID FROM wp_exhibit WHERE post_ID = 1 and preview = 1;"
    I tried creating a table manually and still recieved errors. I copied all of the files as instructed in the .php file. Does anyone know how to solve this? Thanks.

  4. ringmaster
    Member
    Posted 9 years ago #

    @jmb85:
    Where does this error appear? Does Exhibit prompt you to install its table on the advanced editing page?
    @valiot:
    Man... Demanding, aren't we? :) I have a few more things to do before the code is ready. Maybe sometime this week.

  5. jmb85
    Member
    Posted 9 years ago #

    It appears when I do this portion of the instructions :
    "Edit an existing post (or draft) and click on the link in the Exhibit area to create the required database table (if it doesn't already exist)."
    I don't recall being prompted in install/create a table.. it just says it is unable to do so.
    Thanks.

  6. ringmaster
    Member
    Posted 9 years ago #

    Is there no Exhibit area on your advanced edit form at all? Did you insert the code into the advanced edit php file as per the instructions? Where on the page does the error appear?

  7. jmb85
    Member
    Posted 9 years ago #

    Yes, I did add the code in "edit-form-advanced.php" if that is what you mean.. The error message shows up right next and under the topic.

  8. symantix
    Member
    Posted 9 years ago #

    ringmaster, is there any way that I can get the corrected style sheet so that my thumbs look right in IE? Will the css file for your 1.1 version work in my 1.0c version? If not, is there something that I can change in my current css style sheet which will correct it?
    Thanks in advance.

  9. ringmaster
    Member
    Posted 9 years ago #

    @symantix:
    Try changing this element in your CSS file-
    #exhibit_thumbs {
    border-width: 1px 0px 1px 0px;
    border-color: #cccccc;
    border-style: dotted;
    width:100%;
    }

  10. ringmaster
    Member
    Posted 9 years ago #

    That's a tough one. Looking at the 1.1 code, I'd have to move about 30 lines of code to get this to happen. I'll think more on it after lunch. Suffice to say that unless you're going to dig heavily into the code, it's not going to happen with what you've got.

  11. symantix
    Member
    Posted 9 years ago #

    Do you think it's worth your time to write into the code? Like maybe have a < !--exhibitfront-- > tag, used only to display an image on the front page? I think it would make your excellent plugin more perfect, as it would facilitate the creation of beautiful front page compositions.

  12. jmb85
    Member
    Posted 9 years ago #

    Hey.. I solved the problem i was having before.. so I went to post an image with the thumbnail showing up on top. I saved it and all looked well in the preview, but then when I went to view the blog i got this error:
    "Parse error: parse error, unexpected T_CONSTANT_ENCAPSED_STRING, expecting ')' in H:\apachefriends\xampp\htdocs\blog\wp-content\plugins\exhibit10.php(146) : eval()'d code on line 1"
    Now the thumb still showed up.. but that message was above, on top of the page, then when i went to edit the post, it is the only thing that showed up in the Exhibit box.

  13. Anonymous
    Unregistered
    Posted 9 years ago #

    I'm not able to add photos to my weblog. I do not get a button to add photos, see this screenshot.
    I use Exhibit 1.1a and WordPress 1.2 mingus. I have the GD library installed (I'm also able to create thumbnails) and my PHP version is 4.3.3
    Do you have an idea what the problem could be?
    Greetings,
    Dj 2Be

  14. ringmaster
    Member
    Posted 9 years ago #

    Click on the small photo-like icon next to the image of the recycle bin. That will create a thumbnail for the listed image. When the icon is large, click on it and that will add the image to your post.
    There is no problem, just poor documentation on my part. :)
    If you create a new directory (by clicking the link at the top of the file picker) you can upload files into it. Then you can add teh whole directory by clicking the folder icon next to the directory name.
    I'm sure you'll get the hang of it.

  15. Anonymous
    Unregistered
    Posted 9 years ago #

    It doesn't work for me. I tried what you told me, but when I click on the photo-like icon next to the image of the recycle bin, the icon doesn't become large. It keeps small and the text it says stays: "click to create a single thumbnail".
    When I tried to open a directory created by exhibit I get to following error:
    Warning: opendir(): SAFE MODE Restriction in effect. The script whose uid is 516 is not allowed to access /home/virtual/site13/fst/var/www/html/dj2be/wordpress/images/1 owned by uid 48 in /home/virtual/site13/fst/var/www/html/dj2be/wordpress/wp-content/plugins/exhibitimg/exhibit10f.php on line 398
    Warning: opendir(/home/virtual/site13/fst/var/www/html/dj2be/wordpress/images/1): failed to open dir: Success in /home/virtual/site13/fst/var/www/html/dj2be/wordpress/wp-content/plugins/exhibitimg/exhibit10f.php on line 398
    Is this my problem why I'm not able to get Exhibit to work for me?
    Greetings,
    Dj 2Be

  16. Anonymous
    Unregistered
    Posted 9 years ago #

    It doesn't work for me. I tried what you told me, but when I click on the photo-like icon next to the image of the recycle bin, the icon doesn't become large. It keeps small and the text it says stays: "click to create a single thumbnail".
    When I tried to open a directory created by exhibit I get to following error:
    Warning: opendir(): SAFE MODE Restriction in effect. The script whose uid is 516 is not allowed to access /home/virtual/site13/fst/var/www/html/dj2be/wordpress/images/1 owned by uid 48 in /home/virtual/site13/fst/var/www/html/dj2be/wordpress/wp-content/plugins/exhibitimg/exhibit10f.php on line 398
    Warning: opendir(/home/virtual/site13/fst/var/www/html/dj2be/wordpress/images/1): failed to open dir: Success in /home/virtual/site13/fst/var/www/html/dj2be/wordpress/wp-content/plugins/exhibitimg/exhibit10f.php on line 398
    Is this my problem why I'm not able to get Exhibit to work for me?
    Greetings,
    Dj 2Be

  17. ringmaster
    Member
    Posted 9 years ago #

    Can you upload files with the built-in WordPress upload feature?
    It's possible that the safe mode restrictions that were put in place by your host will prevent you from creating/uploading files via the web at all.
    You might benefit from setting the chmod option in the Exhibit config file to something more write-friendly, like 0777. If that works, reduce it to something like 0664 and try again.

  18. Anonymous
    Unregistered
    Posted 9 years ago #

    I downloaded your new version (1.1b) and installed this and now it seems to work just fine for me! The only thing I notice, is that when I added an image to my post, I first have to save my post to view the image inside Exhibit. I assume this is normal.
    So thank you very much for helping me and thank you very much for making this awesome plugin!
    I'll put a link to your site on my blog!
    Greetings,
    Dj 2Be

  19. dikaryon
    Member
    Posted 9 years ago #

    I'm having two problems so far, one minor, one major.
    Minor one is that (in Safari, at least, the exhibit css makes my editing page look pretty screwy. Useable, but wierd.)
    Major one is that I can upload files, but I can't make thumbs or get anything to appear below the drop menu. Im assuming that uploaded images appear there with check boxes for selection, but that doesnt happen. Clicking the thumb button does nothing. (I get no error msgs either.)
    Do I have to set the location of GD on my server somewhere?
    Thanks in advance,
    Andrew

  20. valiot
    Member
    Posted 9 years ago #

    I'm getting the following error when uploading lots of images at once:
    Fatal error: Maximum execution time of 30 seconds exceeded in .../wp-content/plugins/exhibitimg/exhibit10f.php on line 638
    How do I increase this time?

  21. ringmaster
    Member
    Posted 9 years ago #

    @valiot:
    That may not be possible or recommended on your server. I would use FTP to upload a lot of images. It's more reliable and doesn't time out.
    @kincyc:
    Never heard of that. That's really wierd.

  22. adb
    Member
    Posted 9 years ago #

    I don't understand what I should change here (do I need to change anything?):
    In the exhibitimg directory find the file exhibit10.cfg. Modify
    the settings in this file to your preference. Verify that your
    use_chmod and use_chmod_dir values are set appropriately for your
    server.

    I also get the following error:
    Current directory: /
    Warning: mkdir(/home/mysite/public_html/images): Permission denied in /home/mysite/public_html/wp-content/plugins/exhibitimg/exhibit10f.php on line 473
    '/home/mysite/public_html/images' is not a valid directory on this server. Check your image directory settings in Exhibit.
    You may need to create a user directory before you can use the file picker.

  23. adb
    Member
    Posted 9 years ago #

    can someone help?

  24. Anonymous
    Unregistered
    Posted 9 years ago #

    Nice plugin!
    I would like to be able to write my posts like this:
    blah, blah blah!
    <thumbnail with link to full size photo here>
    more blah, blah blah!
    <next thumbnail with link to full size photo here>
    more blah, blah blah!
    <next thumbnail with link to full size photo here>
    and no thumbnails at the bottom...
    Is this possible and if not, where would I go in the code to make the mods?
    Thanks,
    R

  25. Anonymous
    Unregistered
    Posted 9 years ago #

    Oh, and BTW... It sure would be helpful if there were a flowchart of Exhibit showing how it intersects with WP. Is there such a thing and is it shareable?

  26. Anonymous
    Unregistered
    Posted 9 years ago #

    Exhibit didn't work at me. it complained that the directory images is missing. I had to adjust the following things:
    Under upload options I had to set a directory to upload e.g. wordpress/images (wordpress is the folder in my web directory I installed wordpress) or you create another directory but adjust the variable imagedir (at me line 9) in the file exhibit10.cfg (usually placed under wordpress/wp_content/plugins/exhibitimg/) to this directory.
    The directory images does not exist, you have to create it with right 777.
    If you have done this and want to create a subdirectory in the images directory I got the error "... wrong parameter count for mkdir ..." or something like this.
    I adjusted in line 572 under wordpress/wp-content/plugins/exhibitimg/exhibit10f.php the call mkdir($mk) to mkdir($mk, 0777)
    This solved also this problem.
    I used the version of exhibit which was the latest on the 3rd November.

  27. shadowmason
    Member
    Posted 8 years ago #

    Hello--

    I just downloaded this plug-in Exhibit... but I can't find any instructions to load it. I am guessing it goes into the plug-in folder. Can anyone tell me what to do after that? Thanks.

  28. bk
    Member
    Posted 8 years ago #

    May I please see a sample? Anyone could post it, please.
    The original sample site seems to be down.

Topic Closed

This topic has been closed to new replies.

About this Topic