WordPress.org

Ready to get started?Download WordPress

Forums

Exhibit 1.0c Photo Gallery Plugin (88 posts)

  1. ringmaster
    Member
    Posted 10 years ago #

    My Exhibit photo gallery plugin for WordPress has reached version 1.0c!
    New features:

    • Image upload
    • Directory creation
    • Paginated thumbnails
    • Add single images
    • Resample uploaded full-sized images

    It retains features of the prior versions, including:

    • Automatic thumbnail creation
    • Popup full-sized images
    • Per-post override display settings
    • Other good stuff

    Download here.
    Sample site here.

  2. Anonymous
    Unregistered
    Posted 10 years ago #

    oh, it's a great plugin, but I can't find the upload/create dir stuff? am I stupid & tired? :D

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    Is there a way to have sub-directories created automatically for each author? Then restrict the dir view to the authors own directory?

  4. ringmaster
    Member
    Posted 10 years ago #

    lstelie: The thumbnail issue has to do with the exhibit.css file. Copy the css file from your public blog to your test blog and the previews should look the same.
    mufflonen The upload and create stuff is in the right-side div that contains the files with little pictures. You must have a user level high enough to have upload permissions in order to see the upload/create links. This is set somewhere in the main WP Options, and usually applies to the default WP Upload page.
    Be sure that your chmod permissions have a 0 in front of them if they're octal. The problem with chmod settings is that I can't test them because I do not have access to a Linux server on which I can run this. Is it possible that they need to be in text? Like '0664'?
    The server's ability or inability to create the directories and files is undoubtably related to the server's/your permissions on the image directory.
    Anonymous: There is not currently a way to create and restrict user directories like this. It's a good idea, though.

  5. Anonymous
    Unregistered
    Posted 10 years ago #

    Ok. I'm a blog NEWBIE. I have WP installed on my server (Fuitadnet/Fantastico did it). How do I add this Hack? Is there any instructions posted how to add this to WordPress? I downloaded 1.0c and no help file. Do I just upload these files?

  6. chad
    Member
    Posted 10 years ago #

    For restricting upload directories I've tried creating a directory for each registered user's nick name and changing the imagedir variable in the exhibit10.cfg file to imagedir = the_author_nickname(), but that doesn't seem to want to work. Any suggestions for a similar quick little hack?

  7. Anonymous
    Unregistered
    Posted 10 years ago #

    After installing this release of Exhibit I have a problem that continues... Whne I click the links: [Create Directory], [Upload], or [rebuild all] I get in return a Not Found error in the window. Looking closer I noticed that the path to the exhibit10.php file was wrong in the link that was created by Exhibit. I was bummed.
    The fix?
    Replace all references of 'SCRIPT_NAME' with 'SCRIPT_URL' in the file exhibit10.php. All seems to be working like it shoudl now.
    BTW - Groovy program!

  8. ringmaster
    Member
    Posted 10 years ago #

    I should really include some instructions in the install of this thing somewhere very clear. I think at the top of every file in the archive it says "look at exhibit10.php for instructions". Maybe I missed a file. Anyhow...
    Installation Instructions
    Look in exhibit10.php in the archive for installation instructions. Do not simply drop all of these files into your plugin directory.
    chad: Nice try. That sort of thing probably won't work until next revision. When the page that reads the directory executes, it does not have access to the standard WordPress variables.
    Anonymous: Thanks for the tip. I didn't realize this would be a problem. I can include a check for this in the next release. IIS and my copy of Apache don't omit SCRIPT_NAME. What server are you using?

  9. mufflonen
    Member
    Posted 10 years ago #

    I found the solution for the problem with "create dir/upload" didn't show up - I had image upload permissions set to 10 and I my user (I'm admin) was a ten - but when I changed permission for uploading to 9 (that is, one below my level), it worked! great - except for the chmod stuff :)
    the chmod thing doesn't work with neither 0664 or 664 but I'll try a little bit more...

  10. perler
    Member
    Posted 10 years ago #

    ok, i installed it, can upload pictures, they even appear on the right side of the exhibit box in "advanced editing" - but i can neither create thumbs (pressing the link just does nothing) nor can i add the directory to the left side of the box.
    the webserver's error log doesn't spit out anything when pressing "Add current directory".
    all this with 1.0c and the wordpress mingus from sourceforge, virgin installation..
    PAT

  11. ringmaster
    Member
    Posted 10 years ago #

    perler: You might not have appropriate permissions on the web server so that you can create files in your image directory.
    It also sounds like there's some kind of browser issue here. Usually Exhibit reports an error of some kind when something doesn't work. What exactly happens when you click the Add Directory button? Does the page reload? If there are no thumbnails for the images in the selected directory (thumbnails must be in a subdirectory "t" of that directory, or named "thumb-filename.jpg" in the same directory) Exhibit will add no images - this is expected. You must have thumbnails already.
    My suggestion is to use FTP to create a "t" directory with thumbnails of a couple of the images to see if that works. Be sure that your server has GD installed for PHP, which is a requirement for automatically making thumbnails.
    Sorry if this is a lot of info, but hopefully it gives you something to try. :)

  12. perler
    Member
    Posted 10 years ago #

    ok, the thumbs problem i solved by creating a directory "t" by hand..
    afterwards, strangely, the "add current directory" worked too (maybe it was a permission thing although i set all files to ".apacheuser" and chmodded it to g+w)
    what i missed was, that i can click onto the small picture icons on to the left of the filename. maybe you should put a around them, so that the cursor changes to the usual "hand"..
    thanks for your help,
    PAT

  13. lstelie
    Member
    Posted 10 years ago #

    @ringmaster
    lstelie: The thumbnail issue has to do with the exhibit.css file. Copy the css file from your public blog to your test blog and the previews should look the same.
    I'm stupid I didn't check the css file.
    Last one has a lot of commented lines, is there specific reason for that ?

  14. ringmaster
    Member
    Posted 10 years ago #

    No, they're not of great significance. Uncommenting and using them instead of any that are there already would certainly provide a different appearance for the images.

  15. Anonymous
    Unregistered
    Posted 10 years ago #

    I managed to get this installed. I try and upload a file, and it uploads no problem, but... There's always a but, when it starts to do the thumbnail stuff, I get errors. Then when I FTP in, I can't delete the T folder, or the parent folder.... My wordpress is in my root folder if this makes a difference. Here's a sample of the first two errors (many many more).
    kr8.gif uploaded successfully, 54k bytes.
    Warning: imagecreatefromjpeg(): gd-jpeg: JPEG library reports unrecoverable error: in /home/website/public_html/wp-content/plugins/exhibit10.php on line 1489
    Warning: imagecreatefromjpeg(): '/home/droiddep/public_html/images/engine/kr8.gif' is not a valid JPEG file in /home/website/public_html/wp-content/plugins/exhibit10.php on line 1489

  16. Anonymous
    Unregistered
    Posted 10 years ago #

    How can I have preview image(s) display as large thumbnails for one post, and as horizontal list of smaller thumbnails for other posts? Just like on the vexme.com demo site.
    Thanks and good work, as usual :)

  17. ringmaster
    Member
    Posted 10 years ago #

    To get your preview images to display differently for different posts, use the exhibit post comment: < !--exhibit:preview_class=someclass-->
    You must define .someclass in your exhibit.css file so that the image appears differently than the default. For example, if your default styling displays small thumbnails, then .someclass should set the style so that the preview images are large.
    The bottom line is that you need to tweak the CSS in exhibit.css to your liking.
    welsper: Exhibit could fill the height/width tags for the image, but the server-side processing required would be dependent on how you wanted to implement it. If you simply wanted a static setting of height and width, that's pretty easy. If you wanted it to look at the file and fill in the actual dimensions of the image, that takes a little more doing.
    Either way, you would need to change Exhibit source code (and not mere configurations) to accomplish this.

  18. Anonymous
    Unregistered
    Posted 10 years ago #

    <str>ringmaster</str>--- I'm running in a Ensim hosted environment. Running Linux, Apache, etc. Ensim ver 3.7 I believe.

    After installing this release of Exhibit I have a problem that continues... Whne I click the links: [Create Directory], [Upload], or [rebuild all] I get in return a Not Found error in the window. Looking closer I noticed that the path to the exhibit10.php file was wrong in the link that was created by Exhibit. I was bummed.
    The fix?
    Replace all references of 'SCRIPT_NAME' with 'SCRIPT_URL' in the file exhibit10.php. All seems to be working like it shoudl now.
    BTW - Groovy program!

  19. welsper
    Member
    Posted 10 years ago #

    >> If you wanted it to look at the file and fill in the actual dimensions of the image, that takes a little more doing.
    Ok, I wanted the width and height tags for when I show the full image inline. I ended up doing this:
    Right before
    $imagetag = preg_replace('|IMGSRC|', $imageurl, $exc->full_image_display);
    Add
    $image_size = getimagesize($imageurl);
    $imagetag = preg_replace('|IMGWIDTH|', $image_size[0], $imagetag);
    $imagetag = preg_replace('|IMGHEIGHT|', $image_size[1], $imagetag);

    Then you have available the two tags for full_image_display.

  20. Anonymous
    Unregistered
    Posted 10 years ago #

    I downloaded Exhibit 1.0c. I have 1.2 WP. I followed instructions in the exhibit10.php file:
    I changed the value of changeme.
    I copied exhibit10.php, exhibitimg directory, exhibit10.cfg to the wp-content/plugins folder.
    I copied exhibit.css and exhibit_full.php to wp directory (not the plugins folder).
    I verified my server has gd loaded.
    I added the do_action() line to wp-admin/edit-form-advanced.php
    I enabled the Exhibit plugin (I have other plugins running just fine).
    I have a folder in wp called images and a subfolder called t. The results:
    When I click on anything from the drop-down, it adds the comments. Three images I uploaded into /images just sit there. Nothing happens. I tried several different browsers. Here's a screen shot.
    For the heck of it, I clicked create directory, which prompts a JS popup in which I enter a name. It gives me the following:
    Warning: mkdir(/home/meryland/public_html/wp/images/test): Permission denied in /home/site/public_html/wp/wp-content/plugins/exhibit10.php on line 1459
    When clicking upload:
    Warning: copy(/home/site/public_html/wp/images/wp-exhibit.gif): failed to open stream: Permission denied in /home/site/public_html/wp/wp-content/plugins/exhibit10.php on line 1576
    The above two don't surprise me as it is probably a chmod issue... but I already have an existing folder with images in it, which is what the above screen shot is based on.
    When clicking make - nothing happens.
    Did I forget something else?
    Best and TIA,
    Meryl

  21. welsper
    Member
    Posted 10 years ago #

    Anon, you need to click on the images themselves or the "ADD CURRENT DIRECTORY" button to add the images. The drop down is just how to display those in your post.
    I would set the chmod correctly in your .cfg file though. I set it incorrectly at first (forgot the first 0), then had a fun time recovering the permissions.

  22. Anonymous
    Unregistered
    Posted 10 years ago #

    welsper, thanks for the quick reply. The chmod is set to 0644. Thumbnails set to 1. I went into the control panel and set the image and t folders to 755 even since 644 didn't seem to be working. Can't click on the image file names or icon at all. This is the latest error:
    Warning: is_dir(): Stat failed for /home/site/public_html/wp/images/IMG_1500.JPG (errno=13 - Permission denied) in /home/site/public_html/wp/wp-content/plugins/exhibit10.php on line 876
    Warning: is_file(): Stat failed for /home/site/public_html/wp/images/t/IMG_1500.JPG (errno=13 - Permission denied) in /home/site/public_html/wp/wp-content/plugins/exhibit10.php on line 893
    Warning: is_file(): Stat failed for /home/site/public_html/wp/images/thumb-IMG_1500.JPG (errno=13 - Permission denied) in /home/site/public_html/wp/wp-content/plugins/exhibit10.php on line 897

  23. Anonymous
    Unregistered
    Posted 10 years ago #

    Finally got it! Got the answer from one of the responses above. Saw the image and t folders needed to be 777 not 755 or 644. Changed those and ta-da. Thank you. You guys are awesome especially the plugin creator. Kudos.

  24. ringmaster
    Member
    Posted 10 years ago #

    777 probably isn't the best permission setting security-wise. You might try 664 instead of 644. There is no reason to give execute permissions to your image directories, especially since you're letting the web server write uploaded files there.
    The important number to set is the middle one, which controls group permissions. You want your group permissions (which would include the web server and ftp users) to be read+write.
    Man, I remember my Linux/Ensim days... I'm glad those are over, even if I look back on them fondly.
    Cool beans, welsper. I might add that and the EXIF functions to the next release. (I really dig your anime/manga site, BTW!)

  25. welsper
    Member
    Posted 10 years ago #

    ring, thanks for visiting my site. :) Also have another question: I noticed that when I add an entire directory, the images don't get added alphabetically. What determines the ordering of images?
    muff, you need root access to reclaim permissions. Login as root and use chown. If you don't have root access, you have to ask someone who does to do this for you. Exhibit works as user httpd, not under your user. So with permission 755, you have the "5" and not the "7".

  26. mufflonen
    Member
    Posted 10 years ago #

    yea, I know I have to ask my host to remove the pictures but for the future, it'd be better if the script could just give "me" enough permissions for deleting as well since lots of people don't have root access and would have to get help from their webhost everytime something was to be deleted. I know this is possible to do (through a search on google) with a php script but I don't know enough php to fix it.

  27. ringmaster
    Member
    Posted 10 years ago #

    Might it be helpful to change the group of the directory when it's created? You could add a chgrp command to Exhibit to enable this.
    Somewhere around line 1474 in the make_thumbnails function is the chmod command for the 't' folder. If you added a chgrp command there to set the permissions to the appropriate group, you might have better luck deleting the directory.
    If you get it to work, let me know how you did it, and I'll be sure to include it as a configuration option in the next release.

  28. ringmaster
    Member
    Posted 10 years ago #

    The images are ordered in the order they are added. If you add individual images (click the little picture next to the filename), you can control this to some extent. I think that the directory listing function sorts the files by filename, but when it adds them to the database table, it uses the natural file order. This might be by date. Not exactly sure. There currently isn't a method in exhibit to re-order the images. Maybe next release, since a couple of folks have now asked about it.

  29. Anonymous
    Unregistered
    Posted 10 years ago #

    I agree -- I don't like 777 as the permissions for the /image and /t folders. I went to play with them further. 644 and 664 don't work. 755, however, does work. That's the lowest setting I can make it work.
    Meryl

  30. mufflonen
    Member
    Posted 10 years ago #

    ok, I DID IT :D
    around line 1472 before the @mkdir - added umask(0000);
    line 1453 before $abspath - added umask(0000);
    this gives me permissions 777 on created subdir's & t-folders. doesn't have to be 777 of course, this was just a test to see if it was possible. it was! I can now delete created folders heh.
    this also works:
    @mkdir("{$path}/t",0777);

Topic Closed

This topic has been closed to new replies.

About this Topic