WordPress.org

Ready to get started?Download WordPress

Forums

All-in-One Event Calendar
excusion of "ai1ec_event" in the event detail url (8 posts)

  1. jankowalski
    Member
    Posted 1 year ago #

    it was resolved before in this topic http://wordpress.org/support/topic/plugin-all-in-one-event-calendar-excusion-of-ai1ec_event-in-the-event-detail-url?replies=13

    but the topic is close and in new version of calendar i do not fond the line 178

    : 'rewrite' => true

    wp-content/plugins/all-in-one-event-calendar/app/helper/class-ai1ec-app-helper.php
    line 178
    Change from: 'rewrite' => true,
    Change to: 'rewrite' => array( 'slug' => 'ai1ec_event' ),

    has anyone sucesfully rename slug in the newsest 1.10 version?

    http://wordpress.org/extend/plugins/all-in-one-event-calendar/

  2. Jaber Oumalik
    Member
    Posted 1 year ago #

    same issue here, i renamed the slug but it gave me the 404 error.

  3. Yoz
    Member
    Posted 1 year ago #

    me too. Nobody would have any idea?

  4. jankowalski
    Member
    Posted 1 year ago #

  5. bobby.noonan
    Member
    Posted 1 year ago #

    Same question here. I really want to get rid of "ai1ec_event"...Any luck so far?

  6. mindfeck
    Member
    Posted 1 year ago #

    Yes, it's in the = args for custom post type = section

    I changed that line to
    'rewrite' => array( 'slug' => 'event' ),

    Then I went to settings>permalinks and saved, and it worked.

  7. bobby.noonan
    Member
    Posted 1 year ago #

    I'm sorry...you you please explain further? I dont want to screw this up. Here is the code from class-ai1ec-app-helper.php:

    // =============================
    		// = args for custom post type =
    		// =============================
    		$args = array(
    			'labels'							=> $labels,
    			'public' 							=> true,
    			'publicly_queryable' 	=> true,
    			'show_ui' 						=> true,
    			'show_in_menu' 				=> true,
    			'query_var' 					=> true,
    			'rewrite' 						=> true,
    			'capability_type'			=> array( 'ai1ec_event', 'ai1ec_events' ),
    			'capabilities'        => array(
    				'read_post'               => 'read_ai1ec_event',
    				'edit_post'               => 'edit_ai1ec_event',
    				'edit_posts'              => 'edit_ai1ec_events',
    				'edit_others_posts'       => 'edit_others_ai1ec_events',
    				'edit_private_posts'      => 'edit_private_ai1ec_events',
    				'edit_published_posts'    => 'edit_published_ai1ec_events',
    				'delete_post'             => 'delete_ai1ec_event',
    				'delete_posts'            => 'delete_ai1ec_events',
    				'delete_others_posts'     => 'delete_others_ai1ec_events',
    				'delete_published_posts'  => 'delete_published_ai1ec_events',
    				'delete_private_posts'    => 'delete_private_ai1ec_events',
    				'publish_posts'           => 'publish_ai1ec_events',
    				'read_private_posts'      => 'read_private_ai1ec_events' ),
    			'has_archive' 				=> true,
    			'hierarchical' 				=> true,
    			'menu_position' 			=> 5,
    			'supports'						=> $supports,
    			'exclude_from_search' => $ai1ec_settings->exclude_from_search,
    		);
  8. Razz
    Member
    Posted 11 months ago #

    Got the following to work on AI1EC 1.10 Standard and WordPress 3.6 :

    Open wp-content/plugins/all-in-one-event-calendar/app/helper/class-ai1ec-app-helper.php. The line in question is line #198 and reads

    'rewrite' => true,

    If you have a hard time finding it, or you are not on AI1EC 1.10 Standard, search class-ai1ec-app-helper.php for "args for custom post type" (excluding quotation marks).

    In that section, change 'rewrite' => true,

    to

    'rewrite' => array( 'slug' => 'event'),

    You can replace 'event' to anything you want the permalink to be.

    Save this file and then log in as an administrator to your WordPress installation. Go to Settings > Permalinks. Change the permalink format to something other than what it currently is. Hit "Save Changes" and the page will reload with your new settings. Select your previous settings (the permalink structure that you prefer...any one will do) and hit "Save Changes".

    Your AI1EC links should now not have "ai1ec_events" in the address.

    However, mine does still have "instance_id" attached at the end...so if someone could help me out with that one, it would be much appreciated.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.