WordPress.org

Ready to get started?Download WordPress

Forums

WordPress File Monitor Plus
Exclusion paths (20 posts)

  1. patrickhealy
    Member
    Posted 1 year ago #

    For the life of me, I can't seem to get the "Dirs/Files To Ignore" feature to work. I use backupbuddy and don't need to see when a new file is saved to that directory.

    I have left the File Check Root as is on my hostgator server as /home/xxxxxxxx/public_html/mywebsite.com and there are a few BB directories that I wish to ignore.

    /wp-content/uploads/backupbuddy_backups/*
    /wp-content/uploads/backupbuddy_temp/*
    /wp-content/uploads/pb_backupbuddy/*
    /wp-content/uploads/backupbuddy*

    As you can see I added the wildcard after the directory to ensure all files are ignored. What am I doing wrong?

    Thanks for your help and patience. I am sure you get these questions all the time and I have read all of the entries and followed all of the advice to date but can't seem to get this sorted.

    http://wordpress.org/extend/plugins/wordpress-file-monitor-plus/

  2. patrickhealy
    Member
    Posted 1 year ago #

    hey, just wanted to give this a bump. I still can't figure out how to exclude paths with this plugin. Backupbuddy runs every day and this is the bulk of the notices it generates. Any help would really be appreciated.

  3. Scott Cariss
    Member
    Plugin Author

    Posted 1 year ago #

    Try the following rules:

    /home/xxxxxxxx/public_html/mywebsite.com/wp-content/uploads/backupbuddy_backups*

    /home/xxxxxxxx/public_html/mywebsite.com/wp-content/uploads/backupbuddy_temp*

    /home/xxxxxxxx/public_html/mywebsite.com/wp-content/uploads/pb_backupbuddy*

    /home/xxxxxxxx/public_html/mywebsite.com/wp-content/uploads/backupbuddy*

  4. patrickhealy
    Member
    Posted 1 year ago #

    Do I remove "/home/xxxxxxxx/public_html/mywebsite.com" from the File Check Root field? I would imagine if the plugin hits that first and then hits the threads I put in it would be confused.

  5. Scott Cariss
    Member
    Plugin Author

    Posted 1 year ago #

    Leave the file check root as it was.

    and try the rules as I suggested...

  6. patrickhealy
    Member
    Posted 1 year ago #

    No dice, just got a notification with nothing but files in the above paths listed.

  7. Scott Cariss
    Member
    Plugin Author

    Posted 1 year ago #

    Was the notification saying files were removed?

    If you add a directory to ignore then the next scan will say the files where removed, however the scan after that will be clear from any changes or additions to those areas.

  8. patrickhealy
    Member
    Posted 1 year ago #

    Nah, I have notifications in the added, changed, and removed section. I expect notifications when I update plugins (which is constant) but the BB directories, like the error logs, change daily. I don't know what I'm doing wrong.

  9. golan7m
    Member
    Posted 1 year ago #

    I'm second for this question. I tried different options, with and without slash, with or witout full server path... But I still get all reports.

  10. patrickhealy
    Member
    Posted 1 year ago #

    Just noticed this and I'm not sure if it will help but I'd rather error on the side of safety. When I try and change the default 'File Check Root' from what is there it keeps reverting it back to the default. I would think it wouldn't do that since the plugin is allowing you to change it and gives you the default (I suspect in case your change isn't working out).

  11. Scott Cariss
    Member
    Plugin Author

    Posted 1 year ago #

    File Check Root is changeable option. The only reason why it would revert back to the default setting is if what you entered failed validation.

    $sanitized_site_root = realpath( $input['site_root'] );
    if( is_dir( $sanitized_site_root ) && is_readable( $sanitized_site_root ) )
        $valid['site_root'] = $sanitized_site_root;
    else
        // Failed revert back to default
  12. patrickhealy
    Member
    Posted 1 year ago #

    I guess I'm trying paths that are not acceptable. I tried the root path of http://www.mysite.com/ I guess it wants paths on the server. I'm just trying whatever I can to make the exclusion paths work. For the life of me I can't see what's wrong on my end. Still getting emails with nothing but BackupBuddy results.

  13. Scott Cariss
    Member
    Plugin Author

    Posted 1 year ago #

    Please tell me what you currently have in File Check Root and I can recommend exactly what your exclude settings should be.

  14. patrickhealy
    Member
    Posted 1 year ago #

    You are such a good sport. Thanks. I have:

    /home/[myaccount]/public_html/[mydomain]

    no matter what I do to alter this it reverts back.

  15. Scott Cariss
    Member
    Plugin Author

    Posted 1 year ago #

    /home/[myaccount]/public_html/[mydomain]

    Ok to be clear the above file check root will check for files only on the website it is running. If the website at that path is sandboxed and can only read and write it's own files you wont be able to change the file check root further up the tree.

    You could try this path: /home/[myaccount]/public_html but if this reverts back to default then your website only has access to read to it's self.

    As for ignoring dirs try the following:

    /home/[myaccount]/public_html/[mydomain]/wp-content/uploads/backupbuddy_backups*
    /home/[myaccount]/public_html/[mydomain]/wp-content/uploads/backupbuddy_temp*
    /home/[myaccount]/public_html/[mydomain]/wp-content/uploads/pb_backupbuddy*
    /home/[myaccount]/public_html/[mydomain]/wp-content/uploads/backupbuddy*

    Make sure each entry is on their own line.

    If the above doesn't work try:

    /home/[myaccount]/public_html/[mydomain]/wp-content/uploads/backupbuddy_backups/*
    /home/[myaccount]/public_html/[mydomain]/wp-content/uploads/backupbuddy_temp/*
    /home/[myaccount]/public_html/[mydomain]/wp-content/uploads/pb_backupbuddy/*
    /home/[myaccount]/public_html/[mydomain]/wp-content/uploads/backupbuddy/*

    If this still doesn't work then something with your webhost config is a-miss. Possibly a function not available or not enabled.

  16. patrickhealy
    Member
    Posted 1 year ago #

    No dice. I've tried every variation of it. What could possibly need to be enabled on my hosts end? I use HostGator and they are really solid IMO. I really would like to use this plugin to monitor non-backup/plugin directories. Am I the only one that has run into this problem?

  17. Leigh
    Member
    Posted 1 year ago #

    I was having a similar problem, but I've edited my post since I just got it working, right now. This is the path that worked for me:

    /home/[myaccount]/website.org/wp-content/cache/*

    It seems that there did have to be a /* at the end for it to work for me.

  18. patrickhealy
    Member
    Posted 1 year ago #

    My recommendation is to uninstall this plugin. It clearly doesn't work -and never had for me. Install Better WP Security. That plugin has a feature that does what this one claims to and so much more. I've been so happy since I dumped this one.

  19. Scott Cariss
    Member
    Plugin Author

    Posted 1 year ago #

    @patrickhealy Sorry that you couldn't get it to work in your environment.

    I plan in a future release to alter the settings UI to enhance the exclusion system to make it more user friendly and more cross compatible with different hosting environments.

  20. Cultivate
    Member
    Posted 1 year ago #

    I too am having problems with the directories to ignore settings, nothing seems to work.
    Below are the links i have at the moment.

    The first one is a full folder, the second a text file which is used to cache tweets, this file is updated regularly so i receive emails every hour for that one file.

    /home/sites/[url]/public_html/_development/
    /home/sites/[url]/public_html/wp-content/themes/[theme_folder]/_/tweets/tweets.txt

    Is there anything i can try?

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic