WordPress.org

Ready to get started?Download WordPress

Forums

Google Language Translator
[resolved] Excerpts translate but full story does not (18 posts)

  1. BARBSDESK
    Member
    Posted 6 months ago #

    I'm new to wordpress and have a question.

    I have installed this wonderful plugin in the sidebar. It works great until one presses the "read more" link from the home page excerpts - it does not translate the full story on the new page.

    I read through all the support posts and believe putting the plugin on the header might fix this - open 'header.php' and then insert <?php echo do_shortcode ('[google-translator]'); ?> in the area where you want to add it.

    If so - could you tell me where exactly where in the header.php area I should add this code? I'm new to this and afraid of mucking it up.

    http://www.skumrocks.com is the site

    Many thanks.

    http://wordpress.org/plugins/google-language-translator/

  2. Rob Myrick
    Member
    Plugin Author

    Posted 6 months ago #

    Hi BARBSDESK,

    Yes are correct in your assumptions. The translator is not showing on your full post layouts, so it will not translate those pages.

    And yes, adding it to header.php will change this, since the header displays on all pages throughout your website.

    This might be just a little tricky, because you are displaying a hard-coded image as your header image. It would need to be positioned on top of that, with absolute positioning.

    Explaining this would be somewhat time consuming. I don't mind doing it for you, if you would allow me access to the site. You could simply create a new user and assign a password for me.

    I've been helping others with good success in this way.

    Let me know if I can help.

    Thanks! Rob

  3. BARBSDESK
    Member
    Posted 6 months ago #

    How do I contact you privately with that info?

  4. BARBSDESK
    Member
    Posted 6 months ago #

    You guys are great - but the boss is refusing permission and wanting me to figure it out. Great . . .

    Thanks so much for your time.

  5. Rob Myrick
    Member
    Plugin Author

    Posted 6 months ago #

    Hi BARBSDESK,

    I'm going to try and help here:

    1) Place Google Language Translator in your header.php file, directly after <div id="site-description">. Add it using this PHP code: <?php echo do_shortcode('[google-translator]'); ?>

    2) Then open your theme's style.css file, find these line of code, and add these styles to the following areas. Do not remove any of the current styles, just add the following to them (with the exception of line 526, where you will need to replace the existing margin with margin:0px) as shown below:

    On line 510:

    #site-title { top:0; left:0; }

    On line 526:

    #site-description { top:0; right:0; margin:0px; }

    Then let me know when you get to that step and I will instruct you further. Essentially, the next step will be that you have to remove the "clip" CSS property from site-description because that area is currently hiding underneath your header image.

    You will also need to navigate to Settings > General and remove the text from the "Site Description" box near the top of the page, since you will not want that text to show up on your website.

    I hope that helps - please report back here and let us know how it goes!

    Rob

  6. BARBSDESK
    Member
    Posted 6 months ago #

    YAY!

    Rob, you are my Internet Angel or fairy godfather or whatever - you are a good man.

    Thank you so very much for taking the time to help.

    I am going to do it - and I'll let you know how it turns out (either from the coffee shop or the unemployment line).

  7. BARBSDESK
    Member
    Posted 6 months ago #

    Is this (bolded section)the correct place in my header.php file?

    <h1 id="site-title"><span>" title="<?php echo esc_attr( get_bloginfo( 'name', 'display' ) ); ?>" rel="home"><?php bloginfo( 'name' ); ?></span></h1>
    <h2 id="site-description"><?php bloginfo( 'description' ); ?></h2>

  8. Rob Myrick
    Member
    Plugin Author

    Posted 6 months ago #

    Yes, remove the<?php bloginfo('description'); ?> only, then replace with the PHP code I provided earlier to you. I'm glad you found it.

    Be prepared that you may experience some CSS issues (nothing major) until we work this out. I will get you up and running though - I promise.

    Thanks!

  9. BARBSDESK
    Member
    Posted 6 months ago #

    Rob - I'm going to stop until certain the site has a proper backup. First things first and all that.

  10. Rob Myrick
    Member
    Plugin Author

    Posted 5 months ago #

    Hi BARBSDESK, how are things working out on your website. Do you still need any assistance from me?

    I'll help out if needed.

    Thanks, Rob

  11. BARBSDESK
    Member
    Posted 5 months ago #

    Thank you Rob. You are so sweet! The website is great other than the excerpts not translating - I will let you know if anything changes. Thanks again

  12. Rob Myrick
    Member
    Plugin Author

    Posted 5 months ago #

    Hi BARBSDESK, they are translating for me, but you have to wait for like 15 seconds at most due to the page taking time to load. Take a look and let me know if that's the case for you too.

    The site looks good - keep up the great work. Rob

  13. Rob Myrick
    Member
    Plugin Author

    Posted 5 months ago #

    Barb, also there is a small configuration glitch with version 2.7. When you click the English flag, it's displaying single letters for your menu items. This seems to be a Google problem, although the actual configuration is coded inside my plugin, which makes it my fault too.

    You can fix this by reverting back to version 2.6 until the next update. If you delete the current plugin, and then re-install this one below, all your settings will be exactly the same, so no worries.

    http://wordpress.org/plugins/google-language-translator/developers/

    Let me know if that works!

  14. BARBSDESK
    Member
    Posted 5 months ago #

    I just checked - waited two minutes (in French) and the excerpt did not translate for me.

    I will install the 2.6 when I work on site later today - many thanks, Rob.

  15. BARBSDESK
    Member
    Posted 5 months ago #

    Rob
    I installed the 2.6 as you instructed. Thanks again.

  16. Rob Myrick
    Member
    Plugin Author

    Posted 5 months ago #

    Hi BARBSDESK, I can see that the translator seems to work properly now, although on my end it's taking forever to make a translation. I would try de-activating all of your plugins except for the translator, and then see if that helps.

    Then if it works for you, you can start activating the other plugins, one by one, until you see the translator break again.

    This will give you an idea of which one is causing a conflict. The Christmas thing you have looks really nice, although I can see it's based on Flash, which has a history of conflicting with the default translator even outside of my plugin.

    If you try this and the translator still does work fairly quickly (i.e. within 15 seconds), then let me know and I will think of another solution.

    Otherwise, already much better. thanks!

  17. Rob Myrick
    Member
    Plugin Author

    Posted 5 months ago #

    Hi BARBSDESK, are you happy with the translator on your site as of now? I will close this tomorrow if so, but please let me know if any issues arise that you still need help with.

    Thanks, Rob

  18. Rob Myrick
    Member
    Plugin Author

    Posted 5 months ago #

    Actually, the translator looks and works great, I will close this.

    Thanks!

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.