WordPress.org

Ready to get started?Download WordPress

Forums

Single Latest Posts Lite
[resolved] Excerpts not showing (7 posts)

  1. danny_wobble
    Member
    Posted 1 year ago #

    Hi,

    Thanks for the great shortcodes plugin. I am having a problem where the excerpts are not showing up once I have added the shortcode into my page.

    I have the plugin activated and plenty of content in my posts.

    Here is the shortcode I am using:

    [slposts title_only=false category=blog ]

    I can seem to find any problems with it, but I am only receiving "..." where the excerpts should be.

    Thanks in advance .

    Daniel.

    Also is there anyway I can use the shortcode in an actual .php file? I wish to have a small feed of recent blog posts on a custom page not in the sidebar or inserted via the standard wordpress page editor? Thanks.

    http://wordpress.org/extend/plugins/single-latest-posts-lite/

  2. Jose Luis SAYAGO
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Daniel,

    Thanks for your comment. Well to display excerpts you have to make sure of two things:

    1. Your excerpts do exist (when creating posts you need to fill the Excerpt field)
    2. If you are not using WordPress excerpts then you must set auto_excerpt=true parameter so the plugin generates an extract automatically from the post content.

    To use it as a function (embedded in a PHP file), you can do it like this: Single Latest Posts as a Function.

    Please, let me know if it works. Cheers.

  3. danny_wobble
    Member
    Posted 1 year ago #

    Hi Jose,

    Thank you very much for your reply. Could just ask, what is WordPress Excerpts, is that another plugin? Should I download/install it to make easier? Does off any other options?

    I will try the fix and code snippet you supplied(thanks for that) tonight and let you know.

    Also I don't think I ever saw an excerpts field in the add post/edit post page, do I have to activate it in order to see it?

    Regards, Daniel.

  4. Jose Luis SAYAGO
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Daniel,

    That's because excerpts are deactivated by default. I took a screenshot so you can see where you can activate them: Activate Excerpts once you check that option an Excerpt field will appear below the post content.

    If you have another question, don't hesitate to ask.

    Best regards.
    José Luis

  5. danny_wobble
    Member
    Posted 1 year ago #

    Hi Jose,

    Thanks again for your replies and screenshot, much appreciated. I will let you know if need and other help how your snippets and help works out.

    Regards, Daniel.

  6. danny_wobble
    Member
    Posted 1 year ago #

    Hi Jose,

    Everything you suggested/replied with has worked perfectly. Thank you for your help and a great plugin!

    Regards, Daniel.

  7. Jose Luis SAYAGO
    Member
    Plugin Author

    Posted 1 year ago #

    Hello Daniel,

    I'm glad it worked!, thanks for your feedback and comments. Have a good day.

    Best regards,
    José Luis.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic