WordPress.org

Ready to get started?Download WordPress

Forums

Excerpt not visible in Rss 2 feed (10 posts)

  1. Anonymous
    Unregistered
    Posted 10 years ago #

    Im putting a thumbnail in my excerpt and it works well on my archives page.
    For some reason the excerpt does not show in the Rss feed. Only the title link shows up. In my options page I have set Show Summary for the feed. When I look in my generated feed I see only blank space between de
    <description>blank</description> tag where I think the excerpt should be.
    Any ideas?
    thnx

  2. Anonymous
    Unregistered
    Posted 10 years ago #

    I didn`t find a solution yet altough I searched for it.
    Some help would be welcome...

  3. Anonymous
    Unregistered
    Posted 10 years ago #

    Thnx for the response but I`m a newbie.
    How do I allow tags?

  4. Beel
    Member
    Posted 10 years ago #

    Look for the_excerpt_rss in wp-rss2 and change the 2 to 1 - can't say what that will do to your feeds, and don't see the logic in having images in a description of a feed, but the image tag will show up.

  5. Anonymous
    Unregistered
    Posted 10 years ago #

    I changed it like this and the imagetag shows up but the thumbnail is still not visible if you look in the feedreader.
    I have nothing but images so I need a thumbnail. People don`t click that easily on a title compared to a thumbnail.
    This is the result I get:
    <description><img src="http:///wp-content/images/thumb-CRW_1537_RJ.jpg" alt="" /></description>

  6. Anonymous
    Unregistered
    Posted 10 years ago #

    I just want de thumnail displayed on my rss feed.
    Doesnt matter where as long its there.
    I thought it should by in the description but actually I have no clue.
    I just now, I put my thumb in the excerptfield in MT and it showed up automaticely in the rss-feed under the title. Now I just get a title.

  7. Beel
    Member
    Posted 10 years ago #

    from looking at your result above, you have to put the full link to your image not just "/wp-content...":
    http://whatever.com/wp-content...

  8. Anonymous
    Unregistered
    Posted 10 years ago #

    I just made the link shorter in the example.
    Im using the thumbnails on my archive page and it works perfect.
    They just don
    t show up in the rss...
    thanx for the help anyway

  9. ayteale
    Member
    Posted 10 years ago #

    I just found out how to do this....
    I too put a thumbnail in my exerpt field
    then in wp-rss2.php i found this...the_excerpt_rss(get_settings('rss_excerpt_length'), 2)...
    and like as stated above, change the two to 1
    set your Syndication Feeds in your Reading Options to Summary
    Thats it BUT, it did not seem to work until I unsubscribed from Net News Wire, then re-subscribed.
    Hope this helps!

  10. andymerrett
    Blocked
    Posted 9 years ago #

    Thanks I've been looking for that - just for interest the advantage to putting an image in the excerpted feed is that it allows you to include a visual element which may draw more people to your article, in an aggregator for example, but it doesn't publish the entire feed, therefore people can come to your site to read the entire article if they want to. That's why I want it, anyway.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags