WordPress.org

Ready to get started?Download WordPress

Forums

Excerpt Field disappeared (18 posts)

  1. cooperanet
    Member
    Posted 4 years ago #

    Hi,

    A strange bug happened in my WP admin.

    For one user of my website (with an admin profile), the excerpt field has disappeared in the Edit Post section.

    How could we retrieve it?

    Here are the plugins we use on this site:
    WPML multilingual
    Magic Fields
    TinyMCE Advanced

    Thanks for your help!

  2. esmi
    Forum Moderator
    Posted 4 years ago #

    Have you tried:

    - deactivating all plugins to see if this resolves the problem? If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the default theme to rule out any theme-related problems?

    - resetting the plugins folder by FTP or phpMyAdmin? Sometimes, an apparently inactive plugin can still cause problems.

  3. cooperanet
    Member
    Posted 4 years ago #

    I will try tomorrow all your advices and let you know asap. Thanks for your response.

  4. cooperanet
    Member
    Posted 4 years ago #

    Hi,

    I desactivated all plugins: always the bug.

    I switched to the default theme: always the bug.

    I reset the plugins folder: always the bug.

    Could it be a WP database crash?

    Any help would be greatly appreciated!

  5. esmi
    Forum Moderator
    Posted 4 years ago #

    If it's only happening for 1 user, that's highly unlikely. It's far more likely to be something related to the set up of his/her machine or browser.

  6. cooperanet
    Member
    Posted 4 years ago #

    Ok, so the problem happened with differents browsers and machines, so it should be a WP related problem.

    Whatever, I fixed it in an ugly way:

    I created a new user, deleted the "corrupted" user and reassigned posts to the new user. Argh!

  7. ctraganos
    Member
    Posted 4 years ago #

    I am having the same issue with a user.
    Have followed all those steps, no avail.

    In our office, it seems to be affecting user who are logged in the most.

    Any insight would be very helpful

  8. ctraganos
    Member
    Posted 4 years ago #

    Update: If I have the user log into WP from another computer, it resets the excerpt to work again (ie not be collapsed).

    This is very odd.

  9. Mark Jaquith
    WordPress Lead Dev
    Posted 4 years ago #

    I have a client that experiences this once every couple of weeks. He is a full-time blogger and is frequently logged in and active in the admin for an entire work day.

    It is limited to him, and I think it goes away with a full browser reset.

    I suspect that something is happening with the user settings cookie that is set in JavaScript. This may be getting corrupted in some way that WP thinks the user wants that field hidden.

    If it happens again, I'm going to spend some real time looking into it. But maybe this info will help someone discover the cause.

    If you experience the issue, Figure out a way to dump all of your cookies. DO NOT POST THE LOGIN OR ADMIN COOKIES, as that could give someone access to your site. We want the settings one.

  10. eileen.carpenter
    Member
    Posted 4 years ago #

    I recently ran into same problem as the original poster. With the excerpt, etc disappearing on one account, but making a new account brought it back.

    The someone pointed out the obvious to me. If this happen to you first check that these "missing" options are checked under screen options inside the invididual posts. It's at the top. It's sort of hidden, and I had totally forgotten it was there. Somehow excerpts, tags, post time, etc had all been unchecked. Maybe a cookie problem? Either way once they are rechecked they start working again. No need to create a new account.

  11. ryan76nz
    Member
    Posted 4 years ago #

    these "missing" options are checked under screen options inside the invididual posts. It's at the top.

    Where is it????? I can't find it. The top of where? The post?

  12. ryan76nz
    Member
    Posted 4 years ago #

    It's on the top right of the screen.

  13. ontargetpro
    Member
    Posted 3 years ago #

    Has anyone figured out a way to fix this?

  14. ontargetpro
    Member
    Posted 3 years ago #

    Oh, and "Excerpt" does not show up as an option to check on the Screen Options tag and it doesn't matter which user is logged in or which browser they use.

  15. ontargetpro
    Member
    Posted 3 years ago #

    In my case someone had taken Excerpt out, using custom_functions.

  16. Esfandiar
    Member
    Posted 3 years ago #

    Have you upgraded to 3.1? This happens to anyone who has upgraded. Basically it is trying to keep the screen neat so it removes field such as "author", "custom fields" and "excerpt".

    Here is the solution only if this has happened to you after upgrade: Click on one of your posts. Once you are in its screen, click the "screen options" at the top right hand side of the screen. It is pretty obvious after this. You can check the items that you want to be shown on the screen.

    If you have not upgraded to 3.1, you should be more specific about how it happened and I might be able to help.

    Hope this helped
    Regards,
    Esfandiar

  17. agtile
    Member
    Posted 3 years ago #

    Just like eileen pointed out open the "screen options" located o the very top right corner, next to help and log out button. make sure excerpt and whatever you want down there is checked.That's it.

  18. Catherine
    Member
    Posted 3 years ago #

    thank you, I was freaking out!

Topic Closed

This topic has been closed to new replies.

About this Topic