WordPress.org

Ready to get started?Download WordPress

Forums

Postie
[resolved] Excel / Word documents not attaching (4 posts)

  1. TuPhat
    Member
    Posted 1 year ago #

    I have a brand new install of WordPress 3.5.2 running on WAMP within Windows 2008 R2. I have installed Postie 1.5.15 and no other plugins.

    I am trying to emulate something I was playing around with a couple years ago, which was being able to post emails from my corporate Outlook clients (connecting to Exchange server 2003/2010), and posting emails to a WordPress blog via postie.

    Currently, postie is able to retrieve messages and post to the blog, but any email that has either a Word Document (doc or docx) or Excel Spreadsheet (xls or xlsx), the attachment doesn't appear at the bottom of the message. It doesn't get attached. I am able to successfully post PDF attachments in blog entries so it's somewhat working. When running postie debug, no debug txt appears when processing these emails with Doc/Excel attachments.

    I somewhat remember fighting with this a couple years ago and managed to get it to work. It may have something to do with postie retrieving messages to Exchange server. Or perhaps it's just my install.

    Can anyone help?

    http://wordpress.org/extend/plugins/postie/

  2. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    I do know there are some issues with Exchange Server and IMAP. Can you connect via POP?

    Otherwise try turning on debug logging and sending the log file to postie-help@devzing.com and reference this thread.
    http://postieplugin.com/enabling-debug-output/

  3. Wayne Allen
    Member
    Plugin Author

    Posted 1 year ago #

    Here is the smoking gun from the log file:

    [04-Jul-2013 14:01:14 UTC] Postie: postie_handle_upload: detected file type for Sample-document.docx is
    [04-Jul-2013 14:01:14 UTC] Postie: File type does not meet security guidelines. Try another.

    WordPress is not allowing you to attach .docx files. You might try a plugin like "More Mime Type Filters" which will give you control over which file types are allowed.

  4. TuPhat
    Member
    Posted 1 year ago #

    I followed through with your suggestions and found the problem.

    I believe the issue was that I'm running multi-site network. Under the Network Admin -> Settings -> Network Settings, there is a 'Upload file types' field where you can state which file extensions are allowed. It defaults to jpg jpeg png gif mp3 mov avi wmv midi mid pdf. I added doc docx xls and xlsx to the list of files and it started working. How wonderfully simple, if you know where to look! That was all the changes I had to make.

    I appreciate you looking into the issue and pointing me in the right direction!

    Cheers!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic