WordPress.org

Ready to get started?Download WordPress

Forums

Google Doc Embedder
[resolved] Excel only displays if force=1 (11 posts)

  1. paulod
    Member
    Posted 1 year ago #

    Hi there,

    I installed this plugin in my website and it only embeds the excel sheet if I include the force=1.

    Any ideas why this is happening? Same behavior in different browsers.

    Thanks in advance,

    Paulo

    http://wordpress.org/extend/plugins/google-document-embedder/

  2. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Hi Paulo,

    Most likely the issue is with the way your web host has configured your server. If you send a support request that will help me confirm it, since that would include your environment info and the document you're trying to embed.

    You can bypass the need to use this extra shortcode option if your server doesn't support the way the plugin verifies the file. In GDE Settings under Advanced Options/Plugin Behavior, check the box that says "Disable internal error checking." The document will be passed to the viewer without the plugin attempting to verify it first. (This is the same as setting "force=1" on everything, without having to type it.)

    In GDE 2.5 beta, the force= option has been removed. There did not seem to be a reason to have this on or off on a per-document basis, which is confusing in GDE 2.4.6. You can still disable internal error checking globally, though, if this configuration is necessary on your web server.

    Hope this helps.

  3. paulod
    Member
    Posted 1 year ago #

    Forgot to mention my website:

    http://www.montijobasket.com/equipa-sub18-masculina/

    Thanks in advance,

    Paulo

  4. k3davis
    Member
    Plugin Author

    Posted 1 year ago #

    Thanks for including the URL, I was able to test much more thoroughly.

    The issue (in this case, at least) seems to be a small bug in GDE 2.4.6 that fails file validation if the server does not return the standard content-length header. Your server is not returning the file size as part of the request, so it's mistakenly failing.

    This will be fixed in GDE 2.5 beta 2. In the meantime you can disable internal error checking (as described above), or if you'd like a patch instead for GDE 2.4.6, contact me directly via email at the email address in the GPL statement of gviewer.php.

  5. paulod
    Member
    Posted 1 year ago #

    Thanks... I'll do that and them test the 2.5 beta 2... ;-)

  6. jamestpereira
    Member
    Posted 10 months ago #

    Hi,
    I'm getting the error,

    "Oops!
    We are really sorry but the page you requested cannot be found.

    Please "Visit Home Page" and start again."

    I've followed the steps, above to remove error checking.

    The file is supposed to display on this page -http://lionreputation.jamestpereira.com/test-leadership-evaluation-3/#sthash.4ZvDxtDT.dpbs

    Thanks.

  7. k3davis
    Member
    Plugin Author

    Posted 10 months ago #

    James,

    Sorry for the slow response. You've resurrected a very old and not relevant thread...

    You're getting a 404 on a secure document. I've seen this a few times for reasons unknown, but I'm looking for some solutions. Unfortunately I can't reproduce the problem on my server which makes it more difficult.

    I'm assuming it works correctly if you use the standard default profile (not secure documents)? If you're willing to send me the literal URL of the document you're trying to privately embed (via the support tab in GDE Settings), I can see if I can reproduce the problem

    Kevin

  8. jamestpereira
    Member
    Posted 10 months ago #

    Thanks Kevin for the advise.

    I've tried embedding using the default profile and still it doesn't show.

    This is the URL of the file (it's excel) - http://lionreputation.jamestpereira.com/wp-content/uploads/2013/08/Leadership-Evaluation.xlsx

    Thanks.

  9. k3davis
    Member
    Plugin Author

    Posted 10 months ago #

    Hi James,

    I'm able to embed the linked document normally using the default profile (I didn't try secure documents).

    If you will submit a request using the support tab in GDE Settings I'll have a snapshot of your configuration and may be able to assist more specifically. But there are no inherent problems with the document itself and GDE.

    Thanks

    Kevin

  10. jamestpereira
    Member
    Posted 10 months ago #

    Hi Kevin,
    Got it to embed. I used the standard viewer rather than extended viewer and it worked.

    However, all excel properties have been stripped out and no input of data can be made. Is this the way it should work?

    Thanks.

  11. k3davis
    Member
    Plugin Author

    Posted 10 months ago #

    Hi James,

    As a viewer only, there are no editing facilities. It essentially converts your document into a series of flat image files, which every browser supports without need of plugins, but comes with all the limitations of that approach.

    Kevin

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.