WordPress.org

Ready to get started?Download WordPress

Forums

NextGEN Gallery
Everything turns into a real mess after 2.0 update (19 posts)

  1. fjavier
    Member
    Posted 1 year ago #

    Using custom templates and other extension plugins for gallery effects to support different gallery types under the previous version. And now after the 2.0 update all of the above gets overridden or deactivated, re-sizes thumbnails and messes all the galleries layout. I urge authors to facilitate a method to downgrade to the previous version since the update is not of any benefit for users with said customizations or until given the option to keep those in place. I don't think it is very convenient to make users to go thru the tremendous effort of re-applying/creating previous customizations after a major upgrade, specially if Nextgen is attempting to convince users to go for its new 'Pro version'

    Having not saved the previous package version. I will appreciate if anybody has any pointers on how to downgrade for now.

    Thanks in advance

    http://wordpress.org/plugins/nextgen-gallery/

  2. Stephen
    Member
    Posted 1 year ago #

    All I had to do was download the nextgen plugin folder as a backup before upgrading, upload the upgrade, and then test.

    I got
    Fatal error: Call to a member function get() on a non-object in /home/content/deletedactualpath/wordpress/wp-includes/query.php on line 27

    I am sure a plugin is conflicting, I have several 3rd party plugins activated that relate to nextgen that have become not compatible. Not concerned with upgrading at this time as I tried this on a site that I am revamping anyways.

    So after I did that test, I deleted the plugin folder for nextgen (2.0) , and then reuploaded the older version I had. My galleries still work the same.

  3. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @fjavier: Can you give some more detail on what kind of customizations you've done? We've worked hard to ensure we're honoring all existing Legacy short codes. But, yes, it's possible that if you are using NG extension plugins, if you've created your own custom gallery templates, or you've otherwise customized things dramatically, that you'll experience issues.

    As far as downgrading, normally, you could just grab the 1.9.13 files and reupload via FTP. Did you edit the actual plugin files during your customizations? That's the only concern I'd have. Otherwise, it should rollback fine by re-uploading 1.9.13.

    To keep you instance clean, if that matters, you can change the name of your current NGfolder, and just upload the entire 1.9.13 nextgen-gallery folder and just activate that version.

    @sboltonjr - We're expecting some plugin conflicts and some incompatibilities with some NextGEN extension plugins, but it's concerning that they caused an error on activation. If you learn any more about which if any plugins triggered that, can you let us know?

    [Signature removed by moderator per forum rules.]

  4. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    Hi, just wanted to add that we've published this tutorial on rolling back:

    http://www.nextgen-gallery.com/how-to-rollback-a-version/

  5. Stephen
    Member
    Posted 1 year ago #

    The only NextGEN 3rd party plugins I have activated right now are.

    NextGEN Gallery Voting version 2.2.1 (note this is an old version, haven't updated to 2.6 yet, edit - updating anyways, only never did because of modification of images I do. edit #2 - this plugin doesn't conflict, disabled and updated to 2.0, still same error, will see if Photoswipe is the issue.) - plugin by Shaun Alberts

    Photoswipe for NextGEN Gallery v 1.2.1 by Guillermo SeƱas

    I had also activated NextGEN Public Uploader v 1.7.1 by WebDevStudios but it is now disabled after initial NextGEN Gallery update.

    This does not include the 23 other active plugins I have on the site that don't relate to NextGEN. Redoing the website anyways so hoping not to use so many.

    May just retry updating with disabling one plugin at a time to see which one is causing it possibly, will report what I find when I do. If there is anything else I can do please let me know.

  6. Stephen
    Member
    Posted 1 year ago #

    Tested updating to 2.0, disabling each plugin one by one, neither are the cause of the error. This leaves me with a possible 23 other plugins conflicting with it, or the theme itself. I do know NextGEN 2.0 works just fine on another site of mine that doesn't have hardly any plugins activated. All on the same hosting.

    This is my list of plugins activated (which is motivating me right now to just work on the revamped site as this is a dumb list)

    AdRotate 3.7.4.3 (newer version is 3.8.6.2)
    Bad Behavior v2.2.14
    Brute Protect 0.9.8.4
    Business Directory Plugin 2.1.6.1
    Chat Lite 1.0.8
    Disqus Comment System 2.74
    Events Manger 5.4.4
    Exploit Scanner 1.3.3
    Google XML Sitemaps 3.2.9
    kStats Reloaded 0.7.4
    Quick Post Widget 1.9.1
    Share Buttons by AddtoAny 1.1.1
    Social Connect 0.9
    Social Media Widget 4.0.2
    Statpress Visitors 1.5.4
    Stop SOPA Widget 1.0 (probably should delete)
    Stop Spammer Registrations Plugin 4.3
    Under Construction 1.11
    Wordfence Security 3.8.1
    Wordpress Importer 0.6.1
    wp-konami 1.3.1
    WP FullCalendar 0.8.2
    WP Showtime 1.0
    WPtouch 1.9.4.2
  7. photocrati
    Member
    Plugin Author

    Posted 1 year ago #

    @sboltonjr - can you try deactivating Events Manager? I think I've seen one or two mentions of that one today already. The others I haven't heard anything about so it would be a guess.

  8. fjavier
    Member
    Posted 1 year ago #

    @photocrati : Thanks for your quick response!
    Under the former version the only NG extension plugins I have are:
    'prettyPhoto Media 1.4' and 'NextGEN Custom Fields 1.2.2'
    For the first one it just requires to replace the code for the Lightbox effect to use its own and for the second in order for the custom fields to work and to answer your question it requires the use of custom templates, those templates are placed under the theme's directory therefore the plugin core files are untouched.
    Furthermore I also use an additional custom album template-file for some of my Album > Gallery displays.
    Thanks for the downgrading tip.

  9. Stephen
    Member
    Posted 1 year ago #

    @photocrati: Still getting the error with the Events Manager deactivated. So it must be another plugin. I will try spending a little time deactivating a plugin one by one to see which it may be.

  10. BruceManning
    Member
    Posted 12 months ago #

    Thanks for the tutorial on how to rollback - I upgraded to 2.0 today and it screwed up my menu and frontpage slider. I'm using Elegant Themes alongside NextGEN, BackupBuddy, Shareaholic, TinyMCE Advanced, Page Links To, MapPress, Google Analytics, Cookie Control, and Antispam Bee.

    I feel it doesn't like Elegant Themes.

    Roll-back to previous version did the trick.. I'll just have to make a mental note not to upgrade next time around (tricky when you have 10+ WP sites!).

  11. fjavier
    Member
    Posted 12 months ago #

    Reworking issues under 2.0.. I just like to update that we recovered the 'prettyPhoto Media' ext. plugin effect by re-entering its code but since it kept loading the default css/scripts We also had to remove the paths under advanced settings and now it loads like before, however I noticed these changes are undoable.

    I re-saved each album/gallery without changing anything and that corrected some layout and text inconsistencies we were experiencing.

    As for the custom templates for a configuration such as: Custom album > custom galleries, template for album loads correctly but for gallery's needs to be set to override in the template selector.

    Otherwise totally incompatible with 'NextGEN Custom Fields' though

    Update.. It came to my attention that if we used html and specifically linked text into any Gallery - Alt/Title Text/Description item, it causes not to load effect and renders something like the following:
    <a href="http://myLinkedPage.com/">more info</a>" rel="prettyPhoto[pp_gal]" >

  12. DownHouse00
    Member
    Posted 12 months ago #

    What did you expect, after one week of the test.
    xaxa

    EPIC FAIL

  13. Stephen
    Member
    Posted 12 months ago #

    I just noticed that when updating to Nextgen, it removes my responsive navigation menu completely on one site, and on another it keeps the background of the navigation menu but makes the text disappear and the ability to drop down a menu goes away. Will be downgrading for now.

    Edit - to replicate the problem, just install the responsive theme from wordpress.org, and then activate the nextgen gallery to see the problem when minimizing your screen that the navigation bar goes away.

  14. photocrati
    Member
    Plugin Author

    Posted 12 months ago #

    @sboltonjr: Can you clarify which theme that is? You just said "the responsive theme." We'd like to keep track of theme conflicts.

    @BruceManning: Yes, it appears NextGEN Gallery conflicts somehow with the front page slider on Elegant Themes. This is the first I've heard on the menus, but I've heard of other menu conflicts. We'll update our notes on the Elegant Themes issues.

  15. Stephen
    Member
    Posted 12 months ago #

    Responsive by CyberChimps
    http://wordpress.org/themes/responsive

  16. Stephen
    Member
    Posted 11 months ago #

    @photocrati - In the latest beta has the disappearing navigation menu been figured out?

  17. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    @sboltonjr We just resolved that today, we are hoping to push out the next update sometime today or tomorrow. We're doing internal testing right now and hope to iron everything out before release. We deeply appreciate everyone's patience and understanding.

    --Becky

  18. Stephen
    Member
    Posted 11 months ago #

    @photocrati - That is good news. And I am sure everyone appreciates the hard work on the plugin, as we should be patient. Thank you.

  19. photocrati
    Member
    Plugin Author

    Posted 11 months ago #

    @sboltonjr - Thank you. :)

    -Becky

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic