WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
everything is broke (34 posts)

  1. kevquirk
    Member
    Posted 1 year ago #

    I just updated to the latest version and when I now try and go to the WordPress backend I get the following error:

    Fatal error : Uncaught exception 'FileOperationException' with message '/home/kevi7793/public_html/RefuGeeks/wp-content/w3tc-config/master.php could not be created, please run following command:
    chmod 777 /home/kevi7793/public_html/RefuGeeks/wp-content/w3tc-config' in /home/kevi7793/public_html/RefuGeeks/wp-content/plugins/w3-total-cache/inc/functions/activation.php:117 Stack trace: #0 /home/kevi7793/public_html/RefuGeeks/wp-content/plugins/w3-total-cache/lib/W3/ConfigWriter.php(159): w3_throw_on_write_error('/home/kevi7793/...') #1 /home/kevi7793/public_html/RefuGeeks/wp-content/plugins/w3-total-cache/lib/W3/ConfigWriter.php(421): W3_ConfigWriter->save() #2 /home/kevi7793/public_html/RefuGeeks/wp-content/plugins/w3-total-cache/inc/functions/update.php(58): W3_ConfigWriter->import_legacy_config_and_save() #3 /home/kevi7793/public_html/RefuGeeks/wp-content/plugins/w3-total-cache/lib/W3/Plugin/TotalCacheAdmin.php(298): w3_run_legacy_update() #4 /home/kevi7793/public in /home/kevi7793/public_html/RefuGeeks/wp-content/plugins/w3-total-cache/inc/functions/activation.php on line 117

    I've reset the permissions to the whole w3-cache folder to 777 and I'm still getting this error. My site is still up but I currently can't manage a thing at the back end. This is very urgent.

    Thanks

    Kev

    http://wordpress.org/extend/plugins/w3-total-cache/

  2. kevquirk
    Member
    Posted 1 year ago #

    Fixed it.

    Had to manually uploade a blank "master.php" file to /wp-content/w3tc-config/

    Not good though guys, I'd expect this kind of error to be tested before pushing an update. :(

  3. Frederick Townes
    Member
    Plugin Author

    Posted 1 year ago #

    You're right. This release has been used with customers and testers for over a year. Bugs happen, thanks for using W3TC. Another release is coming out today, sorry.

  4. sLa NGjI's
    Member
    Posted 1 year ago #

    Frederick Townes wrote:

    Another release is coming out today, sorry.

    W3 Total Cache 0.9.2.7? :eek

  5. Freedom Builders
    Member
    Posted 1 year ago #

    @Frederick Lot of stuff going on, I know. Some plugins I wait to update after initial release. Especially after the last major change with yours. I give yo credit for what you do with it. Kudos

  6. kevquirk
    Member
    Posted 1 year ago #

    No harm done, I just got panicked when nothing worked :)

    All fixed now - excellent plugin that I'd be lost without.

    Thanks guys.

  7. sylviaunlimited
    Member
    Posted 1 year ago #

    Glad I found this. Great plugin and looking forward for the new release. I just encountered the same lovely message and the back end is completely inaccessible. Not a coder so any advice on which files should be deleted from the cPanel or any fix would be much appreciated. Thanks much in advance.

  8. kevquirk
    Member
    Posted 1 year ago #

    Do you have FTP access to you server?

    If so, create a blank file and call it "master.php" (without quotes). Then, upload this file to your wordpress site in /wp-content/w3tc-config/

    So, to be clear, if your site is called abc.com you will probably have a folder on your server called abc or abc.com. Go into that folder, then wp-content, then w3tc-config and upload the master.php file there.

    Refresh and all should be ok :)

    Kev

  9. sylviaunlimited
    Member
    Posted 1 year ago #

    Thanks so much Kev! Worked like a charm.

  10. GPSuhrTest
    Member
    Posted 1 year ago #

    Hi there,

    I have the same problem...on two sites...
    A blank page after the login.....

    I tried this:

    Had to manually uploade a blank "master.php" file to /wp-content/w3tc-config/

    But nothing happens after that....
    What can I do to fix it?
    No programmer or hard core wordpresser here...:-(....

    Thanks in advance!!!
    K.

  11. sylviaunlimited
    Member
    Posted 1 year ago #

    GPSuhrTest:

    I had to refresh a couple of times. Hopefully that will help.

  12. kevquirk
    Member
    Posted 1 year ago #

    Have you definitely made the file extension .php? If you've done it in Windows then there is a likelihood that there is another file extension. For example, if you created it in Notepad then the file is probably called master.php.txt.

    I'd double check that first...

  13. Danielle
    Member
    Posted 1 year ago #

    ????????????

    Did I miss something ? What is broken ? It runs great on my site ... but I can confirm that it slows a little bit the site. For the rest I have no errors or bugs with this plugin

  14. GPSuhrTest
    Member
    Posted 1 year ago #

    I Kev and Silvia,

    thanks for your replies.

    Kev,
    I put it here /plugins/w3-total-cache/wp-content/w3tc
    is that correct? I couldn't find a "w3tc-config/" like you wrote and I used Taco for Mac to generate the .php file...
    I try again now:-)...

    Sylvia,
    just refresh the browser again and again?

    Thanks and cheers from Hamburg!
    K.

  15. GPSuhrTest
    Member
    Posted 1 year ago #

    Here is another file called wp-content/w3tc/min

    should I put the master.php into the /min maybe??
    Nothing works when I put it into the /w3tc and I don't have a "w3tc-config/" where you put it, Kev...

    Hmmmm....

  16. GPSuhrTest
    Member
    Posted 1 year ago #

    Can I just delete it from the server or what can I make to let my page run again?
    Site it available but the backend not....:-((((

  17. kevquirk
    Member
    Posted 1 year ago #

    You've put the master file in the wrong location. Read my post above for the path.

  18. kevquirk
    Member
    Posted 1 year ago #

    There's w3tc and w3tc-config. It needs to be the latter.

  19. GPSuhrTest
    Member
    Posted 1 year ago #

    Ahhhhh.....

    sorry....I supposed that it must be under /plugins etc.....
    Now I found it and I am back again:-))))..

    THANK YOU, KEV!

    What should I do now? Delete it completely or does it work from now on??

    Thanks so much!
    K.

  20. kevquirk
    Member
    Posted 1 year ago #

    Just leave it as it is now. Everything is fixed.

    No problem, happy to help :)

  21. GPSuhrTest
    Member
    Posted 1 year ago #

    GREAT HELP!

    Is it possible to explain in a few words what the master.php does now? I mean...is it a holy grail of wordpress programming?:-))

  22. kevquirk
    Member
    Posted 1 year ago #

    I don't know to be honest with you. Like you, I'm a WordPress user. I'm not one of the developers. I am technical however so myfix was just an educated guess really.

    I imagine that the master.php file is a configuration file for this plugin. It's not part of WordPress as a whole, just this plugin. The error I was getting was that the file couldn't be created and that the plugin doesn't have the correct permissions to create the file.

    I tried editing the permissions but this didn't work so I thought that creating the file and uploading myself should do the trick as creating the file and writing into it are two different permissions. This obviously worked. I've just checked the master.php file and there has been some version information written into the file as well as an "ID". So it looks like everything is working fine.

    Hope this answers some questions. The developers will probably be able to give a much better explanation that I have. :)

  23. acp73
    Member
    Posted 1 year ago #

    Spent the last week or more getting ver 9.2.5 to work & finally got it done about an hour ago and then saw an update to 9.2.6 & nearly poo'ed myself when the same happen!!! :)

    @Kev, thanks for the fix instructions! I think you might've saved my life (and Thomas for helping setup 9.2.5)

    For anybody else experiencing this after kev's fix I got the following error message:

    Warning: Cannot modify header information - headers already sent by (output started at /home/content/34/5314834/html/wp-content/w3tc-config/master.php:10) in /home/content/34/5314834/html/wp-includes/pluggable.php on line 876

    Refreshed a few times and back up!!!

    *insert sigh of relief here* ( and clean undies)

    ONLY PROBLEM IS: I LOST ALL MY PREVIOUS CDN SETTINGS ... back to the drawing board...and not sure where to now!

  24. Joseph Sileo
    Member
    Posted 1 year ago #

    My question is what functionality of the plugin is now broken until a new release is made.

  25. acp73
    Member
    Posted 1 year ago #

    @Joseph> everything seems fine once you upload the master.php file in kev's 2nd post up there. (don't forget to refresh a few times)

    Though I have to setup EVERYTHING from scratch. Not sure if anybody else had to as well...(?)

  26. Joseph Sileo
    Member
    Posted 1 year ago #

    That is what I was afraid of....serves me right to not make a config backup. IF anybody knows where the config data is hidden let us know. (In my defense it is a new site and configuring W3tc was about the only thing I did.) Good thing I didn't apply updates to m other sites yet.

  27. Joseph Sileo
    Member
    Posted 1 year ago #

    Not sure if anybody else also has this error, but I attempted to put in my CDN credentials. It said that my bucket didn't exist. Then I went to create a bucket and it said my bucket was taken.....which it is....by me....
    EDIT: Deleting my buckets and distributions then re-setting up corrected the problem....

  28. stillrivercreative
    Member
    Posted 1 year ago #

    UPDATE (after seeing early-thread fix re: uploading a blank master.php file)

    OMG - KEV, THANK YOU! Your fix worked perfectly.
    ________________________________________________________

    Updated, and it totally broke my site. I cannot log in to Dashboard AT ALL - here's what I get when I try (see below). Anyone know how to fix this? Thanks!

    Fatal error: Uncaught exception 'FileOperationException' with message '/home/stillriv/public_html/wp/wp-content/w3tc-config/master-admin.php
    blah, blah, blah...

  29. kevquirk
    Member
    Posted 1 year ago #

    Dude, read the thread! The answers are all there...

    Looking at your error, you need to make "master-admin.php", not "master.php".

  30. stillrivercreative
    Member
    Posted 1 year ago #

    > Dude, read the thread! The answers are all there...

    Yup. Many thanks.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.