WordPress.org

Ready to get started?Download WordPress

Forums

Every page is "Not Found" except for the home page (10 posts)

  1. petersandeen
    Member
    Posted 2 years ago #

    I just moved my blog from GoDaddy shared hosting to their Virtual Dedicated Server. I had a lot of work to even get the WordPress installed but finally managed to do it today with the help of some forum members here.

    Now the problem is that only the home page and all the dashboard functions work. All other pages (besides the home page) show an 404 Not Found error. "The requested document was not found on this server."

    What could be the problem?

    I've already tried the following:

    I've deactivated all plugins.
    I've "rebooted" the plugins folder.
    I've updated all plugins and wordpress itself.
    I've changed my theme to the standard themes.
    I've re-uploaded the wp-content files.
    I've deleted .htaccess (and renamed it to old.htaccess).
    I've also contacted GoDaddy customer service, but they insist it's not their problem...

    Earlier today the problem was slightly different. After loading the 404 page once, reloading the page resulted another error (internal server something no. 500).

    I checked the error_log file from the server, but I don't understand it. Here's the beginning of it...

    [Tue Jan 03 08:48:48 2012] [warn] RSA server certificate CommonName (CN)Parallels Panel' does NOT match server name!?
    [Tue Jan 03 08:48:49 2012] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
    [Tue Jan 03 10:56:54 2012] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
    [Tue Jan 03 10:56:54 2012] [warn] RSA server certificate CommonName (CN) `Parallels Panel' does NOT match server name!?
    [Tue Jan 03 11:15:47 2012] [error] [client 82.181.117.211] File does not exist: /var/www/vhosts/affectselling.com/httpdocs/comments
    [Tue Jan 03 11:21:39 2012] [error] [client 208.115.113.86] File does not exist: /var/www/vhosts/affectselling.com/httpdocs/robots.txt
    [Tue Jan 03 11:25:37 2012] [error] [client 66.249.68.175] File does not exist: /var/www/vhosts/affectselling.com/httpdocs/tag
    [Tue Jan 03 11:34:17 2012] [error] [client 66.249.68.153] File does not exist: /var/www/vhosts/affectselling.com/httpdocs/tag
    [Tue Jan 03 11:40:55 2012] [error] [client 209.85.224.91] File does not exist: /var/www/vhosts/affectselling.com/httpdocs/feed
    [Tue Jan 03 11:45:49 2012] [error] [client 82.181.117.211] File does not exist: /var/www/vhosts/affectselling.com/httpdocs/comments
    [Tue Jan 03 11:58:14 2012] [error] [client 208.115.113.86] File does not exist: /var/www/vhosts/affectselling.com/httpdocs/2011
    [Tue Jan 03 12:13:04 2012] [error] [client 209.85.224.96] File does not exist: /var/www/vhosts/affectselling.com/httpdocs/feed
    [Tue Jan 03 12:15:50 2012] [error] [client 82.181.117.211] File does not exist: /var/www/vhosts/affectselling.com/httpdocs/comments
    [Tue Jan 03 12:28:41 2012] [error] [client 82.181.117.211] File does not exist: /var/www/vhosts/affectselling.com/httpdocs/wp-admin
    [Tue Jan 03 12:28:43 2012] [error] [client 82.181.117.211] File does not exist: /var/www/vhosts/affectselling.com/httpdocs/wp-content, referer: http://affectselling.com/ `

    I'd be grateful if someone could help me out here. I'm not that tech-savvy so please explain things simply ;)

    Sincerely,
    Peter Sandeen

  2. James Edmonston
    Member
    Posted 2 years ago #

    Sounds like your .htaccess file isn't writeable (or doesn't even exist). Try making the root of your WordPress install writeable through your FTP (777 in chmod).

  3. petersandeen
    Member
    Posted 2 years ago #

    Thanks for a quick reply. But as I said I'm not really tech-savvy ;) Could you explain what that means and how do I do that? I do have FTP access, but where do I go from there? I think there's no .htaccess file there now.

    Sincerely,
    Peter Sandeen

  4. James Edmonston
    Member
    Posted 2 years ago #

    In your FTP browser, go to the folder that WordPress is installed at and look around for some permission settings (or, on the level above you may need to right click on the folder and go from there).

    You should understand what I mean with the 777 in chmod once you've got that far.

  5. petersandeen
    Member
    Posted 2 years ago #

    Thanks again for helping.

    WordPress is installed in the httpdocs folder. There are 4 folders: wp-admin, wp-content, wp-includes, and plesk-stat. There's also WordPress files like wp-app.php, wp-load.php, and wp-install.php. Other than the files that start with "wp" there are 5 files: favicon, index.php, licence.txt, and readme.html.

    The level above is the root folder (as far as I know, I might be wrong here, but the folder doesn't have a name, but just a "/" as its name). Other than the "httpdocs" folder there are 10 folders: anon_ftp, cgi-bin, conf, error_docs, etc, pd, private, statistics, subdomains, and web_users. Only two of these folders have anything in them: "anon_ftp" has 3 files: conf, incoming, and pub. And the "cgi-bin" folder has one file called "test".

    I changed the permissions of the folder "httpdocs" where wordpress is installed to 777. Its permissions is now "flcdmpe (0777)". But the problem is still the same. Only the home page loads. Here's the address if it helps: http://affectselling.com

    What did I do wrong? Or do I need to do something else as well?

    Sincerely,
    Peter Sandeen

  6. James Edmonston
    Member
    Posted 2 years ago #

    In WP Admin - go to the Permalinks settings and check if it says anything about not being able to write to .htaccess. Thanks.

  7. petersandeen
    Member
    Posted 2 years ago #

    Now that you mention it, I remember that it used to say something about it previously, but it doesn't anymore. So, no there's no mention about .htaccess now. And now there's an .htaccess file on the server.

    Thank you so much for helping me. What should I do next?

    Sincerely,
    Peter Sandeen

  8. James Edmonston
    Member
    Posted 2 years ago #

    The site seems to be working after those changes. :)

  9. petersandeen
    Member
    Posted 2 years ago #

    It started to work! I didn't do anything new. Maybe there was a latency before the permissions changed or something...

    Thank you, James, so much. I'm truly grateful :)

    Sincerely,
    Peter Sandeen

  10. James Edmonston
    Member
    Posted 2 years ago #

    The .htaccess might have been cached on your system.

    Glad it's working now.

Topic Closed

This topic has been closed to new replies.

About this Topic