WordPress.org

Ready to get started?Download WordPress

Forums

WP eCommerce
[resolved] WP E-Commerce - Every Page in Website Replaced With Product Page (13 posts)

  1. jpizzolato
    Member
    Posted 3 years ago #

    The WP E-Commerce Plugin Documentation is severely lacking. After loading the plugin every page I requested to see was replaced with the "Product Page" instead of the Page I requested. In the URL I can see the name of the page I requested BUT what was being displayed was the "Product Page" with the message "No Products Found". No documentation to say why this was happening.

    I de-activated the Plugin and then tested the website again. Now I couldn't get off of the Home Page, no matter what I requested from the menu.

    Then I deleted the Plugin altogether and still couldn't get off of the Home Page.

    Then I went back to see what files were still left around by the Plugin. I found the "Product Page" was still in existence. So I sent the "Product Page" to the Trash.

    I went back to re-test the website and NOW the website was again functioning.

    Don't understand how more than one million downloads have occurred and I experienced these bazaar problems. Didn't anyone else???

  2. cbayly
    Member
    Posted 3 years ago #

    I have had the same problem. I still want to use wp e-commerce so is there a different option to deleting the products page?

  3. blackcopy
    Member
    Posted 2 years ago #

    Thank god I found this post! I've just had the same problem and frankly I was horrified. This is a serious bug. Are there any solutions to this anywhere?

  4. jpizzolato
    Member
    Posted 2 years ago #

    Yes, it is a serious bug. I had hoped someone from the WP-eCommerce plugin would answer this post, but no one has.

    If you get an answer please let me know and I will do the same.

  5. shalderman
    Member
    Posted 2 years ago #

    Thank you!!! I had the same problem after installing (and immediately deactivating) that wp-ecommerce. So glad I found your post!

  6. Visser Labs
    Member
    Plugin Author

    Posted 2 years ago #

    jpizzolato, what Plugin version are you using; 3.8.6? I've never seen this before and I tinker with more than a few sites, if you can reproduce it on a test site the GetShopped.org team or I would be curious to see what's going on. :)

  7. Harry
    Member
    Posted 2 years ago #

    Re-post this Query in the Plugins and Hacks Forum, as this is where the Plugin Developers will most likely see your issue. Follow the direction in the info post, by for example, including the name of the plugin between [].

    Also, I'm currently working on a shop. When I get the problem figured out, I'll post the solution if someone from the Dev team doesn't get back to you before I do.

  8. jpizzolato
    Member
    Posted 2 years ago #

    I will post my original issue in the Plugins and Hacks Forum. Because I totally deleted the plugin I don't know what version I was using. However, I can tell you that I installed it from the Word Press Plugins on the dashboard only a few weeks ago, so the version should be the current version or whichever version offered from that download.

  9. kathorun
    Member
    Posted 2 years ago #

    @jpizzolato
    Thank you so much! You probably saved my computer from a deadly attack!

    I am really disappointed that this plugin isn't working as it was looking so good (until I tried my other pages!)

    Again, thank you sir!

  10. AmyZealand
    Member
    Posted 2 years ago #

    I found changing the permalink structure (and then changing it back if desired) fixed this very odd problem. It's mentioned on this thread: http://wordpress.org/support/topic/plugin-wp-e-commerce-pagination-for-products-not-working

    Good luck!
    Amy

  11. creativeawareness
    Member
    Posted 2 years ago #

    I have been having the same issue, once I installed the Plugin WP E-Commerce from Getshopped.org all of my pages were displaying the products page.

    To resolve this issue I went to Settings > Permalinks > Save Changes
    Do this action twice and refresh your pages and they should be back to normal.

  12. Justin Sainton
    Member
    Plugin Author

    Posted 2 years ago #

    Hi all,

    Glad we're all aware of two things -

    1) Changes to permalink structures require a permalinks flush. This can be accomplished by visiting the Permalinks page. Also, as some have commented - you will sometimes need to save the permalink structure twice.

    2) WPeC currently depends on the existence (and published status) of a few pages - the products page is one of them.

  13. mechy20
    Member
    Posted 2 years ago #

    Awesome, thanks a lot creativeawareness, I had this same issue, once I saved on the permalinks page, everything is working great. It was so annoying.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic