WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Every page, front and back end, are all blank (21 posts)

  1. joltlogan
    Member
    Posted 8 months ago #

    I honestly don't know if it's WordPress 3.5 because it was a website I built several months ago that I trained someone to manage. They are telling me the site is down and I checked. Every page is a blank white screen with no source code. Even the admin area. I did some research to see similar problems, but mostly they were issues form 3-6 years ago. Tried a few of their solutions including:

    1) Increasing the memory limit in wp-config (I've had to do this once already, it's at 256M)

    2) Renaming the plugins folder to plugins.hold via FTP do deactivate plugins without logging in

    3) Checked htaccess to see if there's any signs of hacking. All that's in there is this:

    # Use PHP5.4 Single php.ini as default
    AddHandler application/x-httpd-php54s .php
    
    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    
    # END WordPress

    Doesn't look too suspicious, but I could be wrong.

    I also ran it through Sucuri to see if it caught anything and it said it couldn't scan the page because there was nothing there (FTP says otherwise, all pages and content are still there). It also said "You've been hacked!" which is a possibility, but also could've been a ploy to get me to pay for their services cponsidering it had a nice big button that said "Sign up Here" right next to it.

    Website is http://www.theatre98.org.

    The website contained basic information, though it did have a lot of photos, and I fear the reason I had to increase the memory in the first place was because they were uploading hundreds of photos without resizing them which may have led to the memory issues.

    There's literally nothing there via browser. I've gone to individual pages and they are all blank, including admin pages. I can't do a thing for the front end. Some other suggestions were things like deleting all the files and reuploading them or making a database backup and removing WordPress all together and doing a fresh install. I'd like to avoid having to re-do anything, so I'm asking for some suggestions, and any help would be great!

    Thanks!

  2. graphical_force
    Member
    Posted 8 months ago #

    Honestly, if Surcuri is saying your site is hacked then it most likely is. If you don't have a backup of the site you may want to check out their services or someone like them.

  3. joltlogan
    Member
    Posted 8 months ago #

    I just checked the error logs and the most recent ones over the last few days are saying the following:

    http://pastebin.com/vdwYfuBQ

    Perhaps that will help. It's still saying the memory is exhausted and it started around the time the site apparently went down. It's the same problem I had a couple months back. Before it was tied to the All-In-One Event Calendar. This time, however, I disabled the plugins and it still did nothing. It's saying the most recent php errors are in wp-includes/option.php on line 149... line 149 says

    $alloptions[$o->option_name] = $o->option_value;

    For what it's worth. Could this memory thing be an issue again? If so, what's the cause for something like that? Bandwidth spikes? I'm not completely familiar with why memory usage issues occur or what the causes typically are for WordPress.

  4. SWalberg
    Member
    Posted 8 months ago #

    Sucuri is saying that it can't contact your site. My site, isithacked.com, can't either. Neither of our sites found your site on a blacklist.

    Something strange is going on here. My initial thoughts are that either a plugin or bad data is causing your site to loop endlessly, ending up with the OOM error. To prove that out, disable all the plugins and inspect your wp-options table. Are there any super huge options?

    SELECT option_id, option_name, length(option_value) FROM wp_options WHERE length(option_value) > 20000;

    will show you any options greater than 20k.

  5. joltlogan
    Member
    Posted 8 months ago #

    I've already disabled the plugins by following WordPress' directions by going into FTP and renaming the folder "plugins.hold" and now I'm in PHP My Admin but I'm not sure how to find what you're asking me to look for. The wp-options table has like 24,000 pages... is that normal?

    Not sure where I put that code you asked me to input in/find.

  6. esmi
    Forum Moderator
    Posted 8 months ago #

    I think you find it has 24,000 records - not pages.

  7. joltlogan
    Member
    Posted 8 months ago #

    PHP My Admin says it's showing 30 results per page and has the "Page Number" drop down selection box and the number it has me selecting at the end is 24,494. So it's giving me 30 records for every page, and it's telling me I have 24,494 pages with 30 records on each of those (except the last one).

  8. esmi
    Forum Moderator
    Posted 8 months ago #

    I think you need to have a word with your hosts about this...

  9. joltlogan
    Member
    Posted 8 months ago #

    Something tell me that's not good. For what it's worth, for the 10's of thousands of pages that it's telling me I have, the majority of them look like this:

    http://i.imgur.com/eK3Y3xq.jpg

  10. SWalberg
    Member
    Posted 8 months ago #

    That autoload column.. Anything that says "yes" gets loaded up on page load no matter if the plugin is loaded or not.

    If you feel like trusting a stranger,

    delete from wp_options where option_name like 'displayed_galleries_%' and autoload = 'yes'

    might help.

  11. joltlogan
    Member
    Posted 8 months ago #

    I'm a novice with PHP admin stuff...

    1) What would that do, exactly?

    2) Exactly how does one use that code to do what it needs to do? I have no clue what to do with it.

  12. SWalberg
    Member
    Posted 8 months ago #

    That deletes any row in the wp_option table where the option_name column starts with displayed_galleries and the autoload setting is set to "yes". Enter it in the SQL tab and hit go: https://www.monosnap.com/image/egcrfjNMtVZtiFVaG5aYstFcC.png.

    If you want to play it safe you can first test it out:

    select * from wp_options where option_name like 'displayed_galleries_%' and autoload = 'yes'

    which will show you the rows that would be deleted, and if you think it's ok, change the "select *" to "delete from".

    Just make sure you've got the where stuff intact!

    Sean

  13. joltlogan
    Member
    Posted 8 months ago #

    Ran that test code out, got this response:

    #1146 - Table 'theatrf1_wor1.wp_options' doesn't exist

  14. SWalberg
    Member
    Posted 8 months ago #

    I'm sorry, I should have looked at your phpMyAdmin graphic more closely. Your table is called "wrd_options"

    select * from wrd_options where option_name like 'displayed_galleries_%' and autoload = 'yes'
    delete from wrd_options where option_name like 'displayed_galleries_%' and autoload = 'yes'

  15. joltlogan
    Member
    Posted 8 months ago #

    Gotcha. Well, it brought up 244,000+ results. If I delete this what would that do, exactly? Like I said, super novice at this. Would this potentially fix the problem?

    Also, since it's tied to the galleries, I'm guessing, could the sheer volume of photos they added to their website without resizing them be the cause? They've got 21 galleries, most of them averaging 40-50 photos and all of them are in the 350KB-450KB range. So they're pushing something in the ballpark of 340MB of photos on their site alone, which apparently a lot of people look at.

  16. SWalberg
    Member
    Posted 8 months ago #

    http://wordpress.org/support/topic/wp_options-to-many-records?replies=15 has some discussion on it. Sounds like the options can be deleted as they'll be regenerated (those look like timestamps) Also looks like there's an upgrade to the plugin required to fix the underlying problem.

  17. joltlogan
    Member
    Posted 8 months ago #

    Duly noted, I'll look into that. Thanks!

    My hosting got back to me. I relayed to them all the stuff that's been talked about in here. They just told me to rename the htaccess file, plugin folder, and theme folder to see if it fixed the issue, which I've done all that already, but I humored them and did it again anyways, with no luck.

  18. SWalberg
    Member
    Posted 8 months ago #

    What's happening here is you've got a tonne of options set to autoload (plus other stuff). So when the page loads -- forget the theme or plugins -- it's building objects for every single one of those rows just in case some code later down the line might want to look at it. Eventually it runs out of memory it's allowed to allocate and you get the white screen.

  19. joltlogan
    Member
    Posted 8 months ago #

    Well I'll be. I'll give the deletion a go and see what happens!

  20. joltlogan
    Member
    Posted 8 months ago #

    IT'S BACK! Thank you so much, you're the man! Guess I need to upgrade the plugin if they've fixed it!

  21. joltlogan
    Member
    Posted 8 months ago #

    Also marking this as resolved!

Reply

You must log in to post.

About this Topic