WordPress.org

Ready to get started?Download WordPress

Forums

The Events Calendar
[resolved] Events page displays Home page after uninstalling (4 posts)

  1. joshdd
    Member
    Posted 1 year ago #

    I found this support post, exactly the same issue, but the solution in that case has not fixed my problem:
    http://wordpress.org/support/topic/plugin-the-events-calendar-events-displays-home-page-after-uninstalling

    So I installed the free version, I love it, but I've uninstalled it to test some other free event managers, mainly looking for one that adds the "recurring event" functionality for free.

    However, having deactivating and deleting it, my /events/ still redirects to the homepage.
    I tried this fix suggested in the topic I linked to above, this didn't work, so I deleted the page and recreated it, that also didn't work.
    There must be some remnants of the plugin left behind that is redirecting it, I just can't find it! I've also tried clearing my browser history (cache, cookies and history).

    Thanks, Josh.

    http://wordpress.org/extend/plugins/the-events-calendar/

  2. jonahcoyote
    Member
    Posted 1 year ago #

    Hi joshdd,

    You should not have an actual 'events' page to begin with, our plugin creates this page virtually (behind the scenes) automatically. So, be sure you have no pages with that slug and be sure to empty your trash too. WordPress still keeps a slug reserved even after it has been deleted but no permanently deleted. After that try clearing Permalinks again and that should do it.

    - Jonah

  3. joshdd
    Member
    Posted 1 year ago #

    I didn't know not to have an events page before I installed it when I installed it.
    I assumed that the plugin would ask me what I would like the slug to be for the events page not just create it in events (I already had events used for something else). Once I realised that the plugin was automatically using the events slug, I moved my events page to "agenda".
    Then when I decided to uninstall the plugin (because of it's lack of recurring event feature), I tried to move "agenda" back to "events". But the plugin had left a redirect behind so that events now just takes you to the homepage.

    But I've fixed it now.
    This was the solution:
    1. Open phpMyAdmin.
    2. Go to the options table in your wordpress database.
    3. Near the bottom of the options table will be rewrite rule for events page, delete it.

    Wollah, done. There were also several other entries left behind by this plugin which I deleted.

    Thanks though.

  4. jonahcoyote
    Member
    Posted 1 year ago #

    Hi joshdd,

    Glad to hear you figured it out! Let us know if you need anything else.

    Thanks,
    Jonah

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic