WordPress.org

Ready to get started?Download WordPress

Forums

Events Manager
[resolved] Events Manager Listing Page Problems (7 posts)

  1. Karlene814
    Member
    Posted 2 years ago #

    Hi,
    Great Plugin! I have 2 questions.
    1) On the events calendar listing page all I want to show is the date and time and the name of the event, but I get a "," showing up. I've been looking thru the code to find it and get rid of it but can't seem to find it. Can you help with that?

    2) Also, I have the same problem other are having with the dates showing up as dd/mm/yy where I'd rather have them show up as mm/dd/yy.
    I'm not understanding the fix for this. I'm rather new to CSS can any explain a little more in layman's terms.

    my site is http://www.hamlinstation.net
    Thanks for your help!

    http://wordpress.org/extend/plugins/events-manager/

  2. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    1) could be that you have some blank events, did you check your DB wp_em_events table? The first three events might be the culprit (try deleting them if they are aren't yours). or do all the events do this?

    2) this should be according to your WP_LANG settings in your wp-config.php file. we'll be adding better date formatting via our settings page in the coming weeks.

  3. Karlene814
    Member
    Posted 2 years ago #

    I was able to fix #1 in my question above - it was a matter of finding the coma in the the css for the the header and removing it.

    I'm still having problems with the date format of dd/mm/yy instead of mm/dd/yy.

    My WP Lang is set for default of English - meaning it is blank. I did some reading on it. I'm wondering if I should force it to be en_us. If so the codex says you also need an en_us.mo file and an .po file.
    I'm assuming that the .mo file is just a txt file? And it looks like the .po file is very complicated. Do you know where I can find the en_us.po file? And will this even help.

    My customer is quite adamant that the format be correct. Can you help me any further please.
    Thanks, Karlene

  4. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    If you set it to en_GB, it'd show the format you want. No extra po files needed, EM will just localize the dates according to your language/region

  5. Karlene814
    Member
    Posted 2 years ago #

    I set WPLANG to en_GB as you suggested. It still does not show dd/mm/yy. Any other ideas?
    And I also upgraded to the latest version.
    Thanks, Karlene

  6. Marcus
    NetWebLogic Support
    Plugin Author

    Posted 2 years ago #

    This solution works for everyone else..... maybe you're using a lanuage plugin that modifies your language setting?

    We'll also be adding more formatting options in the coming weeks so that the WPLANG isn't used, so you could wait for that as well.

  7. Karlene814
    Member
    Posted 2 years ago #

    I think I finally fixed the problem by playing around with the different date formats.
    In the EVENTS Format setting I used "Events - #F #d #Y"
    In the Date/Time formats setting I used - "F/d/Y"

    This makes everything come out in a format that is acceptable.
    ie: January/28/2012

    the wp_lang is set for en_GB

    I hope this helps someone.
    Thanks for the replies.
    Karlene

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic