WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] Events Calendar causing fatal error! (16 posts)

  1. striser
    Member
    Posted 6 years ago #

    I can't get Events Calendar installed!
    Every time I try to install it from the Plugin page I get the following fatal error:

    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /web/htdocs/www.mcturenum.com/home/wp/wp-content/plugins/events-calendar/ics/ICS_File.php on line 30

    I've installed several plugins (cforms II, DMSGuestbook, Find Us, NextGEN Gallery, StatPress, Subscribe2) and they all work fine, and I'm using the K2 theme.
    What should it be? Is there a solution available?
    Thank you all in advance!

    http://wordpress.org/extend/plugins/events-calendar/

  2. xleggs
    Member
    Posted 6 years ago #

    Me too. I was upgrading the plug-in- it seemed like the versions jumped a couple numbers.

  3. mantisreligiosa
    Member
    Posted 6 years ago #

    Same here. It looks like it is a bug in the code itself.

    I contacted Luke an told him there is a bug, so he can fix it soon i think.

  4. snumb130
    Member
    Posted 6 years ago #

    Sorry. I am looking into this. I believe it has problems working with less than PHP5. The parsing script was from someone else and I am looking through it to try and get this worked out. I will post solution as soon as I get it. I will post updates on my site feed.

  5. jeenie
    Member
    Posted 6 years ago #

    Cool, looking forward to it, as I've come across the same error. Thanks!

  6. codex1
    Member
    Posted 6 years ago #

    i got same error on my wp 2.3.2

    would like to fix it..

  7. smackaysmith
    Member
    Posted 6 years ago #

    Doesn't work on my CentOS 4.x (php4) but does work on my WAMP which uses php5.

    Both sites use WordPress 2.3.2.

  8. snumb130
    Member
    Posted 6 years ago #

    So I can check it properly, what version of the plugin are you using?

  9. striser
    Member
    Posted 6 years ago #

    Ok, now it works fine, thank you very much!

    Just one more question:
    I'm using the K2 theme, and I see that Events Calendar doesen't display neither in the sidebar nor in the dashboard if I use the K2 Sidebar Manager; otherwhise switching to the default WordPress Widgets makes everything work good: do you know why?

  10. snumb130
    Member
    Posted 6 years ago #

    K2 uses sidebar modules instead of widgets. When using the modules it reads from a different directory and therefore does not touch the widgets.

  11. striser
    Member
    Posted 6 years ago #

    Thanks again!

    Is there a way to use Events Calendar with the sidebar modules, or do I have to switch to Widgets?

  12. snumb130
    Member
    Posted 6 years ago #

    At the request of you (and many others) I added the option to use the events calendar a k2 sidebar module. The version can be downloaded now. It is version 5.7.10. If you are not using k2 you will not notice any difference

  13. striser
    Member
    Posted 6 years ago #

    I'm really sorry to bother you, but it still doesen't work with K2 Sidebar Manager:
    uploaded events-calendar-k2.php to the /wp-content/themes/k2/app/modules, plugin correctly enabled on plugin page, but, as usual, nothing displays neither in the sidebar nor in the dashboard.
    However, your plugin rocks, so keep up the good work, and don't mind if you can't fix this very small problem in the near future: I can still use it switching to WordPress Widgets.
    Thanks again for all of your hard work.

  14. snumb130
    Member
    Posted 6 years ago #

    No problem, a lot of people have asked for it. I just switched by blog to k2 to verify again and it is working on my end. If anyone else has k2 try it out and let me know if it is working.

  15. mokkie
    Member
    Posted 6 years ago #

    Hey, I just got the fatal error everyone (above) is mentioning. I downloaded the Calendar plugin today. The comments indicate that the problem had been resolved, but apparently, not? I'm using WP 2.3.1. (I have no idea what the K2 theme might be so I'd guess I'm not using it.) I'd love to use this plugin. What do I need to do to make it work?

  16. scully153
    Member
    Posted 6 years ago #

    Same here - I just downloaded the plugin and I'm getting a Fatal error on WP 2.3.3, no K2 theme. It seems like this plugin is exactly what I need, is it just incompatible with the new version?

Topic Closed

This topic has been closed to new replies.

About this Topic